Eclipse: List of TODO tags in Task view

Discussion in 'Java' started by veljovic@gmail.com, Dec 7, 2004.

  1. Guest

    Hi all,

    It seems that I cannot see any of the TODO tasks in my Tasks window. I
    probably disabled it somehow some time ago and now when I make // TODO
    comment it does not show in the Tasks list. I made sure that in
    Preferences->Java->Task Tags menu everything is setup correctly. TODO
    is a default tag.
    Please help if you know how to make my TODO tasks show in the Tasks
    window again.

    Thanks,
    Tzar
     
    , Dec 7, 2004
    #1
    1. Advertising

  2. On 07-12-2004 22:03, wrote:
    > Hi all,
    >
    > It seems that I cannot see any of the TODO tasks in my Tasks window. I
    > probably disabled it somehow some time ago and now when I make // TODO
    > comment it does not show in the Tasks list. I made sure that in
    > Preferences->Java->Task Tags menu everything is setup correctly. TODO
    > is a default tag.
    > Please help if you know how to make my TODO tasks show in the Tasks
    > window again.
    >
    > Thanks,
    > Tzar
    >

    Did you check the filter setting and the selected working set in the
    task view? Got me once...

    Paul.
     
    Paul van Rossem, Dec 7, 2004
    #2
    1. Advertising

  3. Tzar Guest

    I checked that. It looks fine.
    I think problem is when I enter a comment like // TODO it does not
    create a task icon on the left edge of the editor (after saving). If I
    manually click on the left edge and select Add Task then it does but
    for some reason it's not doing it for the // TODO comment.
    I tried it on couple of other machines and they work fine. It
    automatically creates a TODO task and it shows it in the Tasks View.

    One thing I have different on my machine is I have Lomboz plug-in
    installed. I am not sure if that could interfere.

    Tzar,

    Paul van Rossem wrote:
    > On 07-12-2004 22:03, wrote:
    > > Hi all,
    > >
    > > It seems that I cannot see any of the TODO tasks in my Tasks

    window. I
    > > probably disabled it somehow some time ago and now when I make //

    TODO
    > > comment it does not show in the Tasks list. I made sure that in
    > > Preferences->Java->Task Tags menu everything is setup correctly.

    TODO
    > > is a default tag.
    > > Please help if you know how to make my TODO tasks show in the Tasks
    > > window again.
    > >
    > > Thanks,
    > > Tzar
    > >

    > Did you check the filter setting and the selected working set in the
    > task view? Got me once...
    >
    > Paul.
     
    Tzar, Dec 7, 2004
    #3
  4. Guest

    , Dec 8, 2004
    #4
  5. Tzar wrote:

    > I think problem is when I enter a comment like // TODO it does not
    > create a task icon on the left edge of the editor (after saving). If I
    > manually click on the left edge and select Add Task then it does but
    > for some reason it's not doing it for the // TODO comment.
    > I tried it on couple of other machines and they work fine. It
    > automatically creates a TODO task and it shows it in the Tasks View.


    It seemed to me that this behavior of Eclipse 2 was omitted from Eclipse
    3, or at least not enabled by default. I last looked into when Eclipse
    3 was still prerelease, however, and I never fully characterized the
    problem.


    John Bollinger
     
    John C. Bollinger, Dec 8, 2004
    #5
  6. On 08-12-2004 14:55, John C. Bollinger wrote:
    > Tzar wrote:
    >
    >> I think problem is when I enter a comment like // TODO it does not
    >> create a task icon on the left edge of the editor (after saving). If I
    >> manually click on the left edge and select Add Task then it does but
    >> for some reason it's not doing it for the // TODO comment.
    >> I tried it on couple of other machines and they work fine. It
    >> automatically creates a TODO task and it shows it in the Tasks View.

    >
    >
    > It seemed to me that this behavior of Eclipse 2 was omitted from Eclipse
    > 3, or at least not enabled by default. I last looked into when Eclipse
    > 3 was still prerelease, however, and I never fully characterized the
    > problem.
    >
    >
    > John Bollinger
    >


    It still works for me. Eclipse 3.0 split the task tags (todo) and
    compiler errors into separate panes ("Tasks" and "Problems").
    And indeed todos must now be enabled in Window->Preferences
    ->Java->Task Tags. And, as said before, the Filter setting on the
    Task view must enable them. That's all I can find about it...

    Paul.
     
    Paul van Rossem, Dec 8, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Nathan Given
    Replies:
    3
    Views:
    20,067
    EddyParkinson
    Jul 16, 2010
  2. Replies:
    0
    Views:
    580
  3. Jimmy
    Replies:
    0
    Views:
    549
    Jimmy
    Mar 15, 2007
  4. Yasser Almeida Hernández

    TODO and FIXME tags

    Yasser Almeida Hernández, Nov 16, 2009, in forum: Python
    Replies:
    0
    Views:
    383
    Yasser Almeida Hernández
    Nov 16, 2009
  5. steven masala

    add a task to todo

    steven masala, Dec 5, 2005, in forum: Ruby
    Replies:
    2
    Views:
    156
    Jacob Fugal
    Dec 5, 2005
Loading...

Share This Page