Help... Just installed Visual Studio .Net 2003 and can't get samples to work

Discussion in 'ASP .Net' started by Mark, May 8, 2005.

  1. Mark

    Mark Guest

    Hi... I am new to this so appollogies if I am asking in the wrong place...
    If not could someone please point me in the right direction. This is driving
    me crazy, I only logged on to have a quick play and that was hours ago...

    I have just installed VS.net 2003 (full install) and have a couple of
    problems I expect these are common newbie problems). I am running widows xp
    sp2 and sql server 2000...

    1) I can't access the on-line "quickstart" tutorials. The folders were
    created succesfully on my IIS but all I get is "you are not authorised etc.
    I am logged on with full admin rights etc.

    2) When I try and run the samples (e.g. the datagrid) I get the following
    error

    "An unhandled exception of type 'system.data.sqlclient.sqlexception'
    occurred in system.data.dll additional information: system error"

    I can connect just fine from the same machine to the server via Access and
    have even tried copying the .exe to the server (with the connection string
    set to local etc.) but nothng works :mad:(

    Thanks very much :mad:)

    Mark
    Mark, May 8, 2005
    #1
    1. Advertising

  2. can you display a simple page? start with that first. open a form, drop a
    component on the form and run it into debug mode. If the form shows up
    correctly, then you can eliminate vs studio installation errors and focus on
    permissions errors with sql.

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc, Amazon.com etc
    "Mark" <> wrote in message
    news:1Ycfe.14514$%...
    > Hi... I am new to this so appollogies if I am asking in the wrong place...
    > If not could someone please point me in the right direction. This is
    > driving me crazy, I only logged on to have a quick play and that was hours
    > ago...
    >
    > I have just installed VS.net 2003 (full install) and have a couple of
    > problems I expect these are common newbie problems). I am running widows
    > xp sp2 and sql server 2000...
    >
    > 1) I can't access the on-line "quickstart" tutorials. The folders were
    > created succesfully on my IIS but all I get is "you are not authorised
    > etc. I am logged on with full admin rights etc.
    >
    > 2) When I try and run the samples (e.g. the datagrid) I get the following
    > error
    >
    > "An unhandled exception of type 'system.data.sqlclient.sqlexception'
    > occurred in system.data.dll additional information: system error"
    >
    > I can connect just fine from the same machine to the server via Access and
    > have even tried copying the .exe to the server (with the connection string
    > set to local etc.) but nothng works :mad:(
    >
    > Thanks very much :mad:)
    >
    > Mark
    >
    Alvin Bruney [MVP - ASP.NET], May 8, 2005
    #2
    1. Advertising

  3. Mark

    Mark Guest

    Alvin

    Thanks for that... I can create forms etc. and am able to access sql server
    through ADO. I think you are right about the permissions. I would very much
    like to get the samples working but I'm not sure where to start. I am logged
    on with full admins etc. I would also like to be able to view the quickstart
    pages that were installed on my IIS...

    Shouldn't this sort of thing be easy bearing in mind I installed everything
    from microsoft (while logged on with full admins) according to the
    instructions?

    Thanks again

    Mark
    Mark, May 8, 2005
    #3
  4. It doesn't matter what you log in as, ASP.NET runs under a separate account,
    definitely not the admin account. First, make sure IIS is running and setup
    correctly. it doesn't hurt to run an aspnetregiis -c (not sure of the
    option) at the command prompt to make sure things are warm and fuzzy for
    ASP.NET. Then point your browser to http://localhost/localstart.asp if that
    works, then you should be able to modify the path to quickstart to have it
    work. You would need the correct extension since IIS wouldn't know what
    quickstart is so something like http://localhost/quickstart.aspx should
    suffice.

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc, Amazon.com etc
    "Mark" <> wrote in message
    news:4ntfe.22360$...
    > Alvin
    >
    > Thanks for that... I can create forms etc. and am able to access sql
    > server through ADO. I think you are right about the permissions. I would
    > very much like to get the samples working but I'm not sure where to start.
    > I am logged on with full admins etc. I would also like to be able to view
    > the quickstart pages that were installed on my IIS...
    >
    > Shouldn't this sort of thing be easy bearing in mind I installed
    > everything from microsoft (while logged on with full admins) according to
    > the instructions?
    >
    > Thanks again
    >
    > Mark
    >
    Alvin Bruney [MVP - ASP.NET], May 11, 2005
    #4
  5. Mark

    Mark Guest

    Alvin

    Thanks for that. The IIS install was / is running fine. It turned out that
    the directorys where the quickstart stuff was installed didn't have adequate
    permissions. The set-up is never connected to the outside world so I just
    cheated and granted pretty much everything to everyone :mad:)

    Thanks again

    Mark


    "Alvin Bruney [MVP - ASP.NET]" <www.lulu.com/owc> wrote in message
    news:...
    > It doesn't matter what you log in as, ASP.NET runs under a separate
    > account, definitely not the admin account. First, make sure IIS is running
    > and setup correctly. it doesn't hurt to run an aspnetregiis -c (not sure
    > of the option) at the command prompt to make sure things are warm and
    > fuzzy for ASP.NET. Then point your browser to
    > http://localhost/localstart.asp if that works, then you should be able to
    > modify the path to quickstart to have it work. You would need the correct
    > extension since IIS wouldn't know what quickstart is so something like
    > http://localhost/quickstart.aspx should suffice.
    >
    > --
    > Regards,
    > Alvin Bruney - ASP.NET MVP
    >
    > [Shameless Author Plug]
    > The Microsoft Office Web Components Black Book with .NET
    > Now available @ www.lulu.com/owc, Amazon.com etc
    > "Mark" <> wrote in message
    > news:4ntfe.22360$...
    Mark, May 12, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wh
    Replies:
    2
    Views:
    509
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  2. Robert Rotstein
    Replies:
    1
    Views:
    489
    Scott M.
    Dec 31, 2005
  3. rockdale
    Replies:
    1
    Views:
    602
    Juan T. Llibre
    Aug 23, 2006
  4. xman
    Replies:
    0
    Views:
    491
  5. xman
    Replies:
    1
    Views:
    594
    Victor Bazarov
    Aug 17, 2005
Loading...

Share This Page