How to make the local modelsim.ini takes effect?

Discussion in 'VHDL' started by rxjwg98@gmail.com, Sep 7, 2006.

  1. Guest

    Hi,
    I am new to VHDL and the software Xilinx webpack and modelsim XE III
    6.1e. On my laptop, if I change the source text font, it will take
    effect for the next time modelsim launch. On my desktop, it is always
    the original font the next time launch. I also notice that the recent
    project and recent file selection cannot remember my past execute
    history. The difference between these two computer is my laptop
    computer loads a local copy of modelsim.ini on the path

    C:\Modeltech_xe_starter\win32xoem/../modelsim.ini

    My desktop doesn't do that. Could you tell me how to solve this
    problem? Thank you very much.
     
    , Sep 7, 2006
    #1
    1. Advertising

  2. Don Ansley Guest

    wrote:
    > Hi,
    > I am new to VHDL and the software Xilinx webpack and modelsim XE III
    > 6.1e. On my laptop, if I change the source text font, it will take
    > effect for the next time modelsim launch. On my desktop, it is always
    > the original font the next time launch. I also notice that the recent
    > project and recent file selection cannot remember my past execute
    > history. The difference between these two computer is my laptop
    > computer loads a local copy of modelsim.ini on the path
    >
    > C:\Modeltech_xe_starter\win32xoem/../modelsim.ini
    >
    > My desktop doesn't do that. Could you tell me how to solve this
    > problem? Thank you very much.


    ModelSim will look for an environment variable %MODELSIM% then it will
    look in the current working directory for modelsim.ini, then it will
    look in it's directory. As I have several versions of ModelSim on my
    PC I us a bat file to set up the version and to point to the
    appropriate modelsim.ini file. This bat file also calls vsim and
    passes the command line for the specific test architecture, etc. that I
    wish to use:

    set MODEL=D:\Modeltech_6.1e\win32
    set MODELSIM=[your path]\modelsim.ini
    %MODEL%\vsim %SimCmd%

    I also save the preferences [ TOOLS->save preferences ] which creates
    the modelsim.tcl file in the same path as modelsim.ini. This file
    should restore any non-default settings each time.
     
    Don Ansley, Sep 7, 2006
    #2
    1. Advertising

  3. Amal Guest

    Modelsim started using registry for storing preferences on Windows PCs.
    If you change the preferences using the "Tools | Preferences" menu it
    will be set in stone (registry) :))

    Or you can take a look here:
    HKEY_CURRENT_USER\Software\Model Technology Incorporated\ModeSim

    -- Amal
     
    Amal, Sep 7, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MJones
    Replies:
    5
    Views:
    436
    Hywel Jenkins
    Jan 21, 2005
  2. pertheli
    Replies:
    8
    Views:
    365
    Nils Petter Vaskinn
    Dec 3, 2003
  3. Charlie123

    which css class takes effect?

    Charlie123, May 25, 2007, in forum: HTML and CSS
    Replies:
    0
    Views:
    324
    Charlie123
    May 25, 2007
  4. Rémi
    Replies:
    0
    Views:
    202
    Rémi
    Jul 9, 2011
  5. eenteghadi

    Probelm with modelsim.ini

    eenteghadi, Jul 12, 2012, in forum: VHDL
    Replies:
    0
    Views:
    664
    eenteghadi
    Jul 12, 2012
Loading...

Share This Page