HTTP error 404 when calling ASP page.

Discussion in 'ASP General' started by Brian Rupert, Feb 8, 2004.

  1. Brian Rupert

    Brian Rupert Guest

    I have 2 sites on my Windows Server 2003/ISA/IIS machine.
    One of the sites works fine and has 'default.htm' for the
    default document. The other site returns an 'HTTP error
    404' and has a 'default.asp' for the default document.
    Aside from that they appear to be configured the same.
    Any ideas?

    Thanks,
    Brian
    Brian Rupert, Feb 8, 2004
    #1
    1. Advertising

  2. Turn off 'show friendly http errors' in Tools / Internet Options / Advanced.
    Or, view the page in Netscape / Firebird / Mozilla / Opera.

    --
    Aaron Bertrand
    SQL Server MVP
    http://www.aspfaq.com/




    "Brian Rupert" <> wrote in message
    news:c6ee01c3ee94$8016e360$...
    > I have 2 sites on my Windows Server 2003/ISA/IIS machine.
    > One of the sites works fine and has 'default.htm' for the
    > default document. The other site returns an 'HTTP error
    > 404' and has a 'default.asp' for the default document.
    > Aside from that they appear to be configured the same.
    > Any ideas?
    >
    > Thanks,
    > Brian
    Aaron Bertrand [MVP], Feb 8, 2004
    #2
    1. Advertising

  3. Brian Rupert

    Brian Rupert Guest

    Aaron,
    Thanks for your reply, however, I tried your suggestion
    with no success.
    More specifically, the error reads "File or directory not
    found". However, I can clearly browse to it from Windows
    Explorer.

    Brian



    >-----Original Message-----
    >Turn off 'show friendly http errors' in Tools / Internet

    Options / Advanced.
    >Or, view the page in Netscape / Firebird / Mozilla /

    Opera.
    >
    >--
    >Aaron Bertrand
    >SQL Server MVP
    >http://www.aspfaq.com/
    >
    >
    >
    >
    >"Brian Rupert" <>

    wrote in message
    >news:c6ee01c3ee94$8016e360$...
    >> I have 2 sites on my Windows Server 2003/ISA/IIS

    machine.
    >> One of the sites works fine and has 'default.htm' for

    the
    >> default document. The other site returns an 'HTTP error
    >> 404' and has a 'default.asp' for the default document.
    >> Aside from that they appear to be configured the same.
    >> Any ideas?
    >>
    >> Thanks,
    >> Brian

    >
    >
    >.
    >
    Brian Rupert, Feb 9, 2004
    #3
  4. > Thanks for your reply, however, I tried your suggestion
    > with no success.
    > More specifically, the error reads "File or directory not
    > found". However, I can clearly browse to it from Windows
    > Explorer.


    Oh, ok. Are you typing "C:\path\file.asp" into your browser? Don't do
    that! http://localhost/file.asp

    If that's not the issue, you're going to have to provide more information
    (unless you want random guesses).

    --
    Aaron Bertrand
    SQL Server MVP
    http://www.aspfaq.com/
    Aaron Bertrand [MVP], Feb 9, 2004
    #4
  5. Brian Rupert

    Ray at Guest

    Do you have ASP enabled? I know that in IIS 6, you have to enable something
    before any ASP pages will execute. As I have yet to experience IIS 6, I
    cannot comment on where this setting is or what it may be called. But, this
    comes up pretty often in m.p.inetserver.iis, I believe, so you may find a
    PAQ in there with the answer.

    --

    Ray at home
    Microsoft ASP MVP


    "Brian Rupert" <> wrote in message
    news:d0ee01c3eea7$7bbf0050$...
    > Aaron,
    > Thanks for your reply, however, I tried your suggestion
    > with no success.
    > More specifically, the error reads "File or directory not
    > found". However, I can clearly browse to it from Windows
    > Explorer.
    >
    > Brian
    >
    >
    >
    > >-----Original Message-----
    > >Turn off 'show friendly http errors' in Tools / Internet

    > Options / Advanced.
    > >Or, view the page in Netscape / Firebird / Mozilla /

    > Opera.
    > >
    > >--
    > >Aaron Bertrand
    > >SQL Server MVP
    > >http://www.aspfaq.com/
    > >
    > >
    > >
    > >
    > >"Brian Rupert" <>

    > wrote in message
    > >news:c6ee01c3ee94$8016e360$...
    > >> I have 2 sites on my Windows Server 2003/ISA/IIS

    > machine.
    > >> One of the sites works fine and has 'default.htm' for

    > the
    > >> default document. The other site returns an 'HTTP error
    > >> 404' and has a 'default.asp' for the default document.
    > >> Aside from that they appear to be configured the same.
    > >> Any ideas?
    > >>
    > >> Thanks,
    > >> Brian

    > >
    > >
    > >.
    > >
    Ray at, Feb 9, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jonathan Folland
    Replies:
    2
    Views:
    1,612
    Jonathan Folland
    Mar 17, 2005
  2. Steven Hines
    Replies:
    2
    Views:
    1,102
    Steven Hines
    Feb 5, 2004
  3. searcher1234

    How To Send Http/1.0 404 Not Found Error Page In C

    searcher1234, Oct 31, 2004, in forum: C Programming
    Replies:
    1
    Views:
    621
    Karthik Kumar
    Oct 31, 2004
  4. Replies:
    1
    Views:
    167
    Tiago Halm
    Dec 6, 2007
  5. Andreas.Bretl
    Replies:
    0
    Views:
    143
    Andreas.Bretl
    May 18, 2004
Loading...

Share This Page