IDLE not working under windows.....

Discussion in 'Python' started by Fuzzyman, Jan 6, 2004.

  1. Fuzzyman

    Fuzzyman Guest

    At least I've been advised by the 'officials' (in response to my bug
    report at sourceforge) to only start IDLE with the '-n' argument
    because sub-processes 'don't work' on windows.

    In fact the problem is that IDLE currently only uses a single socket
    and so hangs if you try to open a second version of the shell.....
    Which means so long as I rememebr to only open one shell it works
    fine...... So I have two file associations for IDLE now......

    The trouble is that opening without a subprocess means that if you
    edit any modules you have to close IDLE and reload the main program to
    test changes in the module... which is mightily a pain.....

    So IDLE on windoze is very much a work in progress...............

    Fuzzy
    Fuzzyman, Jan 6, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ollie
    Replies:
    0
    Views:
    366
    Ollie
    Oct 2, 2003
  2. Fuzzyman
    Replies:
    0
    Views:
    344
    Fuzzyman
    Dec 22, 2003
  3. Jonathan Polley

    Unable to run IDLE Under Windows

    Jonathan Polley, Feb 7, 2005, in forum: Python
    Replies:
    8
    Views:
    806
  4. Bo Peng
    Replies:
    1
    Views:
    465
    Bo Peng
    Jan 9, 2006
  5. Matthias Sommer
    Replies:
    0
    Views:
    320
    Matthias Sommer
    May 28, 2008
Loading...

Share This Page