JavaT Runtime Environment Version Selection

Discussion in 'Java' started by Richard Maher, May 14, 2012.

  1. On May 10, 11:36 am, Richard Maher <> wrote:
    > Hi,
    >
    > In my Applet's <object> tag I specify the "java_sersion" parameter as
    > follows: -
    >
    > <param name="java_version" value="1.7+">
    >
    > I'd expected this clause to trigger the Java plugin (as long as after
    > 1.6_10) to throw/report some sort of excption if there was now Java
    > version available >= 1.7. Unfortunately, the Java plugin (1.6_31 in
    > this case) seems very happy just to attempt to run the Applet on that
    > version and ignore the later version requirement.
    >
    > Is this to be expected?
    >
    > Have I specified the parameter incorrectly?
    >
    > I thought it might just have been crappy Safari on OS/X but it also
    > limps-on or completely ignores this parameter on FireFox and Windows.
    >
    > I would like the Applet load to fail if there is no 1.7+ version; how
    > can I achieve this?
    >
    > Cheers Richard Maher



    On May 11, 10:27 pm, Richard Maher <> wrote:
    > Honestly, here's a very simple applet: -
    >
    > <HTML>
    > <HEAD>
    > <TITLE> A Simple Program </TITLE>
    > </HEAD>
    > <BODY>
    >
    > Here is the output of my program:
    > <APPLET CODE="HelloWorld.class" WIDTH=150 HEIGHT=25>
    > <param name="java_version" value="1.4*">
    > </APPLET>
    > </BODY>
    > </HTML>
    >
    > import java.awt.Graphics;
    > public class HelloWorld extends java.applet.Applet {
    >
    > public void init() {
    > resize(150,25);
    > }
    > public void paint(Graphics g) {
    > g.drawString("Hello world!", 50, 25);
    > }
    >
    > }
    >
    > Can *anyone* show me *any version* or Java +/- browser wher the
    > "java_version" applet parameter does *anything* other than take up
    > space? APPLET, OBJECT, or EMBED tags.
    >
    > What is supposed to hapen when I ask/demand 7.0 and 7.0 does not
    > exists???
    >
    > Is larry pre-occupied on courtroom battles to concentrate on something
    > that should be so simple?
    >
    > Cheers Richard Maher


    Once again, for those following at home, I did some more tests and realized
    that if you have multiple JREs available then you can choose a specific
    lower version that is on your system (For example if you have 1.7 and 1.6
    available and some applet is already running in 1.7 then yours can elect to
    run in a 1.6 JVM and it will be duly created) The problem, as I see it, is
    that if you elect/mandate a JRE version that is not available then the new
    plugin will just opt for limp-home mode and gives you the latest version
    available, push it up the flag-pole and see if anyone salutes, in a
    suck-it-and-see strategy :-(

    Details can be found here: -
    http://www.oracle.com/technetwork/java/javase/index-141751.html#BEHAVIOR

    I am aghast at this and implore those in a position to do something (the
    http://forums.java.net/jive/forum.jspa?forumID=77 link doesn't seem very
    active) to introduce a "just do what you're bloody well told" flag!

    Really, what is the point of the "+" and "*" when "+" is what everyone gets?

    Cheers Richard Maher
    Richard Maher, May 14, 2012
    #1
    1. Advertising

  2. Richard Maher

    Lew Guest

    Richard Maher wrote:
    > On May 10, 11:36 am, Richard Maher<> wrote:


    Why start a new thread? Just continue in the original one.

    >> In my Applet's<object> tag I specify the "java_sersion" parameter as
    >> follows: -
    >>
    >> <param name="java_version" value="1.7+">
    >>
    >> I'd expected this clause to trigger the Java plugin (as long as after
    >> 1.6_10) to throw/report some sort of excption if there was now Java
    >> version available>= 1.7. Unfortunately, the Java plugin (1.6_31 in
    >> this case) seems very happy just to attempt to run the Applet on that
    >> version and ignore the later version requirement.
    >>
    >> Is this to be expected?
    >>
    >> Have I specified the parameter incorrectly?


    No, but you have failed to read the documentation. It's working as it's
    supposed to.

    >> I thought it might just have been crappy Safari on OS/X but it also
    >> limps-on or completely ignores this parameter on FireFox and Windows.
    >>
    >> I would like the Applet load to fail if there is no 1.7+ version; how
    >> can I achieve this?


    Use JNLP.

    As already advised. Why you not follow advice?

    > On May 11, 10:27 pm, Richard Maher<> wrote:
    >> Honestly, here's a very simple applet: -


    You're recapitulating the entire thread - well, your part of it. You should
    have stayed in context.

    >> <HTML>
    >> <HEAD>
    >> <TITLE> A Simple Program</TITLE>
    >> </HEAD>
    >> <BODY>
    >>
    >> Here is the output of my program:
    >> blah blah blah
    >>
    >> Can *anyone* show me *any version* or Java +/- browser wher the
    >> "java_version" applet parameter does *anything* other than take up
    >> space? APPLET, OBJECT, or EMBED tags.


    It does exactly what it's documented to do. Your problem?

    >> What is supposed to hapen when I ask/demand 7.0 and 7.0 does not
    >> exists???


    See the relevant quote below. It's from the documentation.

    >> Is larry pre-occupied on courtroom battles to concentrate on something
    >> that should be so simple?


    Still a stupid question, new thread notwithstanding.

    > Once again, for those following at home, I did some more tests and realized
    > that if you have multiple JREs available then you can choose a specific
    > lower version that is on your system (For example if you have 1.7 and 1.6
    > available and some applet is already running in 1.7 then yours can elect to
    > run in a 1.6 JVM and it will be duly created) The problem, as I see it, is
    > that if you elect/mandate a JRE version that is not available then the new
    > plugin will just opt for limp-home mode and gives you the latest version
    > available, push it up the flag-pole and see if anyone salutes, in a
    > suck-it-and-see strategy :-(
    >
    > Details can be found here: -
    > http://www.oracle.com/technetwork/java/javase/index-141751.html#BEHAVIOR
    >
    > I am aghast at this and implore those in a position to do something (the
    > http://forums.java.net/jive/forum.jspa?forumID=77 link doesn't seem very
    > active) to introduce a "just do what you're bloody well told" flag!


    If the tag did as you suggest it would violate the documented behavior:
    "When considering a request to launch an applet on a particular family or any
    later family, the latest available JRE will be used to launch the applet."

    So the thing is working the way it's supposed to.

    RTFM.

    --
    Lew
    Honi soit qui mal y pense.
    http://upload.wikimedia.org/wikipedia/commons/c/cf/Friz.jpg
    Lew, May 14, 2012
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Simon Niederberger
    Replies:
    2
    Views:
    16,407
    Christian Kaufhold
    Jan 7, 2005
  2. Andrew Crowe
    Replies:
    1
    Views:
    4,433
    Andrew Crowe
    Sep 13, 2004
  3. V Green
    Replies:
    0
    Views:
    808
    V Green
    Feb 5, 2008
  4. PA Bear [MS MVP]
    Replies:
    0
    Views:
    908
    PA Bear [MS MVP]
    Feb 5, 2008
  5. MowGreen [MVP]
    Replies:
    5
    Views:
    1,983
    PA Bear [MS MVP]
    Feb 9, 2008
Loading...

Share This Page