Serious issue: parts of my page render as not logged in, parts as logged in. Help!

Discussion in 'ASP .Net' started by pcloches@gmail.com, Apr 11, 2007.

  1. Guest

    I'm having a very difficult time with some of our new pages. We've
    moved to a web farm, and it seems in spurts it will come where parts
    of my page think the user is logged in, and parts think the user is
    not logged in. It seems to happen to an entire control. (None of the
    controls have OutputCache set)

    For example, our login control on top will appear showing the user is
    logged inw hen they have been redirected to RegNewUser, but RegNewUser
    will display instead of redirecting as if the user were actually
    logged in.

    The MachineKey option in the web.config is set to a generated SHA1, so
    the viewstate moves between the web servers just fine.

    This seems to come in spurts where it will happen to a lot of users at
    once, then it will stop coming. This is a serious problem on a
    production website, I just don't know where to turn or how to debug --
    everything looks fine!

    I am also getting Forms Authentication failed events in my log:

    Event code: 4005
    Event message: Forms authentication failed for the request. Reason:
    The ticket supplied has expired.
    Event time: 4/11/2007 12:42:27 PM
    Event time (UTC): 4/11/2007 7:42:27 PM
    Event ID: 0a0a593d17984b41aa13b93254491326
    Event sequence: 1161
    Event occurrence: 13
    Event detail code: 50202

    Application information:
    Application domain: /LM/W3SVC/1/Root-2-128207889508981002
    Trust level: Full
    Application Virtual Path: /
    Application Path: E:\htdocs\mysite-pri\
    Machine name: WEB1

    Process information:
    Process ID: 400
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE

    Request information:
    Request URL: http://www.mysite.com:8080/default.aspx
    Request path: /default.aspx
    User host address: 10.10.1.1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Name to authenticate:

    Custom event details:
    , Apr 11, 2007
    #1
    1. Advertising

  2. RE: Serious issue: parts of my page render as not logged in, parts as

    Make sure the cookie path is the same on all machines. Make sure that the Web
    Site number (e.g., /LM/W3SVC/1/Root-2-128207889508981002 - the "/1/" after
    W3SVC) is the same.
    Peter

    --
    Site: http://www.eggheadcafe.com
    UnBlog: http://petesbloggerama.blogspot.com
    Short urls & more: http://ittyurl.net




    "" wrote:

    > I'm having a very difficult time with some of our new pages. We've
    > moved to a web farm, and it seems in spurts it will come where parts
    > of my page think the user is logged in, and parts think the user is
    > not logged in. It seems to happen to an entire control. (None of the
    > controls have OutputCache set)
    >
    > For example, our login control on top will appear showing the user is
    > logged inw hen they have been redirected to RegNewUser, but RegNewUser
    > will display instead of redirecting as if the user were actually
    > logged in.
    >
    > The MachineKey option in the web.config is set to a generated SHA1, so
    > the viewstate moves between the web servers just fine.
    >
    > This seems to come in spurts where it will happen to a lot of users at
    > once, then it will stop coming. This is a serious problem on a
    > production website, I just don't know where to turn or how to debug --
    > everything looks fine!
    >
    > I am also getting Forms Authentication failed events in my log:
    >
    > Event code: 4005
    > Event message: Forms authentication failed for the request. Reason:
    > The ticket supplied has expired.
    > Event time: 4/11/2007 12:42:27 PM
    > Event time (UTC): 4/11/2007 7:42:27 PM
    > Event ID: 0a0a593d17984b41aa13b93254491326
    > Event sequence: 1161
    > Event occurrence: 13
    > Event detail code: 50202
    >
    > Application information:
    > Application domain: /LM/W3SVC/1/Root-2-128207889508981002
    > Trust level: Full
    > Application Virtual Path: /
    > Application Path: E:\htdocs\mysite-pri\
    > Machine name: WEB1
    >
    > Process information:
    > Process ID: 400
    > Process name: w3wp.exe
    > Account name: NT AUTHORITY\NETWORK SERVICE
    >
    > Request information:
    > Request URL: http://www.mysite.com:8080/default.aspx
    > Request path: /default.aspx
    > User host address: 10.10.1.1
    > User:
    > Is authenticated: False
    > Authentication Type:
    > Thread account name: NT AUTHORITY\NETWORK SERVICE
    >
    > Name to authenticate:
    >
    > Custom event details:
    >
    >
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Apr 12, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lau Lei Cheong

    Page.Render do not render complete page

    Lau Lei Cheong, May 15, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    2,052
    Lau Lei Cheong
    May 15, 2004
  2. keithb
    Replies:
    0
    Views:
    626
    keithb
    Feb 16, 2006
  3. Replies:
    3
    Views:
    584
    Keith Thompson
    Mar 31, 2007
  4. kizk
    Replies:
    0
    Views:
    562
  5. Glenn Gillen
    Replies:
    0
    Views:
    266
    Glenn Gillen
    Nov 17, 2006
Loading...

Share This Page