The Microsoft Jet database engine cannot open the file

Discussion in 'ASP .Net Web Services' started by Jas, Dec 15, 2009.

  1. Jas

    Jas Guest

    Hi we have a project that is running fin on the server itself under the admin
    account and also on the developper computer but soon as we are trying to
    access it from another computer in the network we are getting The Microsoft
    Jet database engine cannot open the file.

    The mdb file is located on a shared drive \\server\public$\foldername

    I added everyone to the foldername security doesn't fixed the probem

    we added the line <identity impersonate="true"/> in the web.config doesn't
    fixed the problem

    The Authenticated access is setup for Intergrated Windows authentication adn
    we are not using the anonymous so it's unchecked.

    When I'm displaying the user that gets windowsidentity it's my
    domainname\username so it's really working the way it should.

    I'm a member of the domain admin group so I have full access everywhere and
    still doesn't work and either a regulare user. Still have the Microsoft Jet
    database engine error.

    Does someone have another idea?

    We really need to keep it as an access database for now and the file need to
    stay on the other shared server.

    Thanks in advance for any ideas,

    Jason
     
    Jas, Dec 15, 2009
    #1
    1. Advertising

  2. Jas

    Patrice Guest

    Hi,

    You have also permissions on the network public$ share itself. Have you
    checked those ?

    Usually using the
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx procmon tool
    will trace filesystem calls and allows to see why it fails (for example I
    found once that a driver wanted to create a temporary file).


    --
    Patrice


    "Jas" <> a écrit dans le message de groupe de
    discussion : ...
    > Hi we have a project that is running fin on the server itself under the
    > admin
    > account and also on the developper computer but soon as we are trying to
    > access it from another computer in the network we are getting The
    > Microsoft
    > Jet database engine cannot open the file.
    >
    > The mdb file is located on a shared drive \\server\public$\foldername
    >
    > I added everyone to the foldername security doesn't fixed the probem
    >
    > we added the line <identity impersonate="true"/> in the web.config doesn't
    > fixed the problem
    >
    > The Authenticated access is setup for Intergrated Windows authentication
    > adn
    > we are not using the anonymous so it's unchecked.
    >
    > When I'm displaying the user that gets windowsidentity it's my
    > domainname\username so it's really working the way it should.
    >
    > I'm a member of the domain admin group so I have full access everywhere
    > and
    > still doesn't work and either a regulare user. Still have the Microsoft
    > Jet
    > database engine error.
    >
    > Does someone have another idea?
    >
    > We really need to keep it as an access database for now and the file need
    > to
    > stay on the other shared server.
    >
    > Thanks in advance for any ideas,
    >
    > Jason
     
    Patrice, Jan 25, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGF2ZQ==?=

    The Microsoft Jet database engine cannot open the file

    =?Utf-8?B?RGF2ZQ==?=, Aug 3, 2005, in forum: ASP .Net
    Replies:
    6
    Views:
    983
    =?Utf-8?B?RGF2ZQ==?=
    Aug 5, 2005
  2. =?Utf-8?B?TmVhbA==?=
    Replies:
    3
    Views:
    41,752
    Paul Clement
    Sep 2, 2005
  3. Morten Wennevik
    Replies:
    1
    Views:
    3,147
    Morten Wennevik
    Oct 31, 2005
  4. mamin
    Replies:
    1
    Views:
    3,478
    elcon
    Jul 28, 2010
  5. snazzy
    Replies:
    2
    Views:
    272
    Bob Barrows [MVP]
    Nov 7, 2008
Loading...

Share This Page