vs2008 deploy to localhost

Discussion in 'ASP .Net' started by =?Utf-8?B?cm9kY2hhcg==?=, Nov 7, 2007.

  1. hey all,
    i created a basic web app in vs2008 and deployed it to my localhost. when i
    tried to browse the site, i get the iis message "page cannot be displayed."

    any iideas?
    thanks,
    rodchar
    =?Utf-8?B?cm9kY2hhcg==?=, Nov 7, 2007
    #1
    1. Advertising

  2. =?Utf-8?B?cm9kY2hhcg==?=

    LVP Guest

    http://support.microsoft.com/kb/241344


    "rodchar" <> wrote in message
    news:...
    > hey all,
    > i created a basic web app in vs2008 and deployed it to my localhost. when
    > i
    > tried to browse the site, i get the iis message "page cannot be
    > displayed."
    >
    > any iideas?
    > thanks,
    > rodchar
    LVP, Nov 7, 2007
    #2
    1. Advertising

  3. On Nov 7, 8:38 pm, rodchar <> wrote:
    > hey all,
    > i created a basic web app in vs2008 and deployed it to my localhost. when i
    > tried to browse the site, i get the iis message "page cannot be displayed."
    >
    > any iideas?
    > thanks,
    > rodchar


    try to disable IE friendly error messages (Tools - Internet Options -
    Advanced...)
    Alexey Smirnov, Nov 7, 2007
    #3
  4. =?Utf-8?B?cm9kY2hhcg==?=, Nov 7, 2007
    #4
  5. Try browsing to an HTML page not ASPX page if that works then you need to
    configure ASP.Net on IIS.
    Also check the ASP.Net version, wouldn't hurt to run
    C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727\aspnet_regiis.exe -i
    You can also check the weblog to see if the page is actualy being hit, can
    usualy be found at C:\WINDOWS\system32\LogFiles\W3SVC1.

    Regards,
    Brian K. Williams




    "rodchar" <> wrote in message
    news:...
    > hey all,
    > i created a basic web app in vs2008 and deployed it to my localhost. when
    > i
    > tried to browse the site, i get the iis message "page cannot be
    > displayed."
    >
    > any iideas?
    > thanks,
    > rodchar
    Brian Williams, Nov 7, 2007
    #5
  6. Alexey Smirnov, Nov 7, 2007
    #6
  7. =?Utf-8?B?cm9kY2hhcg==?=

    LVP Guest

    Have you tried to make sure that you web app is an application.
    right click on the test2
    Under Application Settings
    next to Application name hit Remove then Create.


    "LVP" <> wrote in message
    news:...
    > http://support.microsoft.com/kb/241344
    >
    >
    > "rodchar" <> wrote in message
    > news:...
    >> hey all,
    >> i created a basic web app in vs2008 and deployed it to my localhost. when
    >> i
    >> tried to browse the site, i get the iis message "page cannot be
    >> displayed."
    >>
    >> any iideas?
    >> thanks,
    >> rodchar

    >
    >
    LVP, Nov 7, 2007
    #7
  8. That's a client issue.

    He needs to reconfigure IE to enable enhanced security configuration.



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Alexey Smirnov" <> wrote in message
    news:...
    > On Nov 7, 9:44 pm, rodchar <> wrote:
    >> see what i'm talking about here:
    >>
    >> http://www25.brinkster.com/rodchar/medtest.htm
    >>
    >>

    >
    > Is Asp.net enabled in IIS? Check the web service extensions node
    >
    >
    Juan T. Llibre, Nov 7, 2007
    #8
  9. On Nov 7, 11:03 pm, "Juan T. Llibre" <>
    wrote:
    > That's a client issue.
    >
    > He needs to reconfigure IE to enable enhanced security configuration.
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Alexey Smirnov" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > On Nov 7, 9:44 pm, rodchar <> wrote:
    > >> see what i'm talking about here:

    >
    > >>http://www25.brinkster.com/rodchar/medtest.htm

    >
    > > Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

    >
    > - Show quoted text -


    HTTP 404 is a very common problem with IIS 6, because ASP.NET is
    disabled by default.
    Alexey Smirnov, Nov 7, 2007
    #9
  10. re:
    !> HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.

    Check the screen previous to the 404...




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Alexey Smirnov" <> wrote in message
    news:...
    On Nov 7, 11:03 pm, "Juan T. Llibre" <>
    wrote:
    > That's a client issue.
    >
    > He needs to reconfigure IE to enable enhanced security configuration.
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Alexey Smirnov" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > On Nov 7, 9:44 pm, rodchar <> wrote:
    > >> see what i'm talking about here:

    >
    > >>http://www25.brinkster.com/rodchar/medtest.htm

    >
    > > Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

    >
    > - Show quoted text -


    HTTP 404 is a very common problem with IIS 6, because ASP.NET is
    disabled by default.
    Juan T. Llibre, Nov 7, 2007
    #10
  11. On Nov 8, 12:08 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.
    >
    > Check the screen previous to the 404...
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Alexey Smirnov" <> wrote in message
    >
    > news:...
    > On Nov 7, 11:03 pm, "Juan T. Llibre" <>
    > wrote:
    >
    >
    >
    >
    >
    > > That's a client issue.

    >
    > > He needs to reconfigure IE to enable enhanced security configuration.

    >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq :http://asp.net.do/faq/
    > > foros de asp.net, en español :http://asp.net.do/foros/
    > > ======================================"Alexey Smirnov" <> wrote in message

    >
    > >news:...

    >
    > > > On Nov 7, 9:44 pm, rodchar <> wrote:
    > > >> see what i'm talking about here:

    >
    > > >>http://www25.brinkster.com/rodchar/medtest.htm

    >
    > > > Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > HTTP 404 is a very common problem with IIS 6, because ASP.NET is
    > disabled by default.- Hide quoted text -
    >
    > - Show quoted text -


    Hi Juan,

    I made a test on my Win2003 server. I created a test website with
    default.aspx in the root directory. First, I enabled Internet Explorer
    Enhanced Security Configuration (IE ESC) by adding this component in
    Add or Remove Programs. When starting Internet Explorer, I now had a
    page from res://shdoclc.dll/hardAdmin.htm that is about "Internet
    Explorer Enhanced Security Configuration is enabled". Then I disabled
    IE ESC and on starting Internet Explorer, I got the page from
    res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
    "Internet Explorer Enhanced Security Configuration is not enabled".
    Now, when I typing http://localhost I see the test page.
    Alexey Smirnov, Nov 8, 2007
    #11
  12. re:
    !> Then I disabled IE ESC and on starting Internet Explorer, I got the page
    !> from res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
    !> "Internet Explorer Enhanced Security Configuration is not enabled".
    !> Now, when I typing http://localhost I see the test page.

    You could, also, have left it enabled, and configured localhost as a Trusted site.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Alexey Smirnov" <> wrote in message
    news:...
    On Nov 8, 12:08 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.
    >
    > Check the screen previous to the 404...
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Alexey Smirnov" <> wrote in message
    >
    > news:...
    > On Nov 7, 11:03 pm, "Juan T. Llibre" <>
    > wrote:
    >
    >
    >
    >
    >
    > > That's a client issue.

    >
    > > He needs to reconfigure IE to enable enhanced security configuration.

    >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq :http://asp.net.do/faq/
    > > foros de asp.net, en español :http://asp.net.do/foros/
    > > ======================================"Alexey Smirnov" <> wrote in message

    >
    > >news:...

    >
    > > > On Nov 7, 9:44 pm, rodchar <> wrote:
    > > >> see what i'm talking about here:

    >
    > > >>http://www25.brinkster.com/rodchar/medtest.htm

    >
    > > > Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > HTTP 404 is a very common problem with IIS 6, because ASP.NET is
    > disabled by default.- Hide quoted text -
    >
    > - Show quoted text -


    Hi Juan,

    I made a test on my Win2003 server. I created a test website with
    default.aspx in the root directory. First, I enabled Internet Explorer
    Enhanced Security Configuration (IE ESC) by adding this component in
    Add or Remove Programs. When starting Internet Explorer, I now had a
    page from res://shdoclc.dll/hardAdmin.htm that is about "Internet
    Explorer Enhanced Security Configuration is enabled". Then I disabled
    IE ESC and on starting Internet Explorer, I got the page from
    res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
    "Internet Explorer Enhanced Security Configuration is not enabled".
    Now, when I typing http://localhost I see the test page.
    Juan T. Llibre, Nov 8, 2007
    #12
  13. thanks everyone for a plethora of replies. this is always helpful. it turned
    out to be that ASP.NET was not enabled on the server. i had to go to
    Add/Remove Programs and enable it from there.

    thanks again to everyone. wow!!

    "rodchar" wrote:

    > hey all,
    > i created a basic web app in vs2008 and deployed it to my localhost. when i
    > tried to browse the site, i get the iis message "page cannot be displayed."
    >
    > any iideas?
    > thanks,
    > rodchar
    =?Utf-8?B?cm9kY2hhcg==?=, Nov 8, 2007
    #13
  14. That's fine, but what you did was *install* it
    from Add/Remove Programs, not "enable" it.

    In W2K3, for example, you have to enable it *after* you install it.





    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "rodchar" <> wrote in message
    news:...
    > thanks everyone for a plethora of replies. this is always helpful. it turned
    > out to be that ASP.NET was not enabled on the server. i had to go to
    > Add/Remove Programs and enable it from there.
    >
    > thanks again to everyone. wow!!
    >
    > "rodchar" wrote:
    >
    >> hey all,
    >> i created a basic web app in vs2008 and deployed it to my localhost. when i
    >> tried to browse the site, i get the iis message "page cannot be displayed."
    >>
    >> any iideas?
    >> thanks,
    >> rodchar
    Juan T. Llibre, Nov 8, 2007
    #14
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    819
    Jiong Feng
    Nov 19, 2003
  2. Alex
    Replies:
    4
    Views:
    566
    Hasani Blackwell
    Feb 8, 2005
  3. Cirene

    VS2008 - how deploy a site?

    Cirene, Nov 26, 2007, in forum: ASP .Net
    Replies:
    4
    Views:
    381
    Cirene
    Nov 26, 2007
  4. Michael Tissington

    VS2008 - Localhost debug ...

    Michael Tissington, Apr 20, 2008, in forum: ASP .Net
    Replies:
    19
    Views:
    980
    Random random
    May 15, 2008
  5. Jerry Nettleton

    how to create VS2008 project and/or deploy WCF service on localhos

    Jerry Nettleton, Dec 9, 2008, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    826
    Jerry Nettleton
    Dec 9, 2008
Loading...

Share This Page