web service showing localhost not FQDN ?

Discussion in 'ASP .Net' started by Scott, Jul 16, 2009.

  1. Scott

    Scott Guest

    A Web service has been publish but the svcutil.exe path (displayed when you
    browse to the service.svc page) shows local host as opposed to the domain
    name its been published on (i.e address bar ok, its the svcutil.exe path
    thats wrong). Developers need FQDN here, How can i change this ?

    Its picking up whatever local host its running on, must be some switch in
    the app to allow me to set this somewhere ?

    thanks for any help.
     
    Scott, Jul 16, 2009
    #1
    1. Advertising

  2. Scott

    Scott Guest

    "Scott" <> wrote in message
    news:...
    >A Web service has been publish but the svcutil.exe path (displayed when you
    > browse to the service.svc page) shows local host as opposed to the domain
    > name its been published on (i.e address bar ok, its the svcutil.exe path
    > thats wrong). Developers need FQDN here, How can i change this ?
    >
    > Its picking up whatever local host its running on, must be some switch in
    > the app to allow me to set this somewhere ?
    >
    > thanks for any help.
    >
    >


    http://gavinmckay.wordpress.com/2009/03/24/howto-fix-wcf-host-name-on-iis/
     
    Scott, Jul 16, 2009
    #2
    1. Advertising

  3. Scott

    Scott Guest

    Hi,

    I have followed the method above several times but cannot access my
    service.scv page anymore.

    Amended meta data for 80 and 443
    Tried domain.com and https://domain.com
    Corerct site ID was used
    IIS reset
    Restarted server

    Any ideas ?

    Scott
     
    Scott, Jul 16, 2009
    #3
  4. Scott

    Scott Guest

    spotted the website was offline, after server reboot it did not restart, not
    sure why yet.
     
    Scott, Jul 16, 2009
    #4
  5. Scott

    Scott Guest

    error when trying to start says "the parameter is incorrect".

    No errors in any of the event logs.
     
    Scott, Jul 16, 2009
    #5
  6. Scott

    Scott Guest

    found it, the SSL IP somehow changed to 255.255.255.255 during one of the
    processes above.
     
    Scott, Jul 16, 2009
    #6
  7. Scott

    Scott Guest

    sorry , update to the above. the service stopped because when i run

    cscript.exe //nologo %systemdrive%\inetpub\adminscripts\adsutil.vbs set
    W3SVC/your_website_identifier_here/SecureBindings ":443:my.publicserver.com"

    the IP under WEBSITE / ADVANCED for the SSL socket changes to
    255.255.255.255

    When i delete this entry (wont let me amend) and enter the correct IP the
    site starts but the

    svcutil.exe https://localhost/Service.svc?wsdl

    shows local host still :(
     
    Scott, Jul 16, 2009
    #7
  8. Scott

    Scott Guest

    found this:


    You can manually specify the complete address the service should use in the
    web.config as opposed to having the ServiceHost figure it out for you. You
    have to set the base address of your service:
    <service behaviorConfiguration="Behaviour1" name="Api.Poll"> <endpoint
    address="soap" binding="basicHttpBinding" bindingConfiguration="soapBinding"
    contract="Api.IPoll" /> <endpoint address="mex" binding="mexHttpBinding"
    contract="IMetadataExchange" /> <host> <baseAddresses> <add
    baseAddress="http://www.mydomain.com/Api" /> <add
    baseAddress="http://10.10.20.30/Api" /> </baseAddresses> </host>
    </service>Someone comment that IIS ignorse this BaseAddress.
     
    Scott, Jul 16, 2009
    #8
  9. Scott

    Scott_lotus Guest

    Scott_lotus, Sep 7, 2009
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ThunderMusic
    Replies:
    0
    Views:
    556
    ThunderMusic
    Jan 3, 2006
  2. rh0dium
    Replies:
    2
    Views:
    300
    Mike Meyer
    Sep 21, 2005
  3. GSA

    FQDN to IP

    GSA, Nov 19, 2010, in forum: Java
    Replies:
    10
    Views:
    2,389
  4. Stu Carter

    IIS and FQDN authentication confusion

    Stu Carter, Oct 11, 2005, in forum: ASP .Net Security
    Replies:
    6
    Views:
    603
    Stu Carter
    Oct 12, 2005
  5. Steven Simpson
    Replies:
    0
    Views:
    756
    Steven Simpson
    Feb 6, 2012
Loading...

Share This Page