A connection was successfully established with the server, but then an error occurred during the log

Discussion in 'ASP .Net' started by matt.delvecchio, May 16, 2006.

  1. i saw a similar post from last year, but i didnt see any clear
    solution. the error message:

    "A connection was successfully established with the server, but then an
    error occurred during the login process. (provider: TCP Provider,
    error: 0 - The specified network name is no longer available.)

    Exception Details: System.Data.SqlClient.SqlException: A connection was
    successfully established with the server, but then an error occurred
    during the login process. (provider: TCP Provider, error: 0 - The
    specified network name is no longer available.)"


    ....it would appear to have something to do w/ SQL Server connectivity.
    when i get it, i get it repeatedly. however, if i go to a non-db page,
    then page to a db-page, it's cleared up.

    i am running ASP.NET 2.0, on a commerical hosting environment
    (www.datapacket.net), w/ a SQL 2000 server. no problems in dev, usually
    works in this prod env.


    any ideas what would cause this strangeness?

    thanks,
    matt
     
    matt.delvecchio, May 16, 2006
    #1
    1. Advertisements

  2. matt.delvecchio

    sloan Guest

    Do a google search for

    "Network Library"
    "dbmssocn"

    You can add some extra "hints" to the connection string, which might help.

    You should post your connection string to the group, so it can be evaluated
    also.
     
    sloan, May 16, 2006
    #2
    1. Advertisements

  3. connection string:

    <connectionStrings>
    <add name="FooBar"
    connectionString="server=x.x.x.x; database=FooBar; UID=foo; Pwd=bar"
    providerName="System.Data.SqlClient"/>
    </connectionStrings>
     
    matt.delvecchio, May 17, 2006
    #3
  4. ok can you be a littler more specific here (or, even, completely
    clear)? i found some links that indicate this is a way one can set the
    network library via the conn string:

    http://support.microsoft.com/kb/q238949/

    and the 2nd post here:

    http://www.mcse.ms/archive85-2004-10-1155447.html

    ....says "dbmssocn" is the TCP/P network library and "dbnetlib" is the
    new.

    but, i have no idea what network libraries are, or why id want to use
    them. none of the ASP.NET 2.0 articles/docs/code examples ive come
    across specify a network library in the conn strings. what are these?
    why did you refer them to me? are you aware of ongoing connection
    difficulities if specifiying one is omitted?


    thanks,
    matt
     
    matt.delvecchio, May 17, 2006
    #4
  5. matt.delvecchio

    Joined:
    Mar 18, 2008
    Messages:
    1
    Likes Received:
    0
    Hi



    Try to turn off the pooling, in connection string i.e pooling = false , this has solved my problem , even though the performance of application slows down but it works.

    Sudershan
     
    , Mar 18, 2008
    #5
  6. matt.delvecchio

    rasor

    Joined:
    May 8, 2008
    Messages:
    1
    Likes Received:
    0
    SQL server authentication is not enabled

    It might be due to SQL server authentication is not enabled on the instance localhost\sqlexpress. Right click the node of that name in the object explorer of SQL Srv Mgmt Studio and change the security.
     
    rasor, May 8, 2008
    #6
  7. matt.delvecchio

    jbehl

    Joined:
    Apr 5, 2009
    Messages:
    1
    Likes Received:
    0
    I had the same problem...then I decided to look at the obvious

    I went into my services manager and guess what wasn't started? Yep you guessed it, SQL Server wasn't started. I started it up and the problem went away.:damnmate:
     
    jbehl, Apr 5, 2009
    #7
  8. matt.delvecchio

    pushpaharan

    Joined:
    May 6, 2010
    Messages:
    1
    Likes Received:
    0
    yes its helped. i chenged the authentication modde to both server and windows , after it worked.

    thnaks
     
    pushpaharan, May 6, 2010
    #8
  9. matt.delvecchio

    fedceel

    Joined:
    Jan 16, 2011
    Messages:
    1
    Likes Received:
    0
    Thank you, that helped.
     
    fedceel, Jan 16, 2011
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.