Advice needed for Python packaging - can't find required libraryduring installation

  • Thread starter thebiggestbangtheory
  • Start date
T

thebiggestbangtheory

Hello all,

I am trying to package up a very simple python app. In my setup.py file I have a couple of lines that include the following:

from setuptools import setup

setup(
name='ban',
version='0.1',
packages=['ban',],
description='Python Distribution Utilities',
author='Ban',
author_email='(e-mail address removed)',
package_data={'ban': ['data/*.dat']},
long_description=open('README.txt').read(),
install_requires=['Google-Safe-Browsing-v2-Lookup'],
)


The error I see when running:
$> python setup.py install

***************************
running install
running bdist_egg
running egg_info
writing requirements to ban.egg-info/requires.txt
writing ban.egg-info/PKG-INFO
writing top-level names to ban.egg-info/top_level.txt
writing dependency_links to ban.egg-info/dependency_links.txt
reading manifest file 'ban.egg-info/SOURCES.txt'
writing manifest file 'ban.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib.linux-x86_64-2.6
creating build/lib.linux-x86_64-2.6/ban
copying ban/analyzer.py -> build/lib.linux-x86_64-2.6/ban
copying ban/__init__.py -> build/lib.linux-x86_64-2.6/ban
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/ban
copying build/lib.linux-x86_64-2.6/ban/analyzer.py -> build/bdist.linux-x86_64/egg/ban
copying build/lib.linux-x86_64-2.6/ban/__init__.py -> build/bdist.linux-x86_64/egg/ban
byte-compiling build/bdist.linux-x86_64/egg/ban/analyzer.py to analyzer.pyc
byte-compiling build/bdist.linux-x86_64/egg/ban/__init__.py to __init__.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying ban.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying ban.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying ban.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying ban.egg-info/requires.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying ban.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/ban-0.1-py2.6.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing ban-0.1-py2.6.egg
removing '/usr/local/lib/python2.6/dist-packages/ban-0.1-py2.6.egg' (and everything under it)
creating /usr/local/lib/python2.6/dist-packages/ban-0.1-py2.6.egg
Extracting ban-0.1-py2.6.egg to /usr/local/lib/python2.6/dist-packages
ban 0.1 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.6/dist-packages/ban-0.1-py2.6.egg
Processing dependencies for ban==0.1
Searching for Google-Safe-Browsing-v2-Lookup
Reading http://pypi.python.org/simple/Google-Safe-Browsing-v2-Lookup/
No local packages or download links found for Google-Safe-Browsing-v2-Lookup
error: Could not find suitable distribution for Requirement.parse('Google-Safe-Browsing-v2-Lookup')
**************************

Issue #1

Apparently the setup script cannot find the package - Google-Safe-Browsing-v2-Lookup . However, I can install this package via pip.

What should I specify in the setup.py file instead of install_requires=['Google-Safe-Browsing-v2-Lookup'] so that the library is properly installed ?


Any advice is appreciated.
 
D

dieter

I am trying to package up a very simple python app. In my setup.py file I have a couple of lines that include the following:

from setuptools import setup

setup(
name='ban',
version='0.1',
packages=['ban',],
description='Python Distribution Utilities',
author='Ban',
author_email='(e-mail address removed)',
package_data={'ban': ['data/*.dat']},
long_description=open('README.txt').read(),
install_requires=['Google-Safe-Browsing-v2-Lookup'],
)
...
Processing dependencies for ban==0.1
Searching for Google-Safe-Browsing-v2-Lookup
Reading http://pypi.python.org/simple/Google-Safe-Browsing-v2-Lookup/
No local packages or download links found for Google-Safe-Browsing-v2-Lookup
error: Could not find suitable distribution for Requirement.parse('Google-Safe-Browsing-v2-Lookup')
**************************

Issue #1

Apparently the setup script cannot find the package - Google-Safe-Browsing-v2-Lookup . However, I can install this package via pip.

What should I specify in the setup.py file instead of install_requires=['Google-Safe-Browsing-v2-Lookup'] so that the library is properly installed ?

I suppose that "setuptools" is confused by the "-" in the package
names together with these "-" being omitted in the uploaded file
(https://pypi.python.org/packages/so.../Google Safe Browsing v2 Lookup-0.1.0.tar.gz5").

If this supposition is correct, then you would either need to
contact the "setuptools" author (to get "setuptools" handle this case)
or the "Google Safe Browsing" author to get a filename more
in line with the package name.
 
T

thebiggestbangtheory

Thank you very much! :)

(e-mail address removed) writes:


I am trying to package up a very simple python app. In my setup.py file I have a couple of lines that include the following:
from setuptools import setup
name='ban',
version='0.1',
packages=['ban',],

description='Python Distribution Utilities',
author='Ban',
author_email='(e-mail address removed)',

package_data={'ban': ['data/*.dat']},
long_description=open('README.txt').read(),
install_requires=['Google-Safe-Browsing-v2-Lookup'],

Processing dependencies for ban==0.1
Searching for Google-Safe-Browsing-v2-Lookup
No local packages or download links found for Google-Safe-Browsing-v2-Lookup
error: Could not find suitable distribution for Requirement.parse('Google-Safe-Browsing-v2-Lookup')
**************************

Issue #1
Apparently the setup script cannot find the package - Google-Safe-Browsing-v2-Lookup . However, I can install this package via pip.
What should I specify in the setup.py file instead of install_requires=['Google-Safe-Browsing-v2-Lookup'] so that the library is properly installed ?



I suppose that "setuptools" is confused by the "-" in the package

names together with these "-" being omitted in the uploaded file

(https://pypi.python.org/packages/so.../Google Safe Browsing v2 Lookup-0.1.0.tar.gz5").



If this supposition is correct, then you would either need to

contact the "setuptools" author (to get "setuptools" handle this case)

or the "Google Safe Browsing" author to get a filename more

in line with the package name.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,703
Messages
2,569,328
Members
44,612
Latest member
Billysak

Latest Threads

Top