High Memory Usage aspnet_wp.exe

Discussion in 'ASP .Net' started by Guest, Nov 30, 2005.

  1. Guest

    Guest Guest

    Hi,

    Our customer has a win2k Xeon 2.0 web server with 2GB of Ram. After a
    certain time the aspnet_wp.exe consumes %70 of the Ram and comes to a
    standstill. We end the process and everything is ok. We used memory profiler
    to find out what is causing the problem but couldn't come to a result. I've
    noticed that their is a patch for this type of cause on Microsoft's web site
    but no download.

    The framework is 1.1.4322

    Cheers

    Erkan Tatlidil
     
    Guest, Nov 30, 2005
    #1
    1. Advertisements

  2. Guest

    Guest Guest

    Hi,

    If you go to the processModel in your machine.config file (default
    location>C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\CONFIG) it has a
    setting...

    <processModel enable="true" timeout="Infinite" idleTimeout="Infinite"
    shutdownTimeout="0:00:05" requestLimit="Infinite" requestQueueLimit="5000"
    restartQueueLimit="10" memoryLimit="60" webGarden="false"
    cpuMask="0xffffffff" userName="System" password="AutoGenerate"
    logLevel="Errors" clientConnectedCheck="0:00:05"
    comAuthenticationLevel="Connect" comImpersonationLevel="Impersonate"
    responseDeadlockInterval="00:03:00" maxWorkerThreads="20" maxIoThreads="20"/>

    Now, the memoryLimit = 60 signifies the percentage of memory which could be
    reached before a process recycles. There could be some memory leak that is
    happening in your application. Just ensure that you have debug="true" in your
    web.config file for all the applications and see if that helps.

    Thanks,
    Rahul Soni
     
    Guest, Nov 30, 2005
    #2
    1. Advertisements

  3. Erkan,

    I've noticed this issue also. I'd read article on 4guysfromrolla.com about
    ..Net Framework not GC issues. Now, I explicitly close all
    objects/connections opened and then set them to nothing. Just closing
    connection is not enough.Also, try forcing GC after certain interval. In
    Win2003 you can configure settings on application pool to automatically
    restart aspnet_wp. On W2k only way is either restart W3 services or force
    GC.

    HTH
     
    Nilesh Deshpande, Nov 30, 2005
    #3
  4. Guest

    Guest Guest

    Hi,

    Just wanted to add that, I was wrong about the debug="true"... You should
    have it as debug="false" in all your web.config files.

    Sorry for that mistake.
     
    Guest, Nov 30, 2005
    #4
  5. Guest

    Guest Guest

    Hi Nilesh,

    I agree partially to you, but forcing GC is never a good idea. There are
    multiple issue around that and moreover, without knowing the applications, it
    would be rather difficult to say that the issue is being caused by the GC not
    getting kicked in.

    http://msdn.microsoft.com/msdnmag/issues/1100/GCI/default.aspx
    http://msdn.microsoft.com/msdnmag/issues/1200/GCI2/default.aspx
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dndotnet/html/dotnetgcbasics.asp

    --
    Thanks,
    Rahul Soni

    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    The secret to creativity is knowing how to hide your sources
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     
    Guest, Nov 30, 2005
    #5
  6. Guest

    Guest Guest

    "=?Utf-8?B?RXJrYW4gVGF0bGlkaWw=?=" <Erkan
    > wrote in
    Are you using a lot of datasets? Datasets gobble memory if the result set
    is large.
     
    Guest, Nov 30, 2005
    #6
  7. Guest

    Guest Guest

    Thanks for the info. Even though I force the GC and set all objects to
    nothing the aspnet_wp.net process still continues to grow in the memory.

    We are planing to upgrade the box to a w2k3 server this saturday. I'll see
    how we go and let you know about the results.

    Cheers

    Erkan
     
    Guest, Nov 30, 2005
    #7
  8. Guest

    Guest Guest

    Hi Stan,

    We use datasets but not on all pages. The max dataset is 4 which is used
    only on one page.

    Cheers

    Erkan
     
    Guest, Nov 30, 2005
    #8
  9. Guest

    Guest Guest

    Check and see if those datasets are doing a SELECT * FROM TABLE : )
     
    Guest, Dec 1, 2005
    #9
  10. Guest

    Guest Guest

    Hi Stan,

    Select * will be a crazy thing to do hehehe.

    Anyway last night we uninstalled .net framework 1.1.4 SP 1 and reinstalled
    it today we noticed that once the memory usage goes up to 800 mb the GC kicks
    in and recycles it. So all day it was in a stable condition.

    Cheers

    Erkan
     
    Guest, Dec 1, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.