How to install rmagic gem on Debian squeeze?

Discussion in 'Ruby' started by Oren, Aug 28, 2011.

  1. Oren

    Oren Guest

    When trying to install rmagick gem I get the error:
    Can't install RMagick 2.13.1. Can't find Magick-config

    Here is my setup and the steps I took:
    Debian sqeeeze, ruby 1.9.8-p72.
    I install imagemagick and see the following:

    ii imagemagick 8:6.6.0.4-3
    ii libmagickcore3 8:6.6.0.4-3
    ii libmagickcore3-extra 8:6.6.0.4-3
    ii libmagickwand3 8:6.6.0.4-3

    I believe I also need the following - libmagic-dev and libmagickwand-dev:

    sudo aptitude install libmagic-dev libmagickwand-dev

    The following NEW packages will be installed:
    autopoint{a} debhelper{a} gettext{a} html2text{a} intltool-debian{a} libatk1.0-dev{a} libbz2-dev{a} libcairo2-dev{a} libcgraph5{a} libdjvulibre-dev{a} libexif-dev{a}
    libexpat1-dev{a} libfontconfig1-dev{a} libfreetype6-dev{ab} libglib2.0-dev{a} libgraphviz-dev{a} libgtk2.0-dev{a} libgvpr1{a} libice-dev{a} libilmbase-dev{a} libjasper-dev{a}
    libjpeg62-dev{a} liblcms1-dev{a} liblqr-1-0-dev{a} libltdl-dev{a} libmagickcore-dev{a} libmagickwand-dev libmail-sendmail-perl{a} libopenexr-dev{a} libpango1.0-dev{a}
    libpixman-1-dev{a} libpng12-dev{ab} libpthread-stubs0{a} libpthread-stubs0-dev{a} librsvg2-dev{a} libsm-dev{a} libsys-hostname-long-perl{a} libtiff4-dev{ab} libtiffxx0c2{a}
    libtool{a} libunistring0{a} libwmf-dev{a} libx11-dev{a} libxau-dev{a} libxcb-render-util0-dev{a} libxcb-render0-dev{a} libxcb1-dev{a} libxcomposite-dev{a} libxcursor-dev{a}
    libxdamage-dev{a} libxdmcp-dev{a} libxext-dev{a} libxfixes-dev{a} libxft-dev{a} libxi-dev{a} libxinerama-dev{a} libxml2-utils{a} libxrandr-dev{a} libxrender-dev{a} libxt-dev{a}
    ocaml-base-nox{a} pkg-config{a} po-debconf{a} x11proto-composite-dev{a} x11proto-core-dev{a} x11proto-damage-dev{a} x11proto-fixes-dev{a} x11proto-input-dev{a} x11proto-kb-dev{a}
    x11proto-randr-dev{a} x11proto-render-dev{a} x11proto-xext-dev{a} x11proto-xinerama-dev{a} xtrans-dev{a}
    0 packages upgraded, 74 newly installed, 0 to remove and 0 not upgraded.
    Need to get 24.6 MB of archives. After unpacking 76.9 MB will be used.
    The following packages have unmet dependencies:
    libpng12-dev: Depends: libpng12-0 (= 1.2.44-1) but 1.2.44-1+squeeze1 is installed.
    libtiff4-dev: Depends: libtiff4 (= 3.9.4-5) but 3.9.4-5+squeeze3 is installed.
    libfreetype6-dev: Depends: libfreetype6 (= 2.4.2-2.1) but 2.4.2-2.1+squeeze1 is installed.
    The following actions will resolve these dependencies:

    Keep the following packages at their current version:
    1) libcairo2-dev [Not Installed]
    2) libfontconfig1-dev [Not Installed]
    3) libfreetype6-dev [Not Installed]
    4) libgtk2.0-dev [Not Installed]
    5) libmagickcore-dev [Not Installed]
    6) libmagickwand-dev [Not Installed]
    7) libpango1.0-dev [Not Installed]
    8) libpng12-dev [Not Installed]
    9) librsvg2-dev [Not Installed]
    10) libtiff4-dev [Not Installed]
    11) libwmf-dev [Not Installed]
    12) libxft-dev [Not Installed]



    Accept this solution? [Y/n/q/?]


    any ideas/clues?
     
    Oren, Aug 28, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.