How to stop source being viewed ?


A

Aaron Gray

How do you stop the HTML source for a page being viewed on Windows
View>Source menu option ?

Aaron
 
Ad

Advertisements

T

Thomas 'PointedEars' Lahn

Aaron said:
How do you stop the HTML source for a page
being viewed on Windows View>Source menu option ?

[X] You only know Microsoft Windows. [psf 2.8]
[X] You only know Internet Explorer. [psf 2.9]


PointedEars
 
L

Lee

Aaron Gray said:
How do you stop the HTML source for a page being viewed on Windows
View>Source menu option ?

Before asking a question in a newsgroup, always read several posts, or at least
their titles, and see if you can find a pointer to the FAQ.

This entry refers to hiding Javascript, but it also applies to hiding HTML:

http://www.jibbering.com/faq/#FAQ4_1
 
L

Lasse Reichstein Nielsen

Thomas 'PointedEars' Lahn said:
Aaron said:
How do you stop the HTML source for a page
being viewed on Windows View>Source menu option ?

[X] You only know Microsoft Windows. [psf 2.8]
[X] You only know Internet Explorer. [psf 2.9]

Well, maybe that is all the poster needs. In fact, maybe he is
painfully aware that it is impossible to prevent in any other browser,
and confines his question to the one browser where it would not be
unexpected if it was possible.

/L
 
T

Thomas 'PointedEars' Lahn

Lasse said:
Thomas 'PointedEars' Lahn said:
Aaron said:
How do you stop the HTML source for a page
being viewed on Windows View>Source menu option ?

[X] You only know Microsoft Windows. [psf 2.8]
[X] You only know Internet Explorer. [psf 2.9]

Well, maybe that is all the poster needs. In fact, maybe he is
painfully aware that it is impossible to prevent in any other browser,
and confines his question to the one browser where it would not be
unexpected if it was possible.

It is hard to believe that a person asking an IE-related question without
mentioning IE at all does really know that there is another browser for
the mentioned operating system_s_ (note that the OS version was omitted
as well). He wrote "_Windows_ View>Source", not "IE's View>Source".
If he wrote the latter, perhaps I would have replied differently.

I have heard too many people complaining that "the Internet does not work"
when they activate the "Internet (Explorer)" icon on their Windows desktop
and IE hangs/crashes for some reason :)


Regards,
PointedEars
 
Ad

Advertisements

A

Aaron Gray

How do you stop the HTML source for a page
being viewed on Windows View>Source menu option ?

[X] You only know Microsoft Windows. [psf 2.8]
[X] You only know Internet Explorer. [psf 2.9]

Well, maybe that is all the poster needs. In fact, maybe he is
painfully aware that it is impossible to prevent in any other browser,
and confines his question to the one browser where it would not be
unexpected if it was possible.

It is hard to believe that a person asking an IE-related question without
mentioning IE at all does really know that there is another browser for
the mentioned operating system_s_ (note that the OS version was omitted
as well). He wrote "_Windows_ View>Source", not "IE's View>Source".
If he wrote the latter, perhaps I would have replied differently.

Sorry I did not have predantic mode switched on :)

I have a Linux Laptop as well as a Windoz one, but tend to be a Windozer.
I do like IE however, its great appart from not having SVG and MathML built
in :(
I have heard too many people complaining that "the Internet does not work"
when they activate the "Internet (Explorer)" icon on their Windows desktop
and IE hangs/crashes for some reason :)

I am a C++ and x86 assembler programmer as well.

But I do tend to act like a dumb Windowzer at times so do not be too hard on
me :)

Aaron
 
A

Aaron Gray

How do you stop the HTML source for a page being viewed on Windows
View>Source menu option ?

On IE goto Google, goto 'Personalized Home' (Top Right). Select View>Source
and nothing happens !

Just interested in how it does it.

It does not work on Flock/Firefox ! hehehe :)

Aaron
 
Ad

Advertisements

T

Thomas 'PointedEars' Lahn

Aaron said:
Has this got a virus or trojan in it ?

1. It's Trojan _Horse_. The Trojans were the attacked, not the attacker
(the Greeks were) :)

2. Unlikely.
My system has a process thats eating 99% of the timeslice !

$ GET http://devrijehuisarts.org/test/noViewSource.asp
GIF87aR¨÷3fÌÿ333f33Ì3ÿ3f3ffffÌfÿf3fÌÿÌ3ÌfÌÌÌÌÿÌÿ3ÿfÿÿÌÿ[...]

shows that a GIF resource is served, however the Content-Type header is
missing. It appears that some user agents try to display the content as
plain text if that header is missing.


PointedEars
 
T

Thomas 'PointedEars' Lahn

Thomas said:
Aaron said:
[<http://devrijehuisarts.org/test/noViewSource.asp>]
My system has a process thats eating 99% of the timeslice !

$ GET http://devrijehuisarts.org/test/noViewSource.asp
GIF87aR¨÷3fÌÿ333f33Ì3ÿ3f3ffffÌfÿf3fÌÿÌ3ÌfÌÌÌÌÿÌÿ3ÿfÿÿÌÿ[...]

shows that a GIF resource is served, however the Content-Type header is
missing. It appears that some user agents try to display the content as
plain text if that header is missing.

OK, I should have used the -e option:

$ GET -e http://devrijehuisarts.org/test/noViewSource.asp
Cache-Control: private
Connection: close
Date: Fri, 11 Nov 2005 16:05:46 GMT
Server: Microsoft-IIS/6.0
Content-Length: 2336
Content-Type: image/GIF
Client-Date: Fri, 11 Nov 2005 16:07:01 GMT
Client-Peer: 168.144.25.93:80
Client-Response-Num: 1
MicrosoftOfficeWebServer: 5.0_Pub
Set-Cookie: ASPSESSIONIDCSDBDQCB=BOHBJOECJIFFIBJDKENJHIOK; path=/
X-Powered-By: ASP.NET

GIF87aR¨÷3fÌÿ333f33Ì3ÿ3f3ffffÌfÿf3fÌÿÌ3ÌfÌÌÌÌÿÌÿ3ÿfÿÿÌÿÿÿ333f33Ì3ÿ[...]


It's no virus or Trojan Horse anyway.


PointedEars
 
M

McKirahan

Aaron Gray said:
On IE goto Google, goto 'Personalized Home' (Top Right). Select View>Source
and nothing happens !

Just interested in how it does it.

It does not work on Flock/Firefox ! hehehe :)

Aaron

Open the page, wait 10 minutes, then try View+Source.

This line is the cause:
<meta http-equiv="refresh" content="600">
 
Ad

Advertisements

A

Aaron Gray

Open the page, wait 10 minutes, then try View+Source.
This line is the cause:
<meta http-equiv="refresh" content="600">

Ah. I'd never of fathomed that one. Cheers. Good job I never looked too
hard.

Aaron
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top