InstantRails: Configure/database(via phpmyadmin) not working

Discussion in 'Ruby' started by basi, Oct 13, 2005.

  1. basi

    basi Guest

    Windows XP SP2
    InstantRails
    MySql
    HTTP 500 Internal server error. The URL is pointing to
    http://127.0.0.1/mysql.

    And by the way, what is the password for the root user?

    Thanks,
    basi
     
    basi, Oct 13, 2005
    #1
    1. Advertisements

  2. basi

    Ara.T.Howard Guest

    that is the question isn't it.

    -a
    --
    ===============================================================================
    | email :: ara [dot] t [dot] howard [at] noaa [dot] gov
    | phone :: 303.497.6469
    | Your life dwells amoung the causes of death
    | Like a lamp standing in a strong breeze. --Nagarjuna
    ===============================================================================
     
    Ara.T.Howard, Oct 13, 2005
    #2
    1. Advertisements

  3. basi

    Curt Hibbs Guest

    ------=_Part_9919_4597121.1129229956690
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    As delivered in Instant Rails, the MySQL is configured to only accept
    localhost connections and the root password is blank (empty).

    Curt

    ------=_Part_9919_4597121.1129229956690--
     
    Curt Hibbs, Oct 13, 2005
    #3
  4. basi

    Ara.T.Howard Guest

    sorry - i was just trying to be funny. guess no one else that it was funny to
    be asking for the root password on the net... been working too much ;-)

    -a
    --
    ===============================================================================
    | email :: ara [dot] t [dot] howard [at] noaa [dot] gov
    | phone :: 303.497.6469
    | Your life dwells amoung the causes of death
    | Like a lamp standing in a strong breeze. --Nagarjuna
    ===============================================================================
     
    Ara.T.Howard, Oct 13, 2005
    #4
  5. basi

    Curt Hibbs Guest

    ------=_Part_12356_25840002.1129237136746
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    My only excuse was that I was rushing to get out the door to the airport
    (off to RubyConf!).

    Curt

    ------=_Part_12356_25840002.1129237136746--
     
    Curt Hibbs, Oct 13, 2005
    #5
  6. basi

    Curt Hibbs Guest

    ------=_Part_12404_9785325.1129237290938
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    Apache has to be running to use phpMyAdmin.

    Curt

    ------=_Part_12404_9785325.1129237290938--
     
    Curt Hibbs, Oct 13, 2005
    #6
  7. basi

    basi Guest

    Thanks much!
    basi
     
    basi, Oct 14, 2005
    #7
  8. basi

    basi Guest

    Both Apache and MySql are in the "Started" state.
    basi
     
    basi, Oct 14, 2005
    #8
  9. basi

    Curt Hibbs Guest

    ------=_Part_16640_30791389.1129272664767
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline


    Hmmm.... that's strange. Is there anything in your apache error log or
    access log that might give us some more info?

    Cyrt

    ------=_Part_16640_30791389.1129272664767--
     
    Curt Hibbs, Oct 14, 2005
    #9
  10. basi

    basi Guest

    Here's the content of \InstantRails\apache\access.log

    127.0.0.1 - - [12/Oct/2005:13:26:50 -0600] "GET / HTTP/1.1" 200 220
    127.0.0.1 - - [12/Oct/2005:13:26:53 -0600] "GET /recipe/list HTTP/1.1"
    500 5055
    127.0.0.1 - - [12/Oct/2005:13:27:04 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    127.0.0.1 - - [12/Oct/2005:13:31:58 -0600] "GET
    /recipe/list?BP-RETRY=1&action=list&controller=recipe HTTP/1.1" 500 217
    127.0.0.1 - - [12/Oct/2005:13:32:40 -0600] "GET /recipe/list HTTP/1.1"
    200 1639
    127.0.0.1 - - [12/Oct/2005:13:32:48 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    127.0.0.1 - - [12/Oct/2005:13:32:51 -0600] "GET
    /recipe/list?category=Snacks HTTP/1.1" 200 1278
    127.0.0.1 - - [12/Oct/2005:13:32:57 -0600] "GET /recipe/show/1
    HTTP/1.1" 200 618
    127.0.0.1 - - [12/Oct/2005:13:32:57 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    127.0.0.1 - - [12/Oct/2005:13:33:03 -0600] "GET /category/list
    HTTP/1.1" 200 886
    127.0.0.1 - - [12/Oct/2005:13:33:09 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    127.0.0.1 - - [12/Oct/2005:13:33:09 -0600] "GET /category/edit/2
    HTTP/1.1" 200 723
    127.0.0.1 - - [12/Oct/2005:13:33:16 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    68.150.13.173 - - [12/Oct/2005:13:58:36 -0600] "GET / HTTP/1.0" 200 182
    68.150.13.173 - - [12/Oct/2005:14:29:34 -0600] "GET / HTTP/1.0" 200 182
    68.150.13.173 - - [12/Oct/2005:14:40:27 -0600] "GET / HTTP/1.0" 200 182
    68.150.43.29 - - [12/Oct/2005:14:42:09 -0600] "GET / HTTP/1.0" 200 182
    68.150.13.173 - - [12/Oct/2005:15:21:02 -0600] "GET / HTTP/1.0" 200 182
    68.150.1.188 - - [12/Oct/2005:15:21:13 -0600] "GET / HTTP/1.0" 200 182
    68.150.43.29 - - [12/Oct/2005:15:54:50 -0600] "GET / HTTP/1.0" 200 182
    127.0.0.1 - - [13/Oct/2005:10:02:06 -0600] "GET / HTTP/1.1" 304 -
    127.0.0.1 - - [13/Oct/2005:10:02:26 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    127.0.0.1 - - [13/Oct/2005:10:02:35 -0600] "GET /recipe/list HTTP/1.1"
    200 1639
    127.0.0.1 - - [13/Oct/2005:10:02:40 -0600] "GET /favicon.ico HTTP/1.1"
    404 612
    61.250.201.162 - - [13/Oct/2005:10:20:54 -0600] "GET / HTTP/1.0" 200
    182
    68.150.1.188 - - [13/Oct/2005:13:59:23 -0600] "GET / HTTP/1.0" 200 182
    68.150.130.51 - - [13/Oct/2005:17:34:24 -0600] "GET / HTTP/1.0" 200 182
    68.150.52.39 - - [13/Oct/2005:20:15:52 -0600] "GET / HTTP/1.0" 200 182
    64.213.53.210 - - [13/Oct/2005:20:51:23 -0600] "GET
    /scripts/..%255c%255c../winnt/system32/cmd.exe?/c+ver HTTP/1.0" 404 338
    68.150.51.203 - - [13/Oct/2005:21:16:15 -0600] "GET / HTTP/1.0" 200 182
    68.150.13.173 - - [13/Oct/2005:22:17:49 -0600] "GET / HTTP/1.0" 200 182
    68.150.31.77 - - [13/Oct/2005:22:59:23 -0600] "GET / HTTP/1.0" 200 182
    68.150.130.51 - - [14/Oct/2005:10:00:28 -0600] "GET / HTTP/1.0" 200 182
    68.150.130.51 - - [14/Oct/2005:10:11:02 -0600] "GET / HTTP/1.0" 200 182
    63.86.129.171 - - [14/Oct/2005:10:31:55 -0600] "GET
    /scripts/nsiislog.dll HTTP/1.1" 404 333

    And here's error.log:

    [Wed Oct 12 13:31:58 2005] [error] [client 127.0.0.1] Premature end of
    script headers: /recipe/list
    [Wed Oct 12 13:31:58 2005] [error] [client 127.0.0.1] scgi: error
    reading response headers
    [Thu Oct 13 20:51:23 2005] [error] [client 64.213.53.210] File does not
    exist: c:/instantrails/www/scripts/..%5c%5c/winnt/system32/cmd.exe
    [Fri Oct 14 10:31:55 2005] [error] [client 63.86.129.171] File does not
    exist: c:/instantrails/www/scripts/nsiislog.dll

    Hope this helps.
    Thanks,
    basi
     
    basi, Oct 14, 2005
    #10
  11. basi

    Curt Hibbs Guest

    ------=_Part_1455_22212810.1129314303261
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: quoted-printable
    Content-Disposition: inline

    First off, at this point it might be better if you subscribed to the Instan=
    t
    Rails mailing list so we can reduce the noise on ruby-talk:

    http://rubyforge.org/mail/?group_id=3D904

    I can't see any attempt to access phpMyAdmin in your access log below. For
    example, when I select the Instant Rails menu command "Configure >>
    Database", I get the following line in my access log:

    127.0.0.1 <http://127.0.0.1> - - [14/Oct/2005:13:16:14 -0500] "GET /mysql/
    HTTP/1.1" 200 2910

    Before you try again, clear out your logs so that they don't have a low of
    irrelevant junk in them.

    Curt

    ------=_Part_1455_22212810.1129314303261--
     
    Curt Hibbs, Oct 14, 2005
    #11
  12. basi

    basi Guest

    I am now a subscriber.
    Thanks,
    basi
     
    basi, Oct 14, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.