Long call to webservice generates "underlying connection was closed: An unexpected error occurred on


T

Techsatish

Hi,

while iam generating a crystal report which makes a webservice call for
the data from a

OLAP MDX queries creates a Message "Server was unable to process
request. --> The

underlying connection was closed: An unexpected error occurred on a
receive." Error.

i tried out creating a wrapper class for setting the webrequest
connection live settings

to false.

Class MyTestService
Inherits ReportsDataServices.ReportData
Protected Overrides Function GetWebRequest(ByVal uri As Uri) As


System.Net.WebRequest



Dim webRequest As System.Net.HttpWebRequest
webRequest = CType(MyBase.GetWebRequest(uri),
System.Net.HttpWebRequest)
'Setting KeepAlive to false
webRequest.KeepAlive = False
GetWebRequest = webRequest
End Function
End Class

and called them the new wrapper class.
Still the problem is not solved.Can somebody throw a idea on what went
wrong and how this

can be fixed?

note:
Here i run a start client making calls to a webservice for data and
binding to a crystal

report.data comes from a sql server anaylsis service mdx queries.

thanks
-satish
 
Ad

Advertisements

E

Egghead

Hi here,

No idea why you need a to have a wrapper class, just add the code in the web
service ref class.

Are you running WSE?

I try all of those below which I find from the web when I try to solve a
similar problem.

Are you running win2k3 on the server , go to check your error/system logs at
the server. Do you see something like "asp progress error" , ".net 2.0
error"?

- uninstall your .net 2.0 if you have .net 1.1 web app or web garden.
(something wrong here but Microsoft does not tell us) <- not work for me
- give the network service (assume the app running under that) the
administer right. ( Bill said full control on some reg, but the tool to find
out which reg will crash your pc), beside this solve a lot of other
permission problems <-not work for me
- disable DEP <- not work for me
- uncheck keep alive in the setting <-not work for me
- change asp session time out <-not work for me
- change http time out <-not work for me
- change the lanserver time out <- not work for me

I am sure two things - the app will work on IIS 5.0 with windows 2K, and
the web garden is not the problem. At the end, try to underinstall the sp1
<- I will try it later for my problem as well.

cheers,
Egghead
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top