.Net client times out but SOAP toolkit client does not

Discussion in 'ASP .Net Web Services' started by antopin, Sep 19, 2006.

  1. antopin

    antopin Guest

    Hello,
    I would greatly appreciate if someone could give me ideas on how to
    further investigate a problem that is affecting a customer.

    My application connects to a web service through a proxy server and via
    the internet. On upgrading to a new version, we found that the
    application could no longer talk to the web service.
    The old web service client was written with the SOAP toolkit and works
    OK, the new version uses .Net.
    The person monitoring the web service could see the request coming in
    from the client, but the client itself times out. I tried to increase
    the timeout to 3 minutes, to no avail.

    I tried the application to go through the SOAP trace tool, but I had no
    luck with this either, the app does not connect to the trace tool.

    Other things I verified:
    - The application uses the default proxy settings for the user it runs
    as;
    - I personally tested that I can call the web service via IE when I am
    logged on as that user on the client machine;
    - When performing the same operation from IE, I receive an
    instantaneous response;
    - The server framework build is the same as on my dev machine, i.e.
    1.1.4322.573
    - I made sure that the SOAP toolkit app still works in the same
    environment

    The web service client is written in c# and built on VS .Net 2003.

    TIA
    antopin
     
    antopin, Sep 19, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.