OnSelectedIndexChanged DDL not working now in .NET2. WebResource.axd culprit?

Discussion in 'ASP .Net' started by Groove, May 18, 2006.

  1. Groove

    Groove Guest

    (repost!)

    I have a simple and common scenario. I'm developing pages in VWD and FTP-ing
    them over to a test servr running Window 2003, NET2 Framework. On my page,
    I have a DDL that causes a postback and executes a sub when the value has
    changed. For some reason, it just quit working. I get a js error in IE6
    (but NOT in FF 1.5) and gives me a vague error about:

    'event' is null or not an object.Line X, character X.

    I try to find line X in my markup (view source) and it's nothing even close
    to the right line. I whip up a new test page and have a DDL change a
    label's text with OnSelectedIndexChanged and all works fine. Yet, my page
    that has worked for months just "stopped" working. I added a new DDL to
    the same page and called the same sub and got the same error.

    After doing some searching, I found this thread where this guy had the same
    problem: http://forums.asp.net/thread/1146679.aspx

    However, I don't really understand his workaround or the Project Conversion
    Wizard (huh?) solution from MS. I never converted this page from 1.1 to
    2.0. It has always been a 2.0 page created in VWD Express. After comparing
    the source code from my whipped up test page and my now failing page, I
    found this line in my failing page and it is NOT in my test page:

    <script
    src="/olga3/WebResource.axd?d=0SzioPWWyjhw2E9CY1GR8w2&amp;t=632749912169396975"
    type="text/javascript"></script>

    I looked and all of my pages in my .NET app have this line in browser source
    code. Yet, any NEW pages I create in this app don't show this in my source
    code on the test server.

    What is this line and why is it there? There is no WebResource.axd file on
    my test server. Could this be the problem? How did this happen? I
    recently did a massive Windows update - was the .NET2 framework recently and
    quietly updated causing this? What is my solution?

    I have uninstalled NET2 on the server and completely reinstalled it. I also
    deleted all files on the server and put fresh copies on it. Problem still
    occurs.

    Thanks in advance for all help!!
     
    Groove, May 18, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.