OT: But should be easy question for experienced MSVC6 users

Discussion in 'C++' started by Hamish, Aug 3, 2005.

  1. Hamish

    Hamish Guest

    I can't compile my MSVC6 project. It's very frustrating.

    2 errors:

    (1) C:\Proj1\File1.cpp(938) : fatal error C1010: unexpected end of file
    while looking for precompiled header directive

    Note, I had this error. Have commented out the entire contents, am still
    getting this error.


    (2) BSCMAKE: error BK1506 : cannot open file '.\Debug\File1.sbr': No such
    file or directory

    I have know idea what this is on about.
     
    Hamish, Aug 3, 2005
    #1
    1. Advertisements

  2. Please don't cross-post off-topic to comp.lang.c++, even after
    marking it OT. Thank you. Besides, I don't think your post
    belongs to m.p.v.mfc either. Try microsoft.public.vc.project_mgt
    or microsoft.public.vc.ide_general.
     
    Victor Bazarov, Aug 3, 2005
    #2
    1. Advertisements

  3. Hamish

    David Guest

    The project settings indicate precompiled headers should be used. That
    means
    that there should be a StdAfx.h file in every *.cpp file, and there should
    be
    a StdAfx.cpp in the project. These files are basically empty, except that
    they have headers that Windows considers useful for all compiles to have
    'precompiled'. It is just an optimization setting. You can also remove the
    error by unsetting the "use precomiled headers" option in the project
    settings.
    I recall that this is one of the files created to support browsing. A
    full
    build might create the file. I'm not sure on that though.
    David
     
    David, Aug 3, 2005
    #3
  4. Hamish

    Peter Julian Guest

    Learn how to use your compiler. Project / settings / C++ tab / precompiled
    headers (set to "All Configurations") / Not using precompiled headers.

    And finally, remove any #include "stdafx.h" in your project

    Take the time to read and comprehend the error codes. That one is obvious.
     
    Peter Julian, Aug 3, 2005
    #4
  5. Hamish

    daydaydayu Guest

    Menu "Project" > Settings > C/C++ Tab >
    Category: Precomplied Headers
    Choose "Not using precompiled headers"
     
    daydaydayu, Aug 3, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.