Prerelease of Ruby-pg 0.9.0


M

Michael Granger

Hi All,

I'd like to announce the imminent release of version 0.9.0 of the
ruby-pg library, the Ruby interface to the PostgreSQL RDBMS.

The 0.9.0 version has some fairly significant changes to the backend,
especially for Ruby 1.9.1 and Windows users, so we'd like to have people
test it out in their own environments before we release it to the world.

To that end, I've pushed up a prerelease version of the gem for people
to test out. If you'd like to help out, you can install the prerelease
like so:

gem install pg --prerelease

You can check to see if you have the new version loaded by checking the
PGconn::VERSION constant; it was added in this release, so if you have
one and it's '0.9.0', then you're good.

If you do decide to test, and you find a problem, please submit a ticket
via the project's tracker here:

http://bitbucket.org/ged/ruby-pg/issues/new/

If you test it and it works, I'd really appreciate a note to that effect
either via personal email or in reply to this post, even if you just
send "it worked" and your platform, Ruby version, and PostgreSQL version.

There are very few changes to existing methods in this release, so we
don't anticipate there will be much need to change existing code. If you
want to see the details of what has changed, and can't wait for the
release announcement sometime next week (barring any serious problems),
the changeset history for the release can be found here:

http://bitbucket.org/ged/ruby-pg/changesets/9c65eb905416:7fbe4187e9e5/

Thanks!
 
Ad

Advertisements

J

Jack Christensen

Hi All,

I'd like to announce the imminent release of version 0.9.0 of the
ruby-pg library, the Ruby interface to the PostgreSQL RDBMS.

The 0.9.0 version has some fairly significant changes to the backend,
especially for Ruby 1.9.1 and Windows users, so we'd like to have people
test it out in their own environments before we release it to the world.

To that end, I've pushed up a prerelease version of the gem for people
to test out. If you'd like to help out, you can install the prerelease
like so:

gem install pg --prerelease

You can check to see if you have the new version loaded by checking the
PGconn::VERSION constant; it was added in this release, so if you have
one and it's '0.9.0', then you're good.

If you do decide to test, and you find a problem, please submit a ticket
via the project's tracker here:

http://bitbucket.org/ged/ruby-pg/issues/new/

If you test it and it works, I'd really appreciate a note to that effect
either via personal email or in reply to this post, even if you just
send "it worked" and your platform, Ruby version, and PostgreSQL version.

There are very few changes to existing methods in this release, so we
don't anticipate there will be much need to change existing code. If you
want to see the details of what has changed, and can't wait for the
release announcement sometime next week (barring any serious problems),
the changeset history for the release can be found here:

http://bitbucket.org/ged/ruby-pg/changesets/9c65eb905416:7fbe4187e9e5/

Thanks!
I gave it a quick test on ruby 1.8.7 (2010-01-10 patchlevel 249)
[i386-mingw32]. Worked fine.

Jack
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top