Problem in data insert

D

Deep

Dear friends

I am using asp code and ms access to insert data. But I am getting
error
Error Type:
Microsoft JET Database Engine (0x80004005)
Operation must use an updateable query.
/sachin/test.asp, line 24

I checked permission every where I think read, write permission is
given every where. Please tell me what is the problem. I am using
using ms access 2007 and windows XP.

Its urgent

Thanks in advance
vinod kumar
 
B

Bob Barrows

Deep said:
Dear friends

I am using asp code and ms access to insert data. But I am getting
error
Error Type:
Microsoft JET Database Engine (0x80004005)
Operation must use an updateable query.
/sachin/test.asp, line 24

I checked permission every where I think read, write permission is
given every where. Please tell me what is the problem. I am using
using ms access 2007 and windows XP.
Assuming this is a simple single-table insert, and not an update that
involves multiple joined tables, then this is almost always a
permissions problem.
http://www.aspfaq.com/show.asp?id=2062


Modify Permissions on the _folder_ containing the database must be
granted to all users of the database. The problem is usually in
identifying who the user is. The identity of the user depends on the
authentication mode of your website. If Anonymous is enabled, then you
must grant permission to the IUSR accounts on the machine.

The only time it isn't a permissions problem is when the database file
attributes are set to read-only.
 
N

news

Hello vinod kumar

See if this will assist you

==================================
To fix this issue do the following

Right click on your Database (Access in this case)
(or) if you are dealing with a lot of database's or will be in the future,
then
Right click on the wwwroot (or) the website folder and perform the following
(or)
If you are going to store all your database's in a single location/folder
Then Right click on that folder and perform the following.


Go to: [Properties]
Then choose the [Security] tab.

Make sure that you have the [Internet Guest Account]
Listed in the [Group or user names:] Area.
If it is, then give it [Write] permissions.
If it is not, then add it to the list.
Then give it all permissions.


Click on [Add]
Click on [Advanced]
Click on [Find Now]

Choose:
IUSER_Your-Computer-Name
IWAM_Your-Computer-Name

Click [OK]
Then [OK]

Give both accounts
[Write] Permissions

Click [Apply] then [OK]


(If Security Tab is not available)
In Windows Explorer, go to
Tools/Folder Options/View and click to turn off 'Use simple file sharing' at
the bottom of the list.
==================================

www.picdrive.net
Wayne
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,794
Messages
2,569,641
Members
45,355
Latest member
SJLChristi

Latest Threads

Top