Problem with jabberd-1.4.2, xdb_auth_cpile.smb and Jabber::Connection

Discussion in 'Perl Misc' started by tylernt, May 13, 2004.

  1. tylernt

    tylernt Guest

    I'm afraid xdb_auth_cpile.pl isn't working with my Jabber server. It
    worked ok in a small test environment but when I got more than, oh, 3
    or 4 users logged on to the Jabber server, Jabber would get slower and
    slower and eventually stop allowing logins and stop passing messages
    after 1-5 minutes. It seemed to be related to someone trying to log in
    with a bad username/password... the server seemed to die very quickly
    after a failed login attempt was logged in record.log. Sometimes, the
    xdb_auth_cpile.pl process would die, other times it would keep
    running.

    I noticed sometimes when I stopped the unresponsive jabberd, I would
    get this:

    Use of uninitialized value in concatenation (.) or string at
    /usr/lib/perl5/site_perl/5.8.0/Jabber/Connection.pm line 416.

    Use of uninitialized value in subroutine entry at
    /usr/lib/perl5/site_perl/5.8.0/i386-linux/XML/Parser/Expat.pm line
    614.

    I started out with Jabber::Connection 0.03 but encountered problems
    with jabberd segfaulting (the 'memory leak issue', presumably), so I
    switched to 0.04, which caused the above problem.

    I'm running jabberd-1.4.2 and using xdb_auth_cpile to authenticate
    against a Win2k AD domain with smb. Jabberd worked fine prior to the
    upgrade to xdb_auth_cpile.

    Any ideas or suggestions?
     
    tylernt, May 13, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.