rake doesnt work


A

Anthony Ob

Building native extensions. This could take a while...
ERROR: Error installing ruby-opengl-0.60.1.gem:
ERROR: Failed to build gem native extension.

"/home/anthony/.rvm/rubies/ruby-1.9.2-p180/bin/ruby" -rubygems
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/bin/rake
RUBYARCHDIR=/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/lib
RUBYLIBDIR=/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/lib
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/bin/ruby mkrf_conf.rb
(in /home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1)
rake
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems.rb:370:in
`bin_path': can't find gem rake ([">= 0"]) with executable rake
(Gem::GemNotFoundException)
from /home/anthony/.rvm/gems/ruby-1.9.2-p180/bin/rake:19:in `<main>'
rake aborted!
Command failed with status (1): [rake...]
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:993:in
`block in sh'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1008:in
`call'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1008:in
`sh'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1092:in
`sh'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:8:in
`block in rake'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:7:in
`chdir'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:7:in
`rake'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:65:in
`block in setup_extension'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:634:in
`call'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:634:in
`block in execute'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:629:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:629:in
`execute'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:595:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:605:in
`block in invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:594:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:605:in
`block in invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:594:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:581:in
`invoke'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2041:in
`invoke_task'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`block (2 levels) in top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`block in top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2058:in
`standard_exception_handling'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2013:in
`top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1992:in
`run'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/bin/rake:31:in
`<main>'


Gem files will remain installed in
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1 for
inspection.
Results logged to
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/./gem_make.out
 
Ad

Advertisements

J

Josh Cheek

[Note: parts of this message were removed to make it a legal post.]

Building native extensions. This could take a while...
ERROR: Error installing ruby-opengl-0.60.1.gem:
ERROR: Failed to build gem native extension.

"/home/anthony/.rvm/rubies/ruby-1.9.2-p180/bin/ruby" -rubygems
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/bin/rake

RUBYARCHDIR=/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/lib

RUBYLIBDIR=/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/lib
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/bin/ruby mkrf_conf.rb
(in /home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1)
rake

/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems.rb:370:in
`bin_path': can't find gem rake ([">= 0"]) with executable rake
(Gem::GemNotFoundException)
from /home/anthony/.rvm/gems/ruby-1.9.2-p180/bin/rake:19:in `<main>'
rake aborted!
Command failed with status (1): [rake...]
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:993:in
`block in sh'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1008:in
`call'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1008:in
`sh'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1092:in
`sh'

/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:8:in
`block in rake'

/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:7:in
`chdir'

/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:7:in
`rake'

/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/mkrf-0.2.3/lib/mkrf/rakehelper.rb:65:in
`block in setup_extension'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:634:in
`call'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:634:in
`block in execute'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:629:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:629:in
`execute'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:595:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:605:in
`block in invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:594:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:605:in
`block in invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:602:in
`invoke_prerequisites'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:594:in
`block in invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/monitor.rb:201:in
`mon_synchronize'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:588:in
`invoke_with_call_chain'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:581:in
`invoke'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2041:in
`invoke_task'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`block (2 levels) in top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`each'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2019:in
`block in top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2058:in
`standard_exception_handling'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:2013:in
`top_level'
/home/anthony/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/1.9.1/rake.rb:1992:in
`run'
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/bin/rake:31:in
`<main>'


Gem files will remain installed in
/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1 for
inspection.
Results logged to

/home/anthony/.rvm/gems/ruby-1.9.2-p180/gems/ruby-opengl-0.60.1/./gem_make.out
I had difficulty with this too, if I recall, I googled for it, and
eventually found a solution like the one by Luis Lavena here (
http://stackoverflow.com/questions/3614435/cant-find-rake-on-ruby-rails-install).
However, I experienced further issues after this, and eventually gave up. I
don't recall what they were, I think the gem was stale or something (it
hasn't been updated in a year).
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top