Stepping into my web service


P

pbd22

Hi.

I keep getting a timeout exception when attempting to step into my web
service methods.

I have tried Service Trace Viewer and am seeing the following
exception message there:

<ExceptionString>System.ServiceModel.FaultException: The message with
To 'http://localhost:8731/Design_Time_Addresses/Trade/mex/mex' cannot
be processed at the receiver, due to an AddressFilter mismatch at the
EndpointDispatcher. Check that the sender and receiver's
EndpointAddresses agree.</ExceptionString>

I notice that, in the exception, it is talking about a metadata
endpoint with mex/mex at the end and am wondering if this could be
causing the problem? I have checked my Web.config and do not see mex/
mex but only 'http://localhost:8731/Design_Time_Addresses/Trade.

Any thoughts out there on what might be causing the problem (and what
I need to do to resolve it)?

Thanks in advance.
 
Ad

Advertisements

P

pbd22

One more thing...

I am able to successfully invoke my method using the WCF Test Client
but the same method hangs and fails when invoked when I run my web
(this is a web project) application.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top