vpython

Discussion in 'Python' started by kimjeng, Aug 21, 2010.

  1. kimjeng

    kimjeng Guest

    im trying to build visual python on slackware 64bit 13.1 and i can
    not get beyond the configure stage,

    ....
    checking whether the g++ linker (/usr/x86_64-slackware-linux/bin/ld -m
    elf_x86_64) supports shared libraries... yes
    checking dynamic linker characteristics... GNU/Linux ld.so
    checking how to hardcode library paths into programs... immediate
    checking whether to enable maintainer-specific portions of
    Makefiles... no
    checking for some Win32 platform... no
    checking for some Mac OSX platform... no
    checking for a Python interpreter with version >= 2.2... python
    checking for python... /usr/bin/python
    checking for python version... 2.6
    checking for python platform... linux2
    checking for python script directory... ${prefix}/lib64/python2.6/site-
    packages
    checking for python extension module directory... ${exec_prefix}/lib64/
    python2.6/site-packages
    checking for array in python module numpy... yes
    checking for headers required to compile python extensions... found
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for GTKGLEXTMM... no
    configure: error: gtkglextmm 1.2 is required
    mike@darkstar:~/soft/scinvis/visual-5.32_release$



    the thing is i have installed gtkglextmm both from source and via a
    slackbuilds package script and i still get the same error,
    help would be a appreciated
     
    kimjeng, Aug 21, 2010
    #1
    1. Advertisements

  2. kimjeng

    Anssi Saari Guest

    You'll just have to check what it is configure actually tests for and
    figure out from that why your system doesn't pass.
     
    Anssi Saari, Aug 22, 2010
    #2
    1. Advertisements

  3. kimjeng

    kimjeng Guest

    thanks
    here's something i noticed

    ....
    Package gtkglextmm-1.2 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtkglextmm-1.2.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'gtkglextmm-1.2' found
    ....

    the configure script is looking for gtkglextmm-1.2.pc , a file that
    does not exist, what i do have is gtkglext-1.0.pc , im wondering why
    i have the 1.0. version while i built the 1.2. source , plus the 'mm'
    in the name is missing from the name of my .pc files
    thanks
     
    kimjeng, Aug 23, 2010
    #3
  4. The mm in the name is for a C++ binding for the library. Make sure you
    install both gtkglext and gtkglextmm packages.
     
    Burton Samograd, Aug 23, 2010
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.