win32 perl compiling problem

Discussion in 'Perl Misc' started by Thomas Steinbach, Feb 8, 2009.

  1. Hello NG,

    I got an error if I try to compile perl with mingw (Vista)
    btw: no problems with VS2008SP1 but mingw doesn't work.

    generate_uudmap.exe has stopped working

    but don't know how to fix the error.

    at the command line I got the messages
    ...\generate_uudmap.exe >..\uudmap.h
    dmake.exe: Error code 133, while making '..\uudmap.h'
    dmake.exe: '..\uudmap.h' removed.

    Does anybody know what this error mean and
    what I can do to get this compiling?

    Thomas Steinbach, Feb 8, 2009
    1. Advertisements

  2. Hello Bob,
    I know this distribution. But this is not a free
    distribution and I can't distribute this comercial
    product. I need a "free" distribution which I can
    distribute by myself and which is running from a
    CD. Strawberry perl would be fine, but I don't
    know how to configure it, because strawbery Perl
    is not very good documented. In case of this I
    started to build perl on my own. But still need
    more information how to get perl running.

    If somebody knows a tutorial/wiki and how to get
    perl running on windows, please let me know.

    Thomas Steinbach, Feb 9, 2009
    1. Advertisements

  3. No, you are wrong. ActiveState Perl is free (free as in free of charge).
    ActiveState is offering an OEM license for that purpose.
    Why can't you simply point your customers to or even
    make the download and automated part of your installation?

    Jürgen Exner, Feb 9, 2009
  4. Thomas Steinbach

    sisyphus Guest

    Which version of perl are you trying to build ? ... and from where did
    you obtain the source ?
    Also which version of gcc are you using ?

    I've recently built both perl-5.10.0 and perl-5.8.9 using (the MinGW
    port of) gcc-3.4.5, from official perl source code on Vista - and I
    haven't struck any trouble.

    Looking at
    it seems I've come across the same issue at some stage, but I can't
    really recall the problem. You'll see that, in the second of those 2
    posts, I've suggested that the issue can be fixed if
    binutils-2.17.50-20060824-1 (or later, I presume) is installed.


    sisyphus, Feb 9, 2009
  5. Hello Juergen,
    this means it is not freeware. Visual C++ Express is also
    free of charge, but it's not freeware.
    Alows this OEM licence to put active State perl
    in a runnable style on a CD and distribute it?
    And is this OEM license and the AS perl still
    free of charge? Would be fine but I don't think so.
    if I point my users to ActiveState the perl script
    won't run. The perl script(s) should run from a CD
    I can't put activestate perl in a runnable verson
    on my CD and distribute this CD.
    That is not very helpful.

    Thomas Steinbach, Feb 9, 2009
  6. Hello Sisyphus,

    First I tried to build version 5.10.0 (think it's 5.10.1004)
    and the source is from which points to
    perl-5.10.0.tar.gz at
    Then I tried perl-5.10.0.tar.gz available at
    but I think that are the same files/version.

    Should I use/try an another version?
    Which version of winapi and mingw-runtime did you use?
    What else?
    I tried it with gcc 3.4.5 and this binutils-2.17.50-20060824-1
    version of binutils. but it still doesn't compile :-(

    I also tried binutils-2.17.50-20070129-1.tar.gz and
    the newest version binutils-2.19.1-mingw32-bin.tar.gz
    btw: w32api-3.12 and w32api-3.13, and with mingwrt-3.15.1
    and mingwrt-3.15.2 but it doesn't compile.

    Even gcc version 3.4.2 (binutils-2.16.91-20060119-1.tar,
    winapi 3.10) doesn't compile.

    The error with "generate_uudmap.exe" still comes up.
    (always on a clean source tree with modified
    win32/ an this modifications:

    line 56 USE_SITECUST *= define

    line 215 CCHOME *= D:\download\perl\mingw3_bu_2.17.50

    where my mingw is currently located.
    The path ist set like:

    set PATH2CC=D:\download\perl\mingw3_bu_2.17.50
    set CCVER=3.4.5
    set PATH=%PATH2CC%\bin;%PATH2CC%\libexec\gcc\mingw32\%CCVER%;%PATH%

    dmake from is in the path

    What else can I do and how can I "debug" this error?

    Thomas Steinbach, Feb 9, 2009
  7. Hello Sisyphus,
    I tried know the "latest"
    version which is perl 5.8.9 but now I got an error
    (segfault) with "perlglob.exe" with the current
    mingw gcc 3.4.5 and bu 2.17.50_20060824 and with
    the newest binutils-2.19.1 too. :-(

    at the command prompt I get:
    C:\opt\bin\dmake.exe -S
    ...\..\..\miniperl.exe "-I..\..\..\lib" ..\bin\enc2xs -"Q" -"O" -o
    byte_t.c -f byte_t.fnm
    Use of uninitialized value in -f at ..\bin\enc2xs line 155.
    Use of uninitialized value in concatenation (.) or string at ..\bin\enc2xs
    line 156.
    Use of uninitialized value in concatenation (.) or string at ..\bin\enc2xs
    line 156.
    Cannot open :No such file or directory at ..\bin\enc2xs line 156.
    dmake: Error code 130, while making 'byte_t.c'
    dmake.exe: Error code 255, while making 'subdirs'
    Unsuccessful make(Encode): code=65280 at line 152.
    dmake.exe: Error code 130, while making 'Extensions'


    btw: the copile runs on a fat32 system and no
    rghts (read/write/exec) problem should come up.
    I also have full access (Administrator) to the
    programs at C:

    Thomas Steinbach, Feb 9, 2009
  8. Thomas Steinbach

    sisyphus Guest

    There were initially some problems with Vista and MinGW, and many of
    those problems were fixed when I installed Vista Service Pack 1. So,
    if you haven't already, I would try installing SP1. (Note that Windows
    Update doesn't automatically install SP1 for you - you have to install
    it yourself.) I don't know if that's going to help. By the time SP1
    arrived, MinGW had been pretty well patched up to work with Vista -
    but if you've got one of the earlier versions of 3.4.5, installing SP1
    may be the solution.

    Or try updating to the latest MinGW components - gcc-3.4.5-20060117-3,
    GNU binutils-2.19.1, w32api-3.13, and mingwrt-3.15.2 from . (Just
    unpack them over the top of your existing installation.)

    Of course, now that I've got SP1, I can no longer check up on any of
    those original MinGW/Vista issues.

    Other than that, I would raise the issue on p5p - where you'll get
    some assistance from people who are both passionate and knowledgeable
    as regards building perl with MingW. It *should* be trivial to build
    perl with MinGW on Windows (including Vista).

    sisyphus, Feb 9, 2009
  9. Hello Rob,
    I got it and it works fine. :)
    The binutils version 2.17.50-20060824-1 are (today 2009-02-10)
    definitely the _last_ version of binutils which are able to
    successfull compile perl 5.8.x and 5.10.x (still have problems with
    5.6.x, but that is not so important.) I tested all other versions
    higher than this version of binutils and always got the
    "generate_uudmap.exe" segfault. Still don't know why...
    The other parts of mingw gcc can be the newest versions.
    (winapi, mingw rt, etc.)

    The other errors I encounterd was the result because
    I forgot something to do with the external libs.
    Now I know the secrets and it works fine. Thank you
    for your help.
    yes, now it is trivial :)
    But what is p5p? (I'm still new to perl)

    Thomas Steinbach, Feb 10, 2009
  10. A. Sinan Unur, Feb 10, 2009
  11. Thomas Steinbach

    sisyphus Guest

    Thanks for confirming that it's the binutils version that makes the
    difference. Looks like I had better be a little cautious when it comes
    to updating binutils :)

    I've built 5.6.0, 5.6.1 and 5.6.2 with MinGW in the past and
    experienced no difficulty - but that was a while ago, and not on this
    Vista box. I don't see any need to be using 5.6.x on Windows (or
    anywhere else for that matter).

    I could never get 5.8.0 to build, but from 5.8.3 onwards, I've had no
    trouble (except briefly with that binutils isue) on both XP and Vista.

    sisyphus, Feb 11, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.