Can't create projects / open projects

Discussion in 'ASP .Net' started by jaredea, Jun 9, 2005.

  1. jaredea

    jaredea Guest

    I have the following setup:

    SBS 2003 Server
    Windows 2003 Enterprise Server (setup as an Application Server)
    Windows XP Pro Desktop

    Both the Application server and desktop have Visual Studio 2003 on
    them as well as the .NET Framework 1.1

    I started to use .NET on the desktop to test things out...then i setup
    the 2003 server and now i'm trying to develop to that server but am
    having a heck of a time getting it to work...

    If i try to create or open a new project using localhost i get the:

    "visual studio .net has detected that the specified web server is not
    running asp.net version 1.1"

    error...

    If i create a project on the dev server in Visual Studio and run it it
    works fine...

    If i try and use the dev server's IP address to create a project, i
    get a long error i didn't want to type here, but have a screen shot of
    it:

    www.prolooksports.com/VB/error.gif

    I've tried everything i can think of, from:

    -running aspnet_regiis.exe -i
    -adding the desktop user to the VS Developers group
    -creating a Get_aspx_ver.aspx file and putting it in the root web per
    these instructions:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;825792
    -hitting my head against the wall...

    If i type localhost from the desktop, it takes me to its own IIS 5.1
    and not the DEV server...

    i have a feeling that having the SBS 2003 in the mix and IIS on the
    desktop is keeping things from flowing...

    any ideas - i've been trying to troubleshoot this for hours with no
    luck...

    jared
     
    jaredea, Jun 9, 2005
    #1
    1. Advertising

  2. Hi,

    What are the different versions of framework you have?

    You could specifiy ASP.NET should run under 1.1 in IIS Properties.

    --
    HTH,
    Rakesh Rajan
    MVP, MCSD
    http://www.msmvps.com/rakeshrajan/



    "jaredea" wrote:

    > I have the following setup:
    >
    > SBS 2003 Server
    > Windows 2003 Enterprise Server (setup as an Application Server)
    > Windows XP Pro Desktop
    >
    > Both the Application server and desktop have Visual Studio 2003 on
    > them as well as the .NET Framework 1.1
    >
    > I started to use .NET on the desktop to test things out...then i setup
    > the 2003 server and now i'm trying to develop to that server but am
    > having a heck of a time getting it to work...
    >
    > If i try to create or open a new project using localhost i get the:
    >
    > "visual studio .net has detected that the specified web server is not
    > running asp.net version 1.1"
    >
    > error...
    >
    > If i create a project on the dev server in Visual Studio and run it it
    > works fine...
    >
    > If i try and use the dev server's IP address to create a project, i
    > get a long error i didn't want to type here, but have a screen shot of
    > it:
    >
    > www.prolooksports.com/VB/error.gif
    >
    > I've tried everything i can think of, from:
    >
    > -running aspnet_regiis.exe -i
    > -adding the desktop user to the VS Developers group
    > -creating a Get_aspx_ver.aspx file and putting it in the root web per
    > these instructions:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;825792
    > -hitting my head against the wall...
    >
    > If i type localhost from the desktop, it takes me to its own IIS 5.1
    > and not the DEV server...
    >
    > i have a feeling that having the SBS 2003 in the mix and IIS on the
    > desktop is keeping things from flowing...
    >
    > any ideas - i've been trying to troubleshoot this for hours with no
    > luck...
    >
    > jared
    >
     
    =?Utf-8?B?UmFrZXNoIFJhamFu?=, Jun 9, 2005
    #2
    1. Advertising

  3. Hi, Jaredea.

    re:
    > "visual studio .net has detected that the specified web server is not
    > running asp.net version 1.1"


    1. Check to see that you have enabled ASP.NET 1.1

    IIS 6.0 requires that you enable any web service extension you use.
    To do that, open the IIS mmc, scroll down to the "Web Service Extensions"
    node ( on the left-hand side, right after the "Websites" node ),
    select the ASP.NET v1.1.4322 extension on the right-hand side,
    and click the "Allow" button.

    If you also want to develop for ASP.NET 2.0, enable that, too.

    2. Remember that you need to run 1.1 apps and 2.0 apps in separate Application
    Pools, so if you're going to use both 1.1 and 2.0, create a new application pools,
    assign all 1.1 apps to it and use the DefaultAppPool for 2.0 apps.

    re:
    > If i try and use the dev server's IP address to create a project, i
    > get a long error i didn't want to type here, but have a screen shot of
    > it: www.prolooksports.com/VB/error.gif


    Please read http://support.microsoft.com/kb/320265/EN-US/
    and follow the instructions on it.





    Juan T. Llibre
    ASP.NET MVP
    http://asp.net.do/foros/
    Foros de ASP.NET en Español
    Ven, y hablemos de ASP.NET...
    ======================

    "jaredea" <> wrote in message
    news:...
    >I have the following setup:
    >
    > SBS 2003 Server
    > Windows 2003 Enterprise Server (setup as an Application Server)
    > Windows XP Pro Desktop
    >
    > Both the Application server and desktop have Visual Studio 2003 on
    > them as well as the .NET Framework 1.1
    >
    > I started to use .NET on the desktop to test things out...then i setup
    > the 2003 server and now i'm trying to develop to that server but am
    > having a heck of a time getting it to work...
    >
    > If i try to create or open a new project using localhost i get the:
    >
    > "visual studio .net has detected that the specified web server is not
    > running asp.net version 1.1"
    >
    > error...
    >
    > If i create a project on the dev server in Visual Studio and run it it
    > works fine...
    >
    > If i try and use the dev server's IP address to create a project, i
    > get a long error i didn't want to type here, but have a screen shot of
    > it:
    >
    > www.prolooksports.com/VB/error.gif
    >
    > I've tried everything i can think of, from:
    >
    > -running aspnet_regiis.exe -i
    > -adding the desktop user to the VS Developers group
    > -creating a Get_aspx_ver.aspx file and putting it in the root web per
    > these instructions:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;825792
    > -hitting my head against the wall...
    >
    > If i type localhost from the desktop, it takes me to its own IIS 5.1
    > and not the DEV server...
    >
    > i have a feeling that having the SBS 2003 in the mix and IIS on the
    > desktop is keeping things from flowing...
    >
    > any ideas - i've been trying to troubleshoot this for hours with no
    > luck...
    >
    > jared
     
    Juan T. Llibre, Jun 9, 2005
    #3
  4. jaredea

    jaredea Guest

    Thank you both...the strange thing is i did check to make sure that
    ASP.NET was enabled, but then i did some other stuff
    (remove/re-install) and i guess it disabled...so, now i'm not getting
    the "...server not running asp..." -- but still have the other issues
    with creating a project (although a slightly different error) and now
    that i can open a previous project we worked on before getting the new
    servers I can't debug...here are the errors:

    Debugging Error:

    "Error while trying to run project: Unable to start debugging on the
    web server. The debugger component on the server failed to connect to
    the local machine."

    I added the user to the Debuggers group and that didn't help...




    Error trying to create a new project:

    I've posted screen shots of these 2 errors because they are pretty
    long...the first screen shows what comes up when i try to do a new
    project (in VS 2003 i went into: tools > options > Projects and
    solutions > Visual Studio Projects Location > and changed the location
    to the W: drive which is mapped to the Web Server where our files are
    located.) The second screen is the error that comes up....

    Here are the screen shots:

    http://www.prolooksports.com/vb/1.gif
    http://www.prolooksports.com/vb/2.gif


    jared


    On Wed, 08 Jun 2005 21:29:46 -0600, jaredea <> wrote:

    >I have the following setup:
    >
    >SBS 2003 Server
    >Windows 2003 Enterprise Server (setup as an Application Server)
    >Windows XP Pro Desktop
    >
    >Both the Application server and desktop have Visual Studio 2003 on
    >them as well as the .NET Framework 1.1
    >
    >I started to use .NET on the desktop to test things out...then i setup
    >the 2003 server and now i'm trying to develop to that server but am
    >having a heck of a time getting it to work...
    >
    >If i try to create or open a new project using localhost i get the:
    >
    > "visual studio .net has detected that the specified web server is not
    >running asp.net version 1.1"
    >
    >error...
    >
    >If i create a project on the dev server in Visual Studio and run it it
    >works fine...
    >
    >If i try and use the dev server's IP address to create a project, i
    >get a long error i didn't want to type here, but have a screen shot of
    >it:
    >
    >www.prolooksports.com/VB/error.gif
    >
    >I've tried everything i can think of, from:
    >
    >-running aspnet_regiis.exe -i
    >-adding the desktop user to the VS Developers group
    >-creating a Get_aspx_ver.aspx file and putting it in the root web per
    >these instructions:
    >http://support.microsoft.com/default.aspx?scid=kb;en-us;825792
    >-hitting my head against the wall...
    >
    >If i type localhost from the desktop, it takes me to its own IIS 5.1
    >and not the DEV server...
    >
    >i have a feeling that having the SBS 2003 in the mix and IIS on the
    >desktop is keeping things from flowing...
    >
    >any ideas - i've been trying to troubleshoot this for hours with no
    >luck...
    >
    >jared
     
    jaredea, Jun 10, 2005
    #4
  5. I am having the same problem. I do not see a Web Service Extension nod in
    IIS. Do you know why?
    --
    Marie


    "Juan T. Llibre" wrote:

    > Hi, Jaredea.
    >
    > re:
    > > "visual studio .net has detected that the specified web server is not
    > > running asp.net version 1.1"

    >
    > 1. Check to see that you have enabled ASP.NET 1.1
    >
    > IIS 6.0 requires that you enable any web service extension you use.
    > To do that, open the IIS mmc, scroll down to the "Web Service Extensions"
    > node ( on the left-hand side, right after the "Websites" node ),
    > select the ASP.NET v1.1.4322 extension on the right-hand side,
    > and click the "Allow" button.
    >
    > If you also want to develop for ASP.NET 2.0, enable that, too.
    >
    > 2. Remember that you need to run 1.1 apps and 2.0 apps in separate Application
    > Pools, so if you're going to use both 1.1 and 2.0, create a new application pools,
    > assign all 1.1 apps to it and use the DefaultAppPool for 2.0 apps.
    >
    > re:
    > > If i try and use the dev server's IP address to create a project, i
    > > get a long error i didn't want to type here, but have a screen shot of
    > > it: www.prolooksports.com/VB/error.gif

    >
    > Please read http://support.microsoft.com/kb/320265/EN-US/
    > and follow the instructions on it.
    >
    >
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > http://asp.net.do/foros/
    > Foros de ASP.NET en Español
    > Ven, y hablemos de ASP.NET...
    > ======================
    >
    > "jaredea" <> wrote in message
    > news:...
    > >I have the following setup:
    > >
    > > SBS 2003 Server
    > > Windows 2003 Enterprise Server (setup as an Application Server)
    > > Windows XP Pro Desktop
    > >
    > > Both the Application server and desktop have Visual Studio 2003 on
    > > them as well as the .NET Framework 1.1
    > >
    > > I started to use .NET on the desktop to test things out...then i setup
    > > the 2003 server and now i'm trying to develop to that server but am
    > > having a heck of a time getting it to work...
    > >
    > > If i try to create or open a new project using localhost i get the:
    > >
    > > "visual studio .net has detected that the specified web server is not
    > > running asp.net version 1.1"
    > >
    > > error...
    > >
    > > If i create a project on the dev server in Visual Studio and run it it
    > > works fine...
    > >
    > > If i try and use the dev server's IP address to create a project, i
    > > get a long error i didn't want to type here, but have a screen shot of
    > > it:
    > >
    > > www.prolooksports.com/VB/error.gif
    > >
    > > I've tried everything i can think of, from:
    > >
    > > -running aspnet_regiis.exe -i
    > > -adding the desktop user to the VS Developers group
    > > -creating a Get_aspx_ver.aspx file and putting it in the root web per
    > > these instructions:
    > > http://support.microsoft.com/default.aspx?scid=kb;en-us;825792
    > > -hitting my head against the wall...
    > >
    > > If i type localhost from the desktop, it takes me to its own IIS 5.1
    > > and not the DEV server...
    > >
    > > i have a feeling that having the SBS 2003 in the mix and IIS on the
    > > desktop is keeping things from flowing...
    > >
    > > any ideas - i've been trying to troubleshoot this for hours with no
    > > luck...
    > >
    > > jared

    >
    >
    >
     
    =?Utf-8?B?TWFyaWU=?=, Aug 10, 2005
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. WJ
    Replies:
    2
    Views:
    1,751
  2. ad
    Replies:
    1
    Views:
    328
    clintonG
    Apr 14, 2005
  3. Replies:
    4
    Views:
    967
    Timo Stamm
    Feb 24, 2006
  4. Joe Delphi

    Can't Open Any ASP Projects - HELP!

    Joe Delphi, May 7, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    437
  5. eddie wang
    Replies:
    0
    Views:
    426
    eddie wang
    Oct 3, 2003
Loading...

Share This Page