Decimal value setting problem (ASP & ADODB.Recordset value & MSSQLServer & 2003 Server)

Discussion in 'ASP General' started by avcitamer, Sep 17, 2008.

  1. avcitamer

    avcitamer Guest

    We upgraded our system and problem below occured, pleas help me...

    Windows 2003 server SP1
    When I set a decimal DB field value to "123,32" (using
    ADODB.recordset ) updated value was ok (123.32)

    Windows 2003 server SP2
    Now when I set a decimal DB field value to "123,32" (using
    ADODB.recordset ) updated value is (123.32)

    Thanks

    Systems
    Windows 2003 server Enterprise SP2
    SqlServer 2000 SP4
    Activex Data Object 2.8~
    IIS7, Classsical ASP
    avcitamer, Sep 17, 2008
    #1
    1. Advertising

  2. avcitamer

    avcitamer Guest

    Re: Decimal value setting problem (ASP & ADODB.Recordset value &MSSQL Server & 2003 Server)

    !!! Correction....!!!
    in the second state updated value is (12332) ... sory...


    On 17 Eylül, 14:25, avcitamer <> wrote:
    > We upgraded our system and problem below occured, pleas help me...
    >
    >     Windows 2003 server SP1
    >         When I set a decimal DB field value to "123,32" (using
    > ADODB.recordset ) updated value was ok (123.32)
    >
    >     Windows 2003 server SP2
    >         Now when I set a decimal DB field value to "123,32" (using
    > ADODB.recordset ) updated value is (123.32)
    >
    > Thanks
    >
    > Systems
    >         Windows 2003 server Enterprise SP2
    >         SqlServer 2000 SP4
    >         Activex Data Object 2.8~
    >         IIS7, Classsical ASP
    avcitamer, Sep 17, 2008
    #2
    1. Advertising

  3. Re: Decimal value setting problem (ASP & ADODB.Recordset value & MSSQL Server & 2003 Server)

    avcitamer wrote:
    > !!! Correction....!!!
    > in the second state updated value is (12332) ... sory...
    >
    >
    > On 17 Eylül, 14:25, avcitamer <> wrote:
    >> We upgraded our system and problem below occured, pleas help me...
    >>
    >> Windows 2003 server SP1
    >> When I set a decimal DB field value to "123,32" (using
    >> ADODB.recordset ) updated value was ok (123.32)
    >>
    >> Windows 2003 server SP2
    >> Now when I set a decimal DB field value to "123,32" (using
    >> ADODB.recordset ) updated value is (123.32)
    >>
    >> Thanks
    >>
    >> Systems
    >> Windows 2003 server Enterprise SP2
    >> SqlServer 2000 SP4
    >> Activex Data Object 2.8~
    >> IIS7, Classsical ASP


    It sounds like a Regional Settings issue. By default, regional settings are
    US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
    and the SP restored them to default?

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
    Bob Barrows [MVP], Sep 17, 2008
    #3
  4. avcitamer

    avcitamer Guest

    Re: Decimal value setting problem (ASP & ADODB.Recordset value &MSSQL Server & 2003 Server)

    How can I cange Regional Settings of the IUSR on windows 2003 server?

    On 17 Eylül, 14:41, "Bob Barrows [MVP]" <>
    wrote:
    > avcitamer wrote:
    > > !!! Correction....!!!
    > > in the second state updated value is (12332) ... sory...

    >
    > > On 17 Eylül, 14:25, avcitamer <> wrote:
    > >> We upgraded our system and problem below occured, pleas help me...

    >
    > >> Windows 2003 server SP1
    > >> When I set a decimal DB field value to "123,32" (using
    > >> ADODB.recordset ) updated value was ok (123.32)

    >
    > >> Windows 2003 server SP2
    > >> Now when I set a decimal DB field value to "123,32" (using
    > >> ADODB.recordset ) updated value is (123.32)

    >
    > >> Thanks

    >
    > >> Systems
    > >> Windows 2003 server Enterprise SP2
    > >> SqlServer 2000 SP4
    > >> Activex Data Object 2.8~
    > >> IIS7, Classsical ASP

    >
    > It sounds like a Regional Settings issue.  By default, regional settings are
    > US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
    > and the SP restored them to default?
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"- Alýntýyý gizle -
    >
    > - Alýntýyý göster -
    avcitamer, Sep 17, 2008
    #4
  5. Re: Decimal value setting problem (ASP & ADODB.Recordset value & MSSQL Server & 2003 Server)

    Never done it myself - I try my best not to write code that is affected
    by those settings. You could change the password of the account, log
    onto the machine as that account and use the Regional Settings dialog.
    But changing the IUSR password can have unwanted consequences, so you
    can edit the Registry, HKEY_Users/<IUSR node>/Control
    Panel/International

    The trick will be to identify the IUSR node ... maybe someone who has
    done this can jump in. Or perhaps someone has a script to change the
    regional settings of the IUSR account. You can try the .inetserver.iis
    group, or the .scripting.vbscript group.

    avcitamer wrote:
    > How can I cange Regional Settings of the IUSR on windows 2003 server?
    >
    > On 17 Eylül, 14:41, "Bob Barrows [MVP]" <>
    > wrote:
    >> avcitamer wrote:
    >>> !!! Correction....!!!
    >>> in the second state updated value is (12332) ... sory...

    >>
    >>> On 17 Eylül, 14:25, avcitamer <> wrote:
    >>>> We upgraded our system and problem below occured, pleas help me...

    >>
    >>>> Windows 2003 server SP1
    >>>> When I set a decimal DB field value to "123,32" (using
    >>>> ADODB.recordset ) updated value was ok (123.32)

    >>
    >>>> Windows 2003 server SP2
    >>>> Now when I set a decimal DB field value to "123,32" (using
    >>>> ADODB.recordset ) updated value is (123.32)

    >>
    >>>> Thanks

    >>
    >>>> Systems
    >>>> Windows 2003 server Enterprise SP2
    >>>> SqlServer 2000 SP4
    >>>> Activex Data Object 2.8~
    >>>> IIS7, Classsical ASP

    >>
    >> It sounds like a Regional Settings issue. By default, regional
    >> settings are US. Perhaps you had changed the Regional Settings of
    >> the IUSR account to UK, and the SP restored them to default?
    >>
    >> --
    >> Microsoft MVP - ASP/ASP.NET
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"- Alýntýyý gizle -
    >>
    >> - Alýntýyý göster -


    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
    Bob Barrows [MVP], Sep 17, 2008
    #5
  6. avcitamer

    avcitamer Guest

    Re: Decimal value setting problem (ASP & ADODB.Recordset value &MSSQL Server & 2003 Server)

    On 17 Eylül, 17:33, "Bob Barrows [MVP]" <>
    wrote:
    > Never done it myself - I try my best not to write code that is affected
    > by those settings. You could change the password of the account, log
    > onto the machine as that account and use the Regional Settings dialog.
    > But changing the IUSR password can have unwanted consequences, so you
    > can edit the Registry, HKEY_Users/<IUSR node>/Control
    > Panel/International
    >
    > The trick will be to identify the IUSR node ... maybe someone who has
    > done this can jump in. Or perhaps someone has a script to change the
    > regional settings of the IUSR account. You can try the .inetserver.iis
    > group, or the .scripting.vbscript group.
    >
    >
    >
    >
    >
    > avcitamer wrote:
    > > How can I cange Regional Settings of the IUSR on windows 2003 server?

    >
    > > On 17 Eylül, 14:41, "Bob Barrows [MVP]" <>
    > > wrote:
    > >> avcitamer wrote:
    > >>> !!! Correction....!!!
    > >>> in the second state updated value is (12332) ... sory...

    >
    > >>> On 17 Eylül, 14:25, avcitamer <> wrote:
    > >>>> We upgraded our system and problem below occured, pleas help me...

    >
    > >>>> Windows 2003 server SP1
    > >>>> When I set a decimal DB field value to "123,32" (using
    > >>>> ADODB.recordset ) updated value was ok (123.32)

    >
    > >>>> Windows 2003 server SP2
    > >>>> Now when I set a decimal DB field value to "123,32" (using
    > >>>> ADODB.recordset ) updated value is (123.32)

    >
    > >>>> Thanks

    >
    > >>>> Systems
    > >>>> Windows 2003 server Enterprise SP2
    > >>>> SqlServer 2000 SP4
    > >>>> Activex Data Object 2.8~
    > >>>> IIS7, Classsical ASP

    >
    > >> It sounds like a Regional Settings issue. By default, regional
    > >> settings are US. Perhaps you had changed the Regional Settings of
    > >> the IUSR account to UK, and the SP restored them to default?

    >
    > >> --
    > >> Microsoft MVP - ASP/ASP.NET
    > >> Please reply to the newsgroup. This email account is my spam trap so
    > >> I don't check it very often. If you must reply off-line, then remove
    > >> the "NO SPAM"- Alýntýyý gizle -

    >
    > >> - Alýntýyý göster -

    >
    > --
    > Microsoft MVP -- ASP/ASP.NET
    > Please reply to the newsgroup. The email account listed in my From
    > header is my spam trap, so I don't check it very often. You will get a
    > quicker response by posting to the newsgroup.- Alıntıyı gizle -
    >
    > - Alıntıyı göster -


    i solved it by the helps of you.

    I checked the checkbox as shown below. It solved...
    Regional Settings-->Advenced-->Default User Account Settings--
    >[x]Apply all settings to then current user account to the default

    user profile.

    thanks alot.
    avcitamer, Sep 18, 2008
    #6
  7. Re: Decimal value setting problem (ASP & ADODB.Recordset value & MSSQL Server & 2003 Server)

    avcitamer wrote:
    > On 17 Eylül, 17:33, "Bob Barrows [MVP]" <>
    > wrote:
    >> Never done it myself - I try my best not to write code that is
    >> affected by those settings. You could change the password of the
    >> account, log onto the machine as that account and use the Regional
    >> Settings dialog. But changing the IUSR password can have unwanted
    >> consequences, so you can edit the Registry, HKEY_Users/<IUSR
    >> node>/Control Panel/International
    >>
    >> The trick will be to identify the IUSR node ... maybe someone who has
    >> done this can jump in. Or perhaps someone has a script to change the
    >> regional settings of the IUSR account. You can try the
    >> .inetserver.iis group, or the .scripting.vbscript group.

    >
    > i solved it by the helps of you.
    >
    > I checked the checkbox as shown below. It solved...
    > Regional Settings-->Advenced-->Default User Account Settings--
    >> [x]Apply all settings to then current user account to the default

    > user profile.
    >
    > thanks alot.


    Good to know - thanks for the follow-up.

    --
    Microsoft MVP -- ASP/ASP.NET
    Please reply to the newsgroup. The email account listed in my From
    header is my spam trap, so I don't check it very often. You will get a
    quicker response by posting to the newsgroup.
    Bob Barrows [MVP], Sep 18, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Vikas Yadav
    Replies:
    0
    Views:
    1,114
    Vikas Yadav
    Sep 9, 2003
  2. Replies:
    5
    Views:
    3,839
    Ray Costanzo [MVP]
    Sep 22, 2005
  3. Iain Porter
    Replies:
    7
    Views:
    212
    Iain Porter
    Jul 13, 2004
  4. Marathoner

    ADODB.Recordset as parm to Web Service

    Marathoner, Dec 28, 2004, in forum: ASP .Net Web Services
    Replies:
    1
    Views:
    150
    Dilip Krishnan
    Dec 29, 2004
  5. ching
    Replies:
    3
    Views:
    271
    Bob Barrows [MVP]
    Sep 22, 2005
Loading...

Share This Page