File not found error using #include virtual with UNC path

Discussion in 'ASP General' started by chris_peoples@redlands.edu, Aug 8, 2008.

  1. Guest

    I have a virtual directory, lets say it exists at www.server-a.com/virtual-dir/
    virtual-dir points to another directory on another server using the
    unc path: \\server-b\main-dir

    I have a file at www.server-a.com/virtual-dir/some_script.asp, using
    the following include:
    <!--#include file="some_include.asp"--->

    Going to www.server-a.com/virtual-dir/some_script.asp works perfectly
    fine

    HOWEVER

    If I have another asp file at www.server-a.com/my_script.asp, which
    uses the following include:
    <!--#include virtual="/virtual-dir/some_script.asp"--->
    it produces this error:

    Active Server Pages error 'ASP 0126'

    Include file not found

    /virtual-dir/some_script.asp, line 2

    The include file 'some_include.asp' was not found.

    Anybody have any clues as to why it would say file not found, even
    though the file clearly exists?
     
    , Aug 8, 2008
    #1
    1. Advertising

  2. wrote:
    > I have a virtual directory, lets say it exists at
    > www.server-a.com/virtual-dir/ virtual-dir points to another directory
    > on another server using the
    > unc path: \\server-b\main-dir
    >
    > I have a file at www.server-a.com/virtual-dir/some_script.asp, using
    > the following include:
    > <!--#include file="some_include.asp"--->
    >
    > Going to www.server-a.com/virtual-dir/some_script.asp works perfectly
    > fine
    >
    > HOWEVER
    >
    > If I have another asp file at www.server-a.com/my_script.asp, which
    > uses the following include:
    > <!--#include virtual="/virtual-dir/some_script.asp"--->
    > it produces this error:
    >
    > Active Server Pages error 'ASP 0126'
    >
    > Include file not found
    >
    > /virtual-dir/some_script.asp, line 2
    >
    > The include file 'some_include.asp' was not found.
    >
    > Anybody have any clues as to why it would say file not found, even
    > though the file clearly exists?


    Have you enabled "parent paths" using IIS Manager?
    http://classicasp.aspfaq.com/general/why-do-i-get-asp-0130/asp-0131-errors.html

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows [MVP], Aug 8, 2008
    #2
    1. Advertising

  3. Guest

    On Aug 8, 12:24 pm, "Bob Barrows [MVP]" <>
    wrote:
    > wrote:
    > > I have a virtual directory, lets say it exists at
    > >www.server-a.com/virtual-dir/virtual-dir points to another directory
    > > on another server using the
    > > unc path: \\server-b\main-dir

    >
    > > I have a file atwww.server-a.com/virtual-dir/some_script.asp, using
    > > the following include:
    > > <!--#include file="some_include.asp"--->

    >
    > > Going towww.server-a.com/virtual-dir/some_script.aspworks perfectly
    > > fine

    >
    > > HOWEVER

    >
    > > If I have another asp file atwww.server-a.com/my_script.asp, which
    > > uses the following include:
    > > <!--#include virtual="/virtual-dir/some_script.asp"--->
    > > it produces this error:

    >
    > > Active Server Pages error 'ASP 0126'

    >
    > > Include file not found

    >
    > > /virtual-dir/some_script.asp, line 2

    >
    > > The include file 'some_include.asp' was not found.

    >
    > > Anybody have any clues as to why it would say file not found, even
    > > though the file clearly exists?

    >
    > Have you enabled "parent paths" using IIS Manager?http://classicasp.aspfaq.com/general/why-do-i-get-asp-0130/asp-0131-e...
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"- Hide quoted text -
    >
    > - Show quoted text -


    Yes I have that enabled on both servers, and am still getting the
    error message.

    I thought it might be a permissions thing but the error still occurs
    after adding full control to 'Everyone'.
     
    , Aug 8, 2008
    #3
  4. wrote:
    > On Aug 8, 12:24 pm, "Bob Barrows [MVP]" <>
    > wrote:
    >> wrote:
    >>> I have a virtual directory, lets say it exists at
    >>> www.server-a.com/virtual-dir/virtual-dir points to another directory
    >>> on another server using the
    >>> unc path: \\server-b\main-dir

    >>
    >>> I have a file atwww.server-a.com/virtual-dir/some_script.asp, using
    >>> the following include:
    >>> <!--#include file="some_include.asp"--->

    >>
    >>> Going towww.server-a.com/virtual-dir/some_script.aspworks perfectly
    >>> fine

    >>
    >>> HOWEVER

    >>
    >>> If I have another asp file atwww.server-a.com/my_script.asp, which
    >>> uses the following include:
    >>> <!--#include virtual="/virtual-dir/some_script.asp"--->
    >>> it produces this error:

    >
    > Yes I have that enabled on both servers, and am still getting the
    > error message.
    >
    > I thought it might be a permissions thing but the error still occurs
    > after adding full control to 'Everyone'.


    Oh wait, I didn't read closely enough ... there's two servers involved?
    This is likely to be a permissions issue. Your asp code is running under the
    context of a local account on server A. That local account is not a member
    of the Everyone group on server B.
    http://www.aspfaq.com/show.asp?id=2168

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"
     
    Bob Barrows [MVP], Aug 8, 2008
    #4
  5. Guest

    On Aug 8, 1:35 pm, "Bob Barrows [MVP]" <>
    wrote:
    > wrote:
    > > On Aug 8, 12:24 pm, "Bob Barrows [MVP]" <>
    > > wrote:
    > >> wrote:
    > >>> I have a virtual directory, lets say it exists at
    > >>>www.server-a.com/virtual-dir/virtual-dirpoints to another directory
    > >>> on another server using the
    > >>> unc path: \\server-b\main-dir

    >
    > >>> I have a file atwww.server-a.com/virtual-dir/some_script.asp, using
    > >>> the following include:
    > >>> <!--#include file="some_include.asp"--->

    >
    > >>> Going towww.server-a.com/virtual-dir/some_script.aspworksperfectly
    > >>> fine

    >
    > >>> HOWEVER

    >
    > >>> If I have another asp file atwww.server-a.com/my_script.asp, which
    > >>> uses the following include:
    > >>> <!--#include virtual="/virtual-dir/some_script.asp"--->
    > >>> it produces this error:

    >
    > > Yes I have that enabled on both servers, and am still getting the
    > > error message.

    >
    > > I thought it might be a permissions thing but the error still occurs
    > > after adding full control to 'Everyone'.

    >
    > Oh wait, I didn't read closely enough ... there's two servers involved?
    > This is likely to be a permissions issue. Your asp code is running under the
    > context of a local account on server A. That local account is not a member
    > of the Everyone group on server B.http://www.aspfaq.com/show.asp?id=2168
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"- Hide quoted text -
    >
    > - Show quoted text -


    Whoops, now I'm getting a 401. I changed the password of the
    IUSR_machine account as instructed, but I didn't realize until
    afterwards that those are instructions for Win2000, and I'm on
    Win2003. Seems like it would be the same principal though, unless I
    missed something.
     
    , Aug 8, 2008
    #5
  6. Guest

    On Aug 8, 2:24 pm, wrote:
    > On Aug 8, 1:35 pm, "Bob Barrows [MVP]" <>
    > wrote:
    >
    >
    >
    >
    >
    > > wrote:
    > > > On Aug 8, 12:24 pm, "Bob Barrows [MVP]" <>
    > > > wrote:
    > > >> wrote:
    > > >>> I have a virtual directory, lets say it exists at
    > > >>>www.server-a.com/virtual-dir/virtual-dirpointsto another directory
    > > >>> on another server using the
    > > >>> unc path: \\server-b\main-dir

    >
    > > >>> I have a file atwww.server-a.com/virtual-dir/some_script.asp, using
    > > >>> the following include:
    > > >>> <!--#include file="some_include.asp"--->

    >
    > > >>> Going towww.server-a.com/virtual-dir/some_script.aspworksperfectly
    > > >>> fine

    >
    > > >>> HOWEVER

    >
    > > >>> If I have another asp file atwww.server-a.com/my_script.asp, which
    > > >>> uses the following include:
    > > >>> <!--#include virtual="/virtual-dir/some_script.asp"--->
    > > >>> it produces this error:

    >
    > > > Yes I have that enabled on both servers, and am still getting the
    > > > error message.

    >
    > > > I thought it might be a permissions thing but the error still occurs
    > > > after adding full control to 'Everyone'.

    >
    > > Oh wait, I didn't read closely enough ... there's two servers involved?
    > > This is likely to be a permissions issue. Your asp code is running under the
    > > context of a local account on server A. That local account is not a member
    > > of the Everyone group on server B.http://www.aspfaq.com/show.asp?id=2168

    >
    > > --
    > > Microsoft MVP - ASP/ASP.NET
    > > Please reply to the newsgroup. This email account is my spam trap so I
    > > don't check it very often. If you must reply off-line, then remove the
    > > "NO SPAM"- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > Whoops, now I'm getting a 401.  I changed the password of the
    > IUSR_machine account as instructed, but I didn't realize until
    > afterwards that those are instructions for Win2000, and I'm on
    > Win2003.  Seems like it would be the same principal though, unless I
    > missed something.- Hide quoted text -
    >
    > - Show quoted text -


    Got it solved. Had to change the password in IIS and Computer
    Management. Thanks for your help on this.
     
    , Aug 8, 2008
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Singer
    Replies:
    0
    Views:
    542
    Steve Singer
    Feb 15, 2005
  2. PP
    Replies:
    2
    Views:
    713
  3. =?Utf-8?B?SmVmZiBCZWVt?=

    physical path to virtual path under virtual directory

    =?Utf-8?B?SmVmZiBCZWVt?=, Aug 1, 2007, in forum: ASP .Net
    Replies:
    4
    Views:
    1,049
    Eliyahu Goldin
    Aug 1, 2007
  4. Eric
    Replies:
    10
    Views:
    475
  5. Eric
    Replies:
    0
    Views:
    264
Loading...

Share This Page