gem command hangs with no output

Discussion in 'Ruby' started by Jarrod Menoube, Aug 29, 2008.

  1. Tried to run "gem outdated" on my CentOS 5 server. It just hung with no
    response on the command line for about 10 minutes.

    After that, tried "gem update passenger". I got...

    Updating installed gems...
    Bulk updating Gem source index for: http://gems.rubyforge.org

    then nothing. It's 15 minutes and it's still just hanging.

    Control-C has no effect.

    Looks like I'll have to open another shell and kill it.

    Any way to get gem command to work right now?

    Thanks,

    E
    --
    Posted via http://www.ruby-forum.com/.
    Jarrod Menoube, Aug 29, 2008
    #1
    1. Advertising

  2. Hi Jarrod,

    This happens to me now and then: especially on my Ubuntu box (low-spec
    machine as it happens) - the whole machine can become totally
    unresponsive for 5-10 minutes.

    I tried killing it once, but I just made things worse. (ended up with a
    force-reboot).

    I don't why this happens, but in my experience just letting it run its
    course was the only way of not causing damage to my system....

    John

    Jarrod Menoube wrote:
    > Tried to run "gem outdated" on my CentOS 5 server. It just hung with no
    > response on the command line for about 10 minutes.
    >
    > After that, tried "gem update passenger". I got...
    >
    > Updating installed gems...
    > Bulk updating Gem source index for: http://gems.rubyforge.org
    >
    > then nothing. It's 15 minutes and it's still just hanging.
    >
    > Control-C has no effect.
    >
    > Looks like I'll have to open another shell and kill it.
    >
    > Any way to get gem command to work right now?
    >
    > Thanks,
    >
    > E


    --
    Posted via http://www.ruby-forum.com/.
    John Pritchard-williams, Aug 29, 2008
    #2
    1. Advertising

  3. John Pritchard-williams wrote:
    > Hi Jarrod,
    >
    > This happens to me now and then: especially on my Ubuntu box (low-spec
    > machine as it happens) - the whole machine can become totally
    > unresponsive for 5-10 minutes.
    >
    > I tried killing it once, but I just made things worse. (ended up with a
    > force-reboot).
    >
    > I don't why this happens, but in my experience just letting it run its
    > course was the only way of not causing damage to my system....
    >
    > John


    Thanks for the reply. I upgraded to the latest version of gem and the
    problem went away. I wonder if they changed something on the other end
    and old versions of gem don't work any more.

    E
    --
    Posted via http://www.ruby-forum.com/.
    Jarrod Menoube, Aug 29, 2008
    #3
  4. Jarrod Menoube

    deepak Guest

    deepak, Sep 2, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tim Shadel

    Gem hangs => TCPSocket.write hangs

    Tim Shadel, Jul 23, 2005, in forum: Ruby
    Replies:
    1
    Views:
    375
    Ville Mattila
    Jul 24, 2005
  2. Scott

    gem install rails hangs

    Scott, Dec 4, 2005, in forum: Ruby
    Replies:
    4
    Views:
    204
    Scott
    Dec 5, 2005
  3. Austin 7873
    Replies:
    5
    Views:
    179
    Eric Hodel
    Jan 27, 2007
  4. Greg Hauptmann
    Replies:
    2
    Views:
    133
    Greg Hauptmann
    Nov 8, 2008
  5. kaleem
    Replies:
    8
    Views:
    123
    kaleem
    Aug 14, 2006
Loading...

Share This Page