Help! Can't create ASP.NET project

Discussion in 'ASP .Net' started by dw, Jan 13, 2005.

  1. dw

    dw Guest

    Please help some desperate developers!! We need to create an ASP.NET project
    via VS.NET 2003 on a networked Win 2003 server that we use for testing, but
    it keeps generating an error:

    "The Web server reported the following error when attempting to create or
    open the Web project located at the following URL:..... HTTP/1.1 500
    Internal Server Error."

    People have said Frontpage Server Extensions (FPSE) have to be on that
    server; however, our server admin doesn't want FPSE on our Web server for
    security reasons. We can't use LOCALHOST because we develop our apps on
    central test and production boxes. At this point, people in my department
    are ready to give up on .NET development because of this reason. Are there
    any alternatives to FPSE? Any workarounds? PLEASE HELP -- Thank you much in
    advance.
     
    dw, Jan 13, 2005
    #1
    1. Advertising

  2. It's a bit difficult to develop web apps on a server like that ... especially
    with a restrictive admin.

    If it's that critical (.NET or no .NET), just meet 'em half way and go sans
    VS.NET. Remember, it's only a tool ... develop all your classes and business
    logic locally, push the DLLs to the bin folder, and use your existing tool
    (Dreamweaver, EditPlus, Notepad) to pound out ASP.NET.

    Not ideal, but sure as hell better than doing ASP only. If you get the rest
    of your team hooked, I'm sure you'll be able to get a server to develop on.

    -- Alex Papadimoulis

    "dw" wrote:

    > Please help some desperate developers!! We need to create an ASP.NET project
    > via VS.NET 2003 on a networked Win 2003 server that we use for testing, but
    > it keeps generating an error:
    >
    > "The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:..... HTTP/1.1 500
    > Internal Server Error."
    >
    > People have said Frontpage Server Extensions (FPSE) have to be on that
    > server; however, our server admin doesn't want FPSE on our Web server for
    > security reasons. We can't use LOCALHOST because we develop our apps on
    > central test and production boxes. At this point, people in my department
    > are ready to give up on .NET development because of this reason. Are there
    > any alternatives to FPSE? Any workarounds? PLEASE HELP -- Thank you much in
    > advance.
     
    =?Utf-8?B?QWxleCBQYXBhZGltb3VsaXM=?=, Jan 13, 2005
    #2
    1. Advertising

  3. dw

    dw Guest

    We had a meeting and they've decided to keep using ASP until ASP.NET 2.0
    comes out. Then, depending on whether the issue of the Frontpage extensions
    is resolved or not, they will determine if we'll be using that technology.

    As for building .NET using something other than Visual Studio: One of the
    reasons our development team wanted to use ASP.NET was the features of
    Visual Studio .NET. Now the only way is to use a backdoor approach. I have
    Dreamweaver, which is an excellent tool, but others in the department don't
    have it. So until Microsoft uncouples FPSE from Visual Studio, we won't be
    doing any ASP.NET.

    "Alex Papadimoulis" <alexRemovePi@pa3.14padimoulis.com> wrote in message
    news:...
    > It's a bit difficult to develop web apps on a server like that ...
    > especially
    > with a restrictive admin.
    >
    > If it's that critical (.NET or no .NET), just meet 'em half way and go
    > sans
    > VS.NET. Remember, it's only a tool ... develop all your classes and
    > business
    > logic locally, push the DLLs to the bin folder, and use your existing tool
    > (Dreamweaver, EditPlus, Notepad) to pound out ASP.NET.
    >
    > Not ideal, but sure as hell better than doing ASP only. If you get the
    > rest
    > of your team hooked, I'm sure you'll be able to get a server to develop
    > on.
    >
    > -- Alex Papadimoulis
    >
    > "dw" wrote:
    >
    >> Please help some desperate developers!! We need to create an ASP.NET
    >> project
    >> via VS.NET 2003 on a networked Win 2003 server that we use for testing,
    >> but
    >> it keeps generating an error:
    >>
    >> "The Web server reported the following error when attempting to create or
    >> open the Web project located at the following URL:..... HTTP/1.1 500
    >> Internal Server Error."
    >>
    >> People have said Frontpage Server Extensions (FPSE) have to be on that
    >> server; however, our server admin doesn't want FPSE on our Web server for
    >> security reasons. We can't use LOCALHOST because we develop our apps on
    >> central test and production boxes. At this point, people in my department
    >> are ready to give up on .NET development because of this reason. Are
    >> there
    >> any alternatives to FPSE? Any workarounds? PLEASE HELP -- Thank you much
    >> in
    >> advance.
     
    dw, Jan 14, 2005
    #3
  4. You could map a drive on the server and work through the file system.

    "dw" <> wrote in message
    news:ehUT5Ra%...
    > Please help some desperate developers!! We need to create an ASP.NET
    > project via VS.NET 2003 on a networked Win 2003 server that we use for
    > testing, but it keeps generating an error:
    >
    > "The Web server reported the following error when attempting to create or
    > open the Web project located at the following URL:..... HTTP/1.1 500
    > Internal Server Error."
    >
    > People have said Frontpage Server Extensions (FPSE) have to be on that
    > server; however, our server admin doesn't want FPSE on our Web server for
    > security reasons. We can't use LOCALHOST because we develop our apps on
    > central test and production boxes. At this point, people in my department
    > are ready to give up on .NET development because of this reason. Are there
    > any alternatives to FPSE? Any workarounds? PLEASE HELP -- Thank you much
    > in advance.
    >
     
    Ken Cox [Microsoft MVP], Jan 14, 2005
    #4
  5. dw

    dw Guest

    How would you accomplish this? I thought when you create ASP.NET projects in
    Visual Studio, you have to give it an HTTP address and not a network path.
    Any light you can shed on this will be deeply appreciated. Thank you much.

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:eOWw7Lk%...
    > You could map a drive on the server and work through the file system.
    >
    > "dw" <> wrote in message
    > news:ehUT5Ra%...
    >> Please help some desperate developers!! We need to create an ASP.NET
    >> project via VS.NET 2003 on a networked Win 2003 server that we use for
    >> testing, but it keeps generating an error:
    >>
    >> "The Web server reported the following error when attempting to create or
    >> open the Web project located at the following URL:..... HTTP/1.1 500
    >> Internal Server Error."
    >>
    >> People have said Frontpage Server Extensions (FPSE) have to be on that
    >> server; however, our server admin doesn't want FPSE on our Web server for
    >> security reasons. We can't use LOCALHOST because we develop our apps on
    >> central test and production boxes. At this point, people in my department
    >> are ready to give up on .NET development because of this reason. Are
    >> there any alternatives to FPSE? Any workarounds? PLEASE HELP -- Thank you
    >> much in advance.
    >>

    >
     
    dw, Jan 14, 2005
    #5
  6. 1. Map a drive (say x:) on the remote server to c:\inetpub\wwwroot\myproject
    .. You'll need to have sufficient permissions as a user on the remote
    machine - this is the hard part - try to be part of the same domain on each
    machine.
    2. On the local machine, In IIS Manager, create a virtual directory called
    myproject and set the file location as x:\myproject.
    3. Create a VS.NET project on http://localhost/myproject . The files will be
    written to x:\myproject .
    4. Develop your application using VS.NET on your machine. You can view the
    pages on http://localhost/myproject or on http://servername/myproject .

    On the remote server, you'll need to use IIS Manager to create myproject as
    a Web Application.

    Let us know if it works for you?

    Ken



    "dw" <> wrote in message
    news:O9vGdyk%...
    > How would you accomplish this? I thought when you create ASP.NET projects
    > in Visual Studio, you have to give it an HTTP address and not a network
    > path. Any light you can shed on this will be deeply appreciated. Thank you
    > much.
    >
    > "Ken Cox [Microsoft MVP]" <> wrote in message
    > news:eOWw7Lk%...
    >> You could map a drive on the server and work through the file system.
    >>
    >> "dw" <> wrote in message
    >> news:ehUT5Ra%...
    >>> Please help some desperate developers!! We need to create an ASP.NET
    >>> project via VS.NET 2003 on a networked Win 2003 server that we use for
    >>> testing, but it keeps generating an error:
    >>>
    >>> "The Web server reported the following error when attempting to create
    >>> or open the Web project located at the following URL:..... HTTP/1.1 500
    >>> Internal Server Error."
    >>>
    >>> People have said Frontpage Server Extensions (FPSE) have to be on that
    >>> server; however, our server admin doesn't want FPSE on our Web server
    >>> for security reasons. We can't use LOCALHOST because we develop our apps
    >>> on central test and production boxes. At this point, people in my
    >>> department are ready to give up on .NET development because of this
    >>> reason. Are there any alternatives to FPSE? Any workarounds? PLEASE
    >>> HELP -- Thank you much in advance.
    >>>

    >>

    >
    >
     
    Ken Cox [Microsoft MVP], Jan 14, 2005
    #6
  7. Hi,

    Appart from what Ken suggested, take a look at the following KB article in
    regard to the required security settings for the shares:

    http://support.microsoft.com/?kbid=326495

    Hope this helps
    Martin Dechev
    ASP.NET MVP
    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:#LbZWml#...
    > 1. Map a drive (say x:) on the remote server to

    c:\inetpub\wwwroot\myproject
    > . You'll need to have sufficient permissions as a user on the remote
    > machine - this is the hard part - try to be part of the same domain on

    each
    > machine.
    > 2. On the local machine, In IIS Manager, create a virtual directory called
    > myproject and set the file location as x:\myproject.
    > 3. Create a VS.NET project on http://localhost/myproject . The files will

    be
    > written to x:\myproject .
    > 4. Develop your application using VS.NET on your machine. You can view the
    > pages on http://localhost/myproject or on http://servername/myproject .
    >
    > On the remote server, you'll need to use IIS Manager to create myproject

    as
    > a Web Application.
    >
    > Let us know if it works for you?
    >
    > Ken
    >
    >
    >
    > "dw" <> wrote in message
    > news:O9vGdyk%...
    > > How would you accomplish this? I thought when you create ASP.NET

    projects
    > > in Visual Studio, you have to give it an HTTP address and not a network
    > > path. Any light you can shed on this will be deeply appreciated. Thank

    you
    > > much.
    > >
    > > "Ken Cox [Microsoft MVP]" <> wrote in message
    > > news:eOWw7Lk%...
    > >> You could map a drive on the server and work through the file system.
    > >>
    > >> "dw" <> wrote in message
    > >> news:ehUT5Ra%...
    > >>> Please help some desperate developers!! We need to create an ASP.NET
    > >>> project via VS.NET 2003 on a networked Win 2003 server that we use for
    > >>> testing, but it keeps generating an error:
    > >>>
    > >>> "The Web server reported the following error when attempting to create
    > >>> or open the Web project located at the following URL:..... HTTP/1.1

    500
    > >>> Internal Server Error."
    > >>>
    > >>> People have said Frontpage Server Extensions (FPSE) have to be on that
    > >>> server; however, our server admin doesn't want FPSE on our Web server
    > >>> for security reasons. We can't use LOCALHOST because we develop our

    apps
    > >>> on central test and production boxes. At this point, people in my
    > >>> department are ready to give up on .NET development because of this
    > >>> reason. Are there any alternatives to FPSE? Any workarounds? PLEASE
    > >>> HELP -- Thank you much in advance.
    > >>>
    > >>

    > >
    > >

    >
     
    Martin Dechev, Jan 14, 2005
    #7
  8. Thanks Martin!

    Ken

    "Martin Dechev" <> wrote in message
    news:eDR7Prl%...
    > Hi,
    >
    > Appart from what Ken suggested, take a look at the following KB article in
    > regard to the required security settings for the shares:
    >
    > http://support.microsoft.com/?kbid=326495
    >
    > Hope this helps
    > Martin Dechev
    > ASP.NET MVP
     
    Ken Cox [Microsoft MVP], Jan 14, 2005
    #8
  9. dw

    dw Guest

    Thank you, Ken and Martin. I'm going to try this hopefully this afternoon
    and post my results. It is much appreciated :)

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:OWnUY6l%...
    > Thanks Martin!
    >
    > Ken
    >
    > "Martin Dechev" <> wrote in message
    > news:eDR7Prl%...
    >> Hi,
    >>
    >> Appart from what Ken suggested, take a look at the following KB article
    >> in
    >> regard to the required security settings for the shares:
    >>
    >> http://support.microsoft.com/?kbid=326495
    >>
    >> Hope this helps
    >> Martin Dechev
    >> ASP.NET MVP

    >
     
    dw, Jan 14, 2005
    #9
  10. dw

    dw Guest

    Ken, I got it working, but I'm getting this error when I try to view the
    page in the browser,

    Parser Error Message: Could not load type 'sga_test.Global'.

    Source Error:

    Line 1: <%@ Application Codebehind="Global.asax.vb"
    Inherits="sga_test.Global" %>





    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:OWnUY6l%...
    > Thanks Martin!
    >
    > Ken
    >
    > "Martin Dechev" <> wrote in message
    > news:eDR7Prl%...
    >> Hi,
    >>
    >> Appart from what Ken suggested, take a look at the following KB article
    >> in
    >> regard to the required security settings for the shares:
    >>
    >> http://support.microsoft.com/?kbid=326495
    >>
    >> Hope this helps
    >> Martin Dechev
    >> ASP.NET MVP

    >
     
    dw, Jan 14, 2005
    #10
  11. Make sure the Web is configured as an Application. You may need to do a
    Remove and Create in IIS Manager.

    Make sure that your output is going to the correct /bin directory:

    1. Right-click on the project name.
    2. Got to Configuration Properties > Build
    3. Check the Output path value is pointing to the right place.

    Let us know?

    Ken


    "dw" <> wrote in message
    news:OXOOlNn%...
    > Ken, I got it working, but I'm getting this error when I try to view the
    > page in the browser,
    >
    > Parser Error Message: Could not load type 'sga_test.Global'.
    >
    > Source Error:
    >
    > Line 1: <%@ Application Codebehind="Global.asax.vb"
    > Inherits="sga_test.Global" %>
    >
    >
     
    Ken Cox [Microsoft MVP], Jan 14, 2005
    #11
  12. dw

    dw Guest

    Thanks, Ken. I'll check and let you know.

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:exMS01o%...
    > Make sure the Web is configured as an Application. You may need to do a
    > Remove and Create in IIS Manager.
    >
    > Make sure that your output is going to the correct /bin directory:
    >
    > 1. Right-click on the project name.
    > 2. Got to Configuration Properties > Build
    > 3. Check the Output path value is pointing to the right place.
    >
    > Let us know?
    >
    > Ken
    >
    >
    > "dw" <> wrote in message
    > news:OXOOlNn%...
    >> Ken, I got it working, but I'm getting this error when I try to view the
    >> page in the browser,
    >>
    >> Parser Error Message: Could not load type 'sga_test.Global'.
    >>
    >> Source Error:
    >>
    >> Line 1: <%@ Application Codebehind="Global.asax.vb"
    >> Inherits="sga_test.Global" %>
    >>
    >>

    >
     
    dw, Jan 15, 2005
    #12
  13. dw

    dw Guest

    Thanks, Ken. I tried the suggestions but had the same error.

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:exMS01o%...
    > Make sure the Web is configured as an Application. You may need to do a
    > Remove and Create in IIS Manager.
    >
    > Make sure that your output is going to the correct /bin directory:
    >
    > 1. Right-click on the project name.
    > 2. Got to Configuration Properties > Build
    > 3. Check the Output path value is pointing to the right place.
    >
    > Let us know?
    >
    > Ken
    >
    >
    > "dw" <> wrote in message
    > news:OXOOlNn%...
    >> Ken, I got it working, but I'm getting this error when I try to view the
    >> page in the browser,
    >>
    >> Parser Error Message: Could not load type 'sga_test.Global'.
    >>
    >> Source Error:
    >>
    >> Line 1: <%@ Application Codebehind="Global.asax.vb"
    >> Inherits="sga_test.Global" %>
    >>
    >>

    >
     
    dw, Jan 15, 2005
    #13
  14. dw,

    Please read
    http://support.microsoft.com/kb/321748/EN-US/
    ( After you create this page, you have to build the application )

    or

    http://blogs.biasecurities.com/jim/archive/2004/04/20/446.aspx
    ( specify “Set as Startup Project” )

    Otherwise, do you have sga_test.Global
    defined in your code-behind ?

    i.e. do you have :

    Public Class sga_test.Global
    Inherits System.Web.HttpApplication

    in your global.asax.vb code-behind ?



    Juan T. Llibre
    ASP.NET MVP
    ===========
    "dw" <> wrote in message
    news:OytwVPq%...
    > Thanks, Ken. I tried the suggestions but had the same error.
    >
    > "Ken Cox [Microsoft MVP]" <> wrote in message
    > news:exMS01o%...
    >> Make sure the Web is configured as an Application. You may need to do a
    >> Remove and Create in IIS Manager.
    >>
    >> Make sure that your output is going to the correct /bin directory:
    >>
    >> 1. Right-click on the project name.
    >> 2. Got to Configuration Properties > Build
    >> 3. Check the Output path value is pointing to the right place.
    >>
    >> Let us know?
    >>
    >> Ken
    >>
    >>
    >> "dw" <> wrote in message
    >> news:OXOOlNn%...
    >>> Ken, I got it working, but I'm getting this error when I try to view the
    >>> page in the browser,
    >>>
    >>> Parser Error Message: Could not load type 'sga_test.Global'.
    >>>
    >>> Source Error:
    >>>
    >>> Line 1: <%@ Application Codebehind="Global.asax.vb"
    >>> Inherits="sga_test.Global" %>
    >>>
    >>>

    >>

    >
    >
     
    Juan T. Llibre, Jan 15, 2005
    #14
  15. It's almost like your project isn't being built.

    "dw" <> wrote in message
    news:OytwVPq%...
    > Thanks, Ken. I tried the suggestions but had the same error.
    >
    > "Ken Cox [Microsoft MVP]" <> wrote in message
    > news:exMS01o%...
    >> Make sure the Web is configured as an Application. You may need to do a
    >> Remove and Create in IIS Manager.
    >>
    >> Make sure that your output is going to the correct /bin directory:
    >>
    >> 1. Right-click on the project name.
    >> 2. Got to Configuration Properties > Build
    >> 3. Check the Output path value is pointing to the right place.
    >>
    >> Let us know?
    >>
    >> Ken
    >>
    >>
    >> "dw" <> wrote in message
    >> news:OXOOlNn%...
    >>> Ken, I got it working, but I'm getting this error when I try to view the
    >>> page in the browser,
    >>>
    >>> Parser Error Message: Could not load type 'sga_test.Global'.
    >>>
    >>> Source Error:
    >>>
    >>> Line 1: <%@ Application Codebehind="Global.asax.vb"
    >>> Inherits="sga_test.Global" %>
    >>>
    >>>

    >>

    >
    >
     
    Ken Cox [Microsoft MVP], Jan 15, 2005
    #15
  16. dw

    dw Guest

    Thank you, Juan and Ken. I'll delete the entire app from our server and
    re-create it to see if I'll have better luck. Is there a way to compile an
    ASP.NET app written in VB.NET from the command prompt? You think that might
    resolve this issue? Thanks -- and thank you for all the answers you've been
    patiently providing to me; it's much appreciated :)

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:OnDcUhq%...
    > It's almost like your project isn't being built.
    >
    > "dw" <> wrote in message
    > news:OytwVPq%...
    >> Thanks, Ken. I tried the suggestions but had the same error.
    >>
    >> "Ken Cox [Microsoft MVP]" <> wrote in message
    >> news:exMS01o%...
    >>> Make sure the Web is configured as an Application. You may need to do a
    >>> Remove and Create in IIS Manager.
    >>>
    >>> Make sure that your output is going to the correct /bin directory:
    >>>
    >>> 1. Right-click on the project name.
    >>> 2. Got to Configuration Properties > Build
    >>> 3. Check the Output path value is pointing to the right place.
    >>>
    >>> Let us know?
    >>>
    >>> Ken
    >>>
    >>>
    >>> "dw" <> wrote in message
    >>> news:OXOOlNn%...
    >>>> Ken, I got it working, but I'm getting this error when I try to view
    >>>> the page in the browser,
    >>>>
    >>>> Parser Error Message: Could not load type 'sga_test.Global'.
    >>>>
    >>>> Source Error:
    >>>>
    >>>> Line 1: <%@ Application Codebehind="Global.asax.vb"
    >>>> Inherits="sga_test.Global" %>
    >>>>
    >>>>
    >>>

    >>
    >>

    >
     
    dw, Jan 16, 2005
    #16
  17. Yes, you can compile using the command line. It will be something like this:

    vbc /t:library /r:System.dll,System.Data.dll,System.Web.dll mycodebehind.vb

    You may need to add more references depending on what's in your code.

    Ken

    "dw" <> wrote in message
    news:u0CxaC$%...
    > Thank you, Juan and Ken. I'll delete the entire app from our server and
    > re-create it to see if I'll have better luck. Is there a way to compile an
    > ASP.NET app written in VB.NET from the command prompt? You think that
    > might resolve this issue? Thanks -- and thank you for all the answers
    > you've been patiently providing to me; it's much appreciated :)
    >
     
    Ken Cox [Microsoft MVP], Jan 16, 2005
    #17
  18. dw,
    WHen you use code behind files .net framework expects that your
    application
    will have a dll file in your /bind directory. So when you try to start
    the
    application .net framework throw this exception because it can not found
    the
    needed files

    So you have to rebuild your application and check ( just to be sure )
    that
    your .dll file is in the /bin directory
    Hope it helps
    Patrick


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Patrick Olurotimi Ige, Jan 17, 2005
    #18
  19. dw

    dw Guest

    Thank you, Ken and Patrick. I will try your suggestions and let you know.

    "Patrick Olurotimi Ige" <> wrote in message
    news:OP4UzoE$...
    > dw,
    > WHen you use code behind files .net framework expects that your
    > application
    > will have a dll file in your /bind directory. So when you try to start
    > the
    > application .net framework throw this exception because it can not found
    > the
    > needed files
    >
    > So you have to rebuild your application and check ( just to be sure )
    > that
    > your .dll file is in the /bin directory
    > Hope it helps
    > Patrick
    >
    >
    > *** Sent via Developersdex http://www.developersdex.com ***
    > Don't just participate in USENET...get rewarded for it!
     
    dw, Jan 17, 2005
    #19
  20. dw

    dw Guest

    Ken, when I run the command line compiler on the server at its command
    prompt, I get an error: "'vbc' is not recognized as an internal or external
    command, operable program or batch file."

    "Ken Cox [Microsoft MVP]" <> wrote in message
    news:ezesEVC$...
    > Yes, you can compile using the command line. It will be something like
    > this:
    >
    > vbc /t:library /r:System.dll,System.Data.dll,System.Web.dll
    > mycodebehind.vb
    >
    > You may need to add more references depending on what's in your code.
    >
    > Ken
    >
    > "dw" <> wrote in message
    > news:u0CxaC$%...
    >> Thank you, Juan and Ken. I'll delete the entire app from our server and
    >> re-create it to see if I'll have better luck. Is there a way to compile
    >> an ASP.NET app written in VB.NET from the command prompt? You think that
    >> might resolve this issue? Thanks -- and thank you for all the answers
    >> you've been patiently providing to me; it's much appreciated :)
    >>

    >
     
    dw, Jan 17, 2005
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. George Ter-Saakov
    Replies:
    5
    Views:
    2,890
    Yan-Hong Huang[MSFT]
    Aug 12, 2003
  2. moondaddy
    Replies:
    4
    Views:
    756
    Steven Cheng[MSFT]
    Jul 27, 2004
  3. Raed Sawalha
    Replies:
    4
    Views:
    1,866
    =?Utf-8?B?QnJpYW4=?=
    Oct 24, 2004
  4. dw
    Replies:
    5
    Views:
    513
  5. JB
    Replies:
    1
    Views:
    464
    Mark Rae [MVP]
    Dec 14, 2007
Loading...

Share This Page