IIS caches asp files for too long and delays testing

Discussion in 'ASP General' started by Bob, Feb 25, 2006.

  1. Bob

    Bob Guest

    Running IIS 6

    IIS seems to suffer from the malady I had with IIS5 ... it caches the
    asp files. So when I make a change, save the file to the IIS inetpub
    directory, then test, it runs the old file. If I wait a little while
    then I can test the new file.

    I thought this issue had gone away with IIS 6 but it seems to still be
    there. Is there a fix for IIS6? For IIS5 I remember hacking the
    registry but I don't recall what... and I seem to recall marginal
    success fixing the actual problem.

    Thanks,
    Bob, Feb 25, 2006
    #1
    1. Advertising

  2. Bob

    MikeR Guest

    Bob wrote:
    > Running IIS 6
    >
    > IIS seems to suffer from the malady I had with IIS5 ... it caches the
    > asp files. So when I make a change, save the file to the IIS inetpub
    > directory, then test, it runs the old file. If I wait a little while
    > then I can test the new file.
    >
    > I thought this issue had gone away with IIS 6 but it seems to still be
    > there. Is there a fix for IIS6? For IIS5 I remember hacking the
    > registry but I don't recall what... and I seem to recall marginal
    > success fixing the actual problem.
    >
    > Thanks,
    >

    Switch to Firefox (or at least use it for testing this scenario).
    MikeR
    MikeR, Feb 26, 2006
    #2
    1. Advertising

  3. Bob

    Hal Rosser Guest

    "Bob" <> wrote in message
    news:...
    > Running IIS 6
    >
    > IIS seems to suffer from the malady I had with IIS5 ... it caches the
    > asp files. So when I make a change, save the file to the IIS inetpub
    > directory, then test, it runs the old file. If I wait a little while
    > then I can test the new file.
    >
    > I thought this issue had gone away with IIS 6 but it seems to still be
    > there. Is there a fix for IIS6? For IIS5 I remember hacking the
    > registry but I don't recall what... and I seem to recall marginal
    > success fixing the actual problem.
    >


    Try unchecking the box that says "Cache ISAPI applications" in IIS
    Then you can hit refresh in IE and get the new version.
    Keep it unchecked while you're working on the code, then check it when
    finished.
    In IIS - click home directory - then configuration ...
    HTH
    Hal Rosser, Feb 26, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Neil Zanella
    Replies:
    2
    Views:
    10,121
  2. robert
    Replies:
    1
    Views:
    4,257
    Dennis Lee Bieber
    Jul 1, 2006
  3. Paul Rubin
    Replies:
    8
    Views:
    272
    Steve Holden
    Sep 28, 2006
  4. Replies:
    0
    Views:
    585
  5. JVRudnick

    CDOSYS executes but takes TOO TOO long?

    JVRudnick, Feb 20, 2008, in forum: ASP General
    Replies:
    13
    Views:
    286
    JVRudnick
    Feb 28, 2008
Loading...

Share This Page