JET error in interdev debug only (DCOM error?)

Discussion in 'ASP General' started by SÁRINGER Zoltán, Aug 30, 2004.

  1. hi,

    When I open the connection to a JET database, I get 80004005 "unknown
    error". I know, it's usually permission problem, but I added all users to
    the db directory, and have this error only if I debug the application:
    (environment: "celan" w2000prof, interdev server, all patches.)

    here are the steps from the begining to produce the symptoms:

    1) I create "temp" directory under wwwroot, contains "temp.asp" and the mdb
    file. (TEST result in browser: successfully opens the db!)

    2) right click in IIS mmc on "temp", select "Config server extensions", type
    the name as "temp". (TEST result in browser: successfully opens the db!)

    3) start Interdev. New project, connect to server, to "temp". Run with
    debug. Type the username and password to the login window first time
    (administrator, blank)
    TEST result in browser: Microsoft JET Database Engine (0x80004005) Unknown
    error. But debugging at least works:), i can watch variables, etc, just JET
    confused. Maybe also there are some permission problem? (I'm afraid not at
    file system level, because i tried everything. Maybe something in DCOM
    configuration?)

    As I installed Interdev Server, maybe debugger was set correctly, but I
    checked it by the article
    (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also, and
    found it OK.

    waiting your helps,
    Zoltan
    SÁRINGER Zoltán, Aug 30, 2004
    #1
    1. Advertising

  2. SÁRINGER Zoltán

    asdf Guest

    asdf, Aug 30, 2004
    #2
    1. Advertising

  3. SÁRINGER Zoltán

    Jeff Dillon Guest

    As a test, try adding the IWAM user to the admin group.

    Jeff

    "SÁRINGER Zoltán" <> wrote in message
    news:#...
    > hi,
    >
    > When I open the connection to a JET database, I get 80004005 "unknown
    > error". I know, it's usually permission problem, but I added all users to
    > the db directory, and have this error only if I debug the application:
    > (environment: "celan" w2000prof, interdev server, all patches.)
    >
    > here are the steps from the begining to produce the symptoms:
    >
    > 1) I create "temp" directory under wwwroot, contains "temp.asp" and the

    mdb
    > file. (TEST result in browser: successfully opens the db!)
    >
    > 2) right click in IIS mmc on "temp", select "Config server extensions",

    type
    > the name as "temp". (TEST result in browser: successfully opens the db!)
    >
    > 3) start Interdev. New project, connect to server, to "temp". Run with
    > debug. Type the username and password to the login window first time
    > (administrator, blank)
    > TEST result in browser: Microsoft JET Database Engine (0x80004005) Unknown
    > error. But debugging at least works:), i can watch variables, etc, just

    JET
    > confused. Maybe also there are some permission problem? (I'm afraid not at
    > file system level, because i tried everything. Maybe something in DCOM
    > configuration?)
    >
    > As I installed Interdev Server, maybe debugger was set correctly, but I
    > checked it by the article
    > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also, and
    > found it OK.
    >
    > waiting your helps,
    > Zoltan
    >
    >
    Jeff Dillon, Aug 30, 2004
    #3
  4. SÁRINGER Zoltán

    asdf Guest

    I added IUSR_, IWAM_ to admin group, "of course", nothing happened.
    The problem's source exactly the process what interdev does when setup for
    debugging (creating component for the web application) Until this component
    exists, the error exists too, doesnt matter interdev runs or not.

    If I remove that component (in IIS, I remove the "application"), it will
    work again.

    Do you have some tips how to find out what are these changes?? (registry,
    file settings, i heard about some Norton's "tracker" product..)





    "Jeff Dillon" <> az alábbiakat írta a
    következo üzenetben news:%...
    > As a test, try adding the IWAM user to the admin group.
    >
    > Jeff
    >
    > "SÁRINGER Zoltán" <> wrote in

    message
    > news:#...
    > > hi,
    > >
    > > When I open the connection to a JET database, I get 80004005 "unknown
    > > error". I know, it's usually permission problem, but I added all users

    to
    > > the db directory, and have this error only if I debug the application:
    > > (environment: "celan" w2000prof, interdev server, all patches.)
    > >
    > > here are the steps from the begining to produce the symptoms:
    > >
    > > 1) I create "temp" directory under wwwroot, contains "temp.asp" and the

    > mdb
    > > file. (TEST result in browser: successfully opens the db!)
    > >
    > > 2) right click in IIS mmc on "temp", select "Config server extensions",

    > type
    > > the name as "temp". (TEST result in browser: successfully opens the db!)
    > >
    > > 3) start Interdev. New project, connect to server, to "temp". Run with
    > > debug. Type the username and password to the login window first time
    > > (administrator, blank)
    > > TEST result in browser: Microsoft JET Database Engine (0x80004005)

    Unknown
    > > error. But debugging at least works:), i can watch variables, etc, just

    > JET
    > > confused. Maybe also there are some permission problem? (I'm afraid not

    at
    > > file system level, because i tried everything. Maybe something in DCOM
    > > configuration?)
    > >
    > > As I installed Interdev Server, maybe debugger was set correctly, but I
    > > checked it by the article
    > > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also,

    and
    > > found it OK.
    > >
    > > waiting your helps,
    > > Zoltan
    > >
    > >

    >
    >
    asdf, Aug 31, 2004
    #4
  5. solution

    Hello Jeff,

    you are right. when I deleted and RE-CREATED the component by Interdev
    (after I added all internet user to administrators), it worked.. thank you,
    this had took 2 days from my life.
    Zoltan


    "Jeff Dillon" <> az alábbiakat írta a
    következo üzenetben news:%...
    > As a test, try adding the IWAM user to the admin group.
    >
    > Jeff
    >
    > "SÁRINGER Zoltán" <> wrote in

    message
    > news:#...
    > > hi,
    > >
    > > When I open the connection to a JET database, I get 80004005 "unknown
    > > error". I know, it's usually permission problem, but I added all users

    to
    > > the db directory, and have this error only if I debug the application:
    > > (environment: "celan" w2000prof, interdev server, all patches.)
    > >
    > > here are the steps from the begining to produce the symptoms:
    > >
    > > 1) I create "temp" directory under wwwroot, contains "temp.asp" and the

    > mdb
    > > file. (TEST result in browser: successfully opens the db!)
    > >
    > > 2) right click in IIS mmc on "temp", select "Config server extensions",

    > type
    > > the name as "temp". (TEST result in browser: successfully opens the db!)
    > >
    > > 3) start Interdev. New project, connect to server, to "temp". Run with
    > > debug. Type the username and password to the login window first time
    > > (administrator, blank)
    > > TEST result in browser: Microsoft JET Database Engine (0x80004005)

    Unknown
    > > error. But debugging at least works:), i can watch variables, etc, just

    > JET
    > > confused. Maybe also there are some permission problem? (I'm afraid not

    at
    > > file system level, because i tried everything. Maybe something in DCOM
    > > configuration?)
    > >
    > > As I installed Interdev Server, maybe debugger was set correctly, but I
    > > checked it by the article
    > > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also,

    and
    > > found it OK.
    > >
    > > waiting your helps,
    > > Zoltan
    > >
    > >

    >
    >
    SÁRINGER Zoltán, Aug 31, 2004
    #5
  6. Re: solution

    It's not quite good idea to put IUSR or IWAM user to administrators group,
    concerning security.
    80004005 error might have to do something with permissions in registry.

    Dusan

    "SÁRINGER Zoltán" <> wrote in message
    news:%23ZZ$...
    >
    > Hello Jeff,
    >
    > you are right. when I deleted and RE-CREATED the component by Interdev
    > (after I added all internet user to administrators), it worked.. thank
    > you,
    > this had took 2 days from my life.
    > Zoltan
    >
    >
    > "Jeff Dillon" <> az alábbiakat írta a
    > következo üzenetben news:%...
    >> As a test, try adding the IWAM user to the admin group.
    >>
    >> Jeff
    >>
    >> "SÁRINGER Zoltán" <> wrote in

    > message
    >> news:#...
    >> > hi,
    >> >
    >> > When I open the connection to a JET database, I get 80004005 "unknown
    >> > error". I know, it's usually permission problem, but I added all users

    > to
    >> > the db directory, and have this error only if I debug the application:
    >> > (environment: "celan" w2000prof, interdev server, all patches.)
    >> >
    >> > here are the steps from the begining to produce the symptoms:
    >> >
    >> > 1) I create "temp" directory under wwwroot, contains "temp.asp" and the

    >> mdb
    >> > file. (TEST result in browser: successfully opens the db!)
    >> >
    >> > 2) right click in IIS mmc on "temp", select "Config server extensions",

    >> type
    >> > the name as "temp". (TEST result in browser: successfully opens the
    >> > db!)
    >> >
    >> > 3) start Interdev. New project, connect to server, to "temp". Run with
    >> > debug. Type the username and password to the login window first time
    >> > (administrator, blank)
    >> > TEST result in browser: Microsoft JET Database Engine (0x80004005)

    > Unknown
    >> > error. But debugging at least works:), i can watch variables, etc, just

    >> JET
    >> > confused. Maybe also there are some permission problem? (I'm afraid not

    > at
    >> > file system level, because i tried everything. Maybe something in DCOM
    >> > configuration?)
    >> >
    >> > As I installed Interdev Server, maybe debugger was set correctly, but I
    >> > checked it by the article
    >> > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also,

    > and
    >> > found it OK.
    >> >
    >> > waiting your helps,
    >> > Zoltan
    >> >
    >> >

    >>
    >>

    >
    >
    Dusan Kosaric, Aug 31, 2004
    #6
  7. SÁRINGER Zoltán

    Jeff Dillon Guest

    Ok "of course" I was assuming the vid debugger or specific IIS application
    runs under the IWAM account, so it might be a permissions problem. I have
    other ideas to offer, but will pass at this point.

    Jeff

    "asdf" <> wrote in message
    news:...
    > I added IUSR_, IWAM_ to admin group, "of course", nothing happened.
    > The problem's source exactly the process what interdev does when setup for
    > debugging (creating component for the web application) Until this

    component
    > exists, the error exists too, doesnt matter interdev runs or not.
    >
    > If I remove that component (in IIS, I remove the "application"), it will
    > work again.
    >
    > Do you have some tips how to find out what are these changes?? (registry,
    > file settings, i heard about some Norton's "tracker" product..)
    >
    >
    >
    >
    >
    > "Jeff Dillon" <> az alábbiakat írta a
    > következo üzenetben news:%...
    > > As a test, try adding the IWAM user to the admin group.
    > >
    > > Jeff
    > >
    > > "SÁRINGER Zoltán" <> wrote in

    > message
    > > news:#...
    > > > hi,
    > > >
    > > > When I open the connection to a JET database, I get 80004005 "unknown
    > > > error". I know, it's usually permission problem, but I added all users

    > to
    > > > the db directory, and have this error only if I debug the application:
    > > > (environment: "celan" w2000prof, interdev server, all patches.)
    > > >
    > > > here are the steps from the begining to produce the symptoms:
    > > >
    > > > 1) I create "temp" directory under wwwroot, contains "temp.asp" and

    the
    > > mdb
    > > > file. (TEST result in browser: successfully opens the db!)
    > > >
    > > > 2) right click in IIS mmc on "temp", select "Config server

    extensions",
    > > type
    > > > the name as "temp". (TEST result in browser: successfully opens the

    db!)
    > > >
    > > > 3) start Interdev. New project, connect to server, to "temp". Run with
    > > > debug. Type the username and password to the login window first time
    > > > (administrator, blank)
    > > > TEST result in browser: Microsoft JET Database Engine (0x80004005)

    > Unknown
    > > > error. But debugging at least works:), i can watch variables, etc,

    just
    > > JET
    > > > confused. Maybe also there are some permission problem? (I'm afraid

    not
    > at
    > > > file system level, because i tried everything. Maybe something in DCOM
    > > > configuration?)
    > > >
    > > > As I installed Interdev Server, maybe debugger was set correctly, but

    I
    > > > checked it by the article
    > > > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929) also,

    > and
    > > > found it OK.
    > > >
    > > > waiting your helps,
    > > > Zoltan
    > > >
    > > >

    > >
    > >

    >
    >
    Jeff Dillon, Sep 2, 2004
    #7
  8. SÁRINGER Zoltán

    Jeff Dillon Guest

    Re: solution

    Agreed, and why I said "as a test". It simply and quickly determines if it
    is a permissions problem, you then remove the account from the admin group,
    and act accordingly.

    "Dusan Kosaric" <> wrote in message
    news:rt%Yc.2087$...
    > It's not quite good idea to put IUSR or IWAM user to administrators group,
    > concerning security.
    > 80004005 error might have to do something with permissions in registry.
    >
    > Dusan
    >
    > "SÁRINGER Zoltán" <> wrote in message
    > news:%23ZZ$...
    > >
    > > Hello Jeff,
    > >
    > > you are right. when I deleted and RE-CREATED the component by Interdev
    > > (after I added all internet user to administrators), it worked.. thank
    > > you,
    > > this had took 2 days from my life.
    > > Zoltan
    > >
    > >
    > > "Jeff Dillon" <> az alábbiakat írta a
    > > következo üzenetben news:%...
    > >> As a test, try adding the IWAM user to the admin group.
    > >>
    > >> Jeff
    > >>
    > >> "SÁRINGER Zoltán" <> wrote in

    > > message
    > >> news:#...
    > >> > hi,
    > >> >
    > >> > When I open the connection to a JET database, I get 80004005 "unknown
    > >> > error". I know, it's usually permission problem, but I added all

    users
    > > to
    > >> > the db directory, and have this error only if I debug the

    application:
    > >> > (environment: "celan" w2000prof, interdev server, all patches.)
    > >> >
    > >> > here are the steps from the begining to produce the symptoms:
    > >> >
    > >> > 1) I create "temp" directory under wwwroot, contains "temp.asp" and

    the
    > >> mdb
    > >> > file. (TEST result in browser: successfully opens the db!)
    > >> >
    > >> > 2) right click in IIS mmc on "temp", select "Config server

    extensions",
    > >> type
    > >> > the name as "temp". (TEST result in browser: successfully opens the
    > >> > db!)
    > >> >
    > >> > 3) start Interdev. New project, connect to server, to "temp". Run

    with
    > >> > debug. Type the username and password to the login window first time
    > >> > (administrator, blank)
    > >> > TEST result in browser: Microsoft JET Database Engine (0x80004005)

    > > Unknown
    > >> > error. But debugging at least works:), i can watch variables, etc,

    just
    > >> JET
    > >> > confused. Maybe also there are some permission problem? (I'm afraid

    not
    > > at
    > >> > file system level, because i tried everything. Maybe something in

    DCOM
    > >> > configuration?)
    > >> >
    > >> > As I installed Interdev Server, maybe debugger was set correctly, but

    I
    > >> > checked it by the article
    > >> > (http://support.microsoft.com/default.aspx?scid=kb;en-us;258929)

    also,
    > > and
    > >> > found it OK.
    > >> >
    > >> > waiting your helps,
    > >> > Zoltan
    > >> >
    > >> >
    > >>
    > >>

    > >
    > >

    >
    >
    Jeff Dillon, Sep 2, 2004
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. david
    Replies:
    2
    Views:
    1,613
    Ken Cox [Microsoft MVP]
    Nov 24, 2003
  2. Alex
    Replies:
    3
    Views:
    1,477
    Alvin Bruney
    Dec 2, 2003
  3. Burton Roberts

    Error opening connection to Access (Jet) DB

    Burton Roberts, Feb 8, 2005, in forum: ASP .Net
    Replies:
    5
    Views:
    651
    Patrick Olurotimi Ige
    Feb 8, 2005
  4. Replies:
    1
    Views:
    3,444
    CyberOwl
    Sep 7, 2009
  5. dan m
    Replies:
    2
    Views:
    243
    Jeff Dillon
    Oct 6, 2004
Loading...

Share This Page