SSL and IFrames

Discussion in 'ASP .Net' started by UJ, Oct 10, 2005.

  1. UJ

    UJ Guest

    Are iframes ssl compliant? I have a web page with an iframe on it and when I
    run it I get the infamous 'Secure and unsecure items' message. When I
    comment it out, it works fine.

    Anybody seen this before or know how to fix it?

    TIA - Jeff.
     
    UJ, Oct 10, 2005
    #1
    1. Advertising

  2. UJ

    Bruce Barker Guest

    yes, they are. you get the message when you set the iframe src to a http://
    reference, and the container to a https:// reference or vise-versa.

    -- bruce (sqlwork.com)

    "UJ" <> wrote in message
    news:...
    > Are iframes ssl compliant? I have a web page with an iframe on it and when
    > I run it I get the infamous 'Secure and unsecure items' message. When I
    > comment it out, it works fine.
    >
    > Anybody seen this before or know how to fix it?
    >
    > TIA - Jeff.
    >
    >
     
    Bruce Barker, Oct 10, 2005
    #2
    1. Advertising

  3. UJ

    UJ Guest

    Bruce,
    Thanks for the info. I have my web page source as was generated by my
    project and I get the secure and unsecure message. If I comment out the
    iframe it works fine. If I remove everything except the tag
    <iframe></iframe> I still get the message about secure/unsecure. If I remove
    that command with the empty tag info, then I don't get the message. So I
    know it's the iframe and there's no source command.

    If you have an iframe with no source, what does it assume as a default?

    Any thoughts?

    TIA - Jeff.

    "Bruce Barker" <> wrote in message
    news:...
    > yes, they are. you get the message when you set the iframe src to a
    > http:// reference, and the container to a https:// reference or
    > vise-versa.
    >
    > -- bruce (sqlwork.com)
    >
    > "UJ" <> wrote in message
    > news:...
    >> Are iframes ssl compliant? I have a web page with an iframe on it and
    >> when I run it I get the infamous 'Secure and unsecure items' message.
    >> When I comment it out, it works fine.
    >>
    >> Anybody seen this before or know how to fix it?
    >>
    >> TIA - Jeff.
    >>
    >>

    >
    >
     
    UJ, Oct 10, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Marina

    OT: SSL issues with IFRAMES

    Marina, Aug 11, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    404
    Marina
    Aug 11, 2003
  2. 620
    Replies:
    2
    Views:
    1,059
    Murat Tunaboylu
    Jan 6, 2004
  3. CW
    Replies:
    2
    Views:
    557
  4. John Smith
    Replies:
    0
    Views:
    407
    John Smith
    Oct 5, 2006
  5. Pavel Smerk
    Replies:
    3
    Views:
    162
    Michal Suchanek
    Aug 15, 2006
Loading...

Share This Page