Stop caching

Discussion in 'ASP General' started by ZagrebMike, Jun 6, 2005.

  1. ZagrebMike

    ZagrebMike Guest

    On our (intranet) web site we have an ASP page that runs a report which
    serves up the results in a dynamic Excel file (i.e it specifies
    Response.ContentType = "application/vnd.ms-excel"). This works fine for most
    people. One user is having a problem, though: she generates the report once,
    and it works fine. If she changes the parameters and runs the report again,
    it displays the original result. She says it "used to" work OK.

    Environment details are:
    * MS Windows XP, Professional, Version 2002, Service Pack 2
    * IE Version 6.0.2900.2180.xpsp_sp2_gdr.050301-1519

    Some further info:
    * She's cleared the Internet Explorer cache (Tools -> Internet Options ->
    General tab -> Delete Files -> Check “Delete all offline content†-> OK)
    * She's asked IE not to cache pages (Tools -> Internet Options -> General
    tab -> Settings -> “Check for newer versions of stored pages†is set to
    “Every visit to the pageâ€.)
    * She doesn’t have a proxy server configured manually (In Tools -> Internet
    Options -> Connections tab -> LAN Settings, "Automatically detect settings is
    checked"; but "Use automatic configuration script" and "Use a proxy server
    LAN" are not checked.

    The ASP includes:
    Response.CacheControl = "no-cache" 'stop proxy servers caching the
    page
    Response.Expires = -1 'tell browser page
    shouldn't be cached
    Response.AddHeader "Pragma", "No-Cache" 'force IE not to cache page

    Any help appreciated!
    ZagrebMike, Jun 6, 2005
    #1
    1. Advertising

  2. ZagrebMike

    [MSFT] Guest

    Just one user got the problem? If he close the browser and reopen it again
    with different parameters, will he get different results? Also, I suggest
    you check the application's logic to see if this is related to the user
    account or his computer.

    Luke
    [MSFT], Jun 7, 2005
    #2
    1. Advertising

  3. ZagrebMike

    ZagrebMike Guest

    >>Just one user got the problem?
    Yes, as far as I know

    >>If he close the browser and reopen it again with different parameters, will he get different results?

    Yes, she gets the correct (different) results if she closes down the browser
    and runs the report again.

    >>I suggest you check the application's logic to see if this is related to the user account or his computer.

    I'm confident that there's nothing in the app that is user- or PC-related.
    Did you have anything specific in mind?

    Thanks
    Mike

    "[MSFT]" wrote:

    > Just one user got the problem? If he close the browser and reopen it again
    > with different parameters, will he get different results? Also, I suggest
    > you check the application's logic to see if this is related to the user
    > account or his computer.
    >
    > Luke
    >
    >
    ZagrebMike, Jun 7, 2005
    #3
  4. ZagrebMike

    [MSFT] Guest

    When the Excel file was passed to the client side, is there a "Open or
    Save" dialog? If so, you may save the files twice to see if there is any
    difference. If the saved file are same, the problem may be on server side,
    or your user submit same query twice to the server. I suggest you may
    perform a check with netmon to make sure this.

    Luke
    [MSFT], Jun 8, 2005
    #4
  5. ZagrebMike

    ZagrebMike Guest

    Thanks for the response.

    I should have also said that, when the user runs the reports from another
    PC, everything works as expected: i.e. it does appear to be a client-side
    problem.

    >>When the Excel file was passed to the client side, is there a "Open or Save" dialog?

    No. But, if she runs the report from another PC, there *is* an "Open or
    Save" dialog and the report works correctly.

    Mike
    ZagrebMike, Jun 8, 2005
    #5
  6. ZagrebMike

    ZagrebMike Guest

    The problem appears to have been at least partially solved, but I'm not sure
    why. I asked the user to "click Folder Options on the Tools menu. Click the
    File Types tab, choose “XLS Microsoft Excel Worksheet†in the Registered file
    types box, and then click Advanced. Make sure that the Confirm open after
    download check box is checked, and then click OK" so that I could ask her to
    generate the files.

    She responded: "As well as ticking the 'Confirm Open After Download', I
    tried taking off the tick that said 'Browse in same window' and it seems to
    have cured the problem. I have to close Excel down before I open the next
    file, but that's no big deal. I took the confirm open after download off
    now. And it's working fine as long as I close Excel."
    ZagrebMike, Jun 8, 2005
    #6
  7. ZagrebMike

    [MSFT] Guest

    Maybe you can have her try to enable "Browse in same window" again to see
    if it can work in same IE window, if she couldn't live with closing Excel
    again and again. Also, in IE, Click Tools/Internet Options, on "general"
    tab, click "settings", and select "Every visit to the page", this may help
    on this issue.

    Luke
    [MSFT], Jun 9, 2005
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hypo
    Replies:
    6
    Views:
    406
  2. Troy Simpson

    Fragment Caching inside page caching?

    Troy Simpson, Jan 19, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    785
    Troy Simpson
    Jan 19, 2004
  3. Meron Lavie

    How To Stop Caching By ISP Proxy Servers

    Meron Lavie, Apr 27, 2004, in forum: ASP .Net
    Replies:
    4
    Views:
    8,798
    anilakhwaja
    Jul 16, 2007
  4. =?Utf-8?B?bGFuZW0=?=

    How can I stop PDF docs from caching on my website?

    =?Utf-8?B?bGFuZW0=?=, Jul 19, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    687
    =?Utf-8?B?bGFuZW0=?=
    Jul 20, 2005
  5. JimLad
    Replies:
    3
    Views:
    912
    JimLad
    Jan 21, 2010
Loading...

Share This Page