Virtual directory path problem

Discussion in 'ASP General' started by Sangeetha, Dec 21, 2005.

  1. Sangeetha

    Sangeetha Guest

    Hello All,
    I have a web application called Remoter and the application resides in this
    path
    'D:\InetPub\websites\dev1\Remoter'. Now if I access the application(that is
    homepage default.asp in D:\InetPub\websites\dev1\Remoter), it fails. Inside
    default.asp, I have used Server.Execute(displayURL) where displayURL = "
    \WebParts\HTMLEditor\HTMLDisplay.asp". Now this Server.Execute fails. If I do
    a Server.MapPath(displayURL) to check if it is able to access the right file
    in right path, it returns me
    D:\InetPub\websites\dev1\WebParts\HTMLEditor\HTMLDisplay.asp
    instead of
    D:\InetPub\websites\dev1\Remoter\WebParts\HTMLEditor\HTMLDisplay.asp
    I dont understand why the the virtual directory name gets missed out in the
    URL. I checked up the virtual directory settings in IIS and it seems fine and
    the right location is only
    D:\InetPub\websites\dev1\Remoter\WebParts\HTMLEditor\HTMLDisplay.asp. Can
    someone help ?
    Sangeetha, Dec 21, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Singer
    Replies:
    0
    Views:
    533
    Steve Singer
    Feb 15, 2005
  2. Richard
    Replies:
    1
    Views:
    534
    Richard
    May 14, 2006
  3. Replies:
    9
    Views:
    489
    Juan T. Llibre
    Dec 7, 2006
  4. =?Utf-8?B?SmVmZiBCZWVt?=

    physical path to virtual path under virtual directory

    =?Utf-8?B?SmVmZiBCZWVt?=, Aug 1, 2007, in forum: ASP .Net
    Replies:
    4
    Views:
    1,035
    Eliyahu Goldin
    Aug 1, 2007
  5. rockdale

    include virtual in virtual directory?

    rockdale, Sep 3, 2008, in forum: ASP General
    Replies:
    3
    Views:
    437
    rockdale
    Sep 4, 2008
Loading...

Share This Page