Visual Studio Reformatting my HTML!

Discussion in 'ASP .Net' started by Curt, Jun 18, 2004.

  1. Curt

    Curt Guest

    When I'm in Visual Studio.NET, I'll drag controls onto a form and then
    switch from design mode to HTML for various reasons.

    I was doing this with validation controls that I had dragged onto the
    screen, and when I went into HTML to add some attributes, I
    reformatted the tags so that everything was easier to read. When I
    went back to design mode and fiddled around some more, I found that
    when I came back to HTML, the IDE had completely reformatted my HTML
    into one big, unreadable clump of text.

    This seems to be done automatically by Visual Studio.NET. Is there
    any wayt to shut this option off?
    Curt, Jun 18, 2004
    #1
    1. Advertising

  2. Curt

    Eric Cherng Guest

    Curt,

    Yes, you can disable the automatic HTML formatting by going to Tools,
    Options, Text Editor, Format
    then in the Apply Automatic Formatting section, uncheck the check boxes to
    disable automatic formatting.

    Eric


    "Curt" <> wrote in message
    news:...
    > When I'm in Visual Studio.NET, I'll drag controls onto a form and then
    > switch from design mode to HTML for various reasons.
    >
    > I was doing this with validation controls that I had dragged onto the
    > screen, and when I went into HTML to add some attributes, I
    > reformatted the tags so that everything was easier to read. When I
    > went back to design mode and fiddled around some more, I found that
    > when I came back to HTML, the IDE had completely reformatted my HTML
    > into one big, unreadable clump of text.
    >
    > This seems to be done automatically by Visual Studio.NET. Is there
    > any wayt to shut this option off?
    Eric Cherng, Jun 18, 2004
    #2
    1. Advertising

  3. Curt

    Sahil Malik Guest

    Whidbey / VS2k5 RESPECTS your HTML, VS2k3 doesn't .. sorry but you're SOL on
    that one.

    - Sahil Malik
    Independent Consultant
    You can reach me thru my blog - http://dotnetjunkies.com/WebLog/sahilmalik/



    "Curt" <> wrote in message
    news:...
    > When I'm in Visual Studio.NET, I'll drag controls onto a form and then
    > switch from design mode to HTML for various reasons.
    >
    > I was doing this with validation controls that I had dragged onto the
    > screen, and when I went into HTML to add some attributes, I
    > reformatted the tags so that everything was easier to read. When I
    > went back to design mode and fiddled around some more, I found that
    > when I came back to HTML, the IDE had completely reformatted my HTML
    > into one big, unreadable clump of text.
    >
    > This seems to be done automatically by Visual Studio.NET. Is there
    > any wayt to shut this option off?
    Sahil Malik, Jun 18, 2004
    #3
  4. Curt

    Sahil Malik Guest

    Wow, then what is this about
    http://www.asp.net/whidbey/whitepapers/VSWhidbeyOverview.aspx?tabindex=0&tabid=1 ?

    - Sahil Malik
    Independent Consultant
    You can reach me thru my blog - http://dotnetjunkies.com/WebLog/sahilmalik/



    "Eric Cherng" <ericch1@remove_the_dot-hotmai.l.com> wrote in message
    news:e%...
    > Curt,
    >
    > Yes, you can disable the automatic HTML formatting by going to Tools,
    > Options, Text Editor, Format
    > then in the Apply Automatic Formatting section, uncheck the check boxes to
    > disable automatic formatting.
    >
    > Eric
    >
    >
    > "Curt" <> wrote in message
    > news:...
    > > When I'm in Visual Studio.NET, I'll drag controls onto a form and then
    > > switch from design mode to HTML for various reasons.
    > >
    > > I was doing this with validation controls that I had dragged onto the
    > > screen, and when I went into HTML to add some attributes, I
    > > reformatted the tags so that everything was easier to read. When I
    > > went back to design mode and fiddled around some more, I found that
    > > when I came back to HTML, the IDE had completely reformatted my HTML
    > > into one big, unreadable clump of text.
    > >
    > > This seems to be done automatically by Visual Studio.NET. Is there
    > > any wayt to shut this option off?

    >
    >
    Sahil Malik, Jun 18, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. wh
    Replies:
    2
    Views:
    509
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  2. Thirumalai
    Replies:
    0
    Views:
    657
    Thirumalai
    May 22, 2006
  3. sck10
    Replies:
    13
    Views:
    636
    sck10
    Aug 17, 2006
  4. rockdale
    Replies:
    1
    Views:
    602
    Juan T. Llibre
    Aug 23, 2006
  5. xman
    Replies:
    0
    Views:
    492
Loading...

Share This Page