Win2003 SP1 error: "New transaction cannot enlist in the specified transaction coordinator"

Discussion in 'ASP General' started by Vencz Istv?n, Apr 29, 2005.

  1. Vencz Istv?n

    Vencz Istv?n Guest

    I have a web application installed on Windows 2003 Standard Edition
    with SP1, it accesses a SQL Servet 2000 database installed on Windows
    2000 Server, the two computers are not in the same domain. The web
    application uses ASP pages and COM+ components written in VB6.
    After the installation of SP1 for Windows 2003 the application does
    not work anymore (before the installation of SP1 it worked without
    problems). The following error occurs: "New transaction cannot enlist
    in the specified transaction coordinator".
    If I change in Component Services the componets' Transaction model
    from Required to Supported then the application works fine.

    Does anybody know if this is a limitation of Windows 2003 SP1 or a bug
    or if there is a solution in order to solve the problem.

    Thanks,
    István
    Vencz Istv?n, Apr 29, 2005
    #1
    1. Advertising

  2. Hi István

    "Vencz Istv?n" <> schrieb im Newsbeitrag
    news:...
    >I have a web application installed on Windows 2003 Standard Edition
    > with SP1, it accesses a SQL Servet 2000 database installed on Windows
    > 2000 Server, the two computers are not in the same domain. The web
    > application uses ASP pages and COM+ components written in VB6.
    > After the installation of SP1 for Windows 2003 the application does
    > not work anymore (before the installation of SP1 it worked without
    > problems). The following error occurs: "New transaction cannot enlist
    > in the specified transaction coordinator".
    > If I change in Component Services the componets' Transaction model
    > from Required to Supported then the application works fine.


    have you checked if the SP1 changed the settings for MSDTC under Component
    Services?
    AFAIK SP1 introduced the option to allow anonymous access to MSDTC (No
    authentication required) in the UI - before you had to set it in the
    registry to allow web apps to use transactions.
    Maybe they also set a different default value - it wouldn't be the first
    time ;-)

    Helge
    Helge C. Rutz, Apr 29, 2005
    #2
    1. Advertising

  3. Vencz Istv?n

    Guest

    Indeed this was the cause of the problem, after the installation of SP1
    the implicit value is "mutual authentication required". I was not aware
    about this new feature.

    Thank you very much for your help,
    István
    , May 2, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. lh
    Replies:
    0
    Views:
    435
  2. =?Utf-8?B?TmVhbA==?=
    Replies:
    0
    Views:
    399
    =?Utf-8?B?TmVhbA==?=
    Sep 19, 2005
  3. Vijay
    Replies:
    1
    Views:
    311
    Joern Schou-Rode
    Nov 1, 2008
  4. Judy
    Replies:
    0
    Views:
    1,044
  5. Scott Gordo
    Replies:
    4
    Views:
    441
    Scott Gordo
    Mar 15, 2006
Loading...

Share This Page