0x80040111 Error on IIS 5.1 (WinXP)

Discussion in 'ASP General' started by Vladimir, Jun 30, 2003.

  1. Vladimir

    Vladimir Guest

    Getting 0x80040111 Error on trivial IISHelp -
    http://localhost/IISHelp/iis/misc/default.asp

    HTTP 500.100 - Internal Server Error - ASP error
    Internet Information Services
    Technical Information (for support personnel)

    a.. Error Type:
    Server object, ASP 0177 (0x80040111)
    ClassFactory cannot supply requested class
    /IISHelp/iis/misc/default.asp, line 12


    b.. Browser Type:
    Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

    c.. Page:
    GET /IISHelp/iis/misc/default.asp
    I've tried everything: folder permissions, Directory Security - anonymous
    access toggle on/of - nothing helps. Can't understand what goes wrong.

    Please help!
    Vladimir,
     
    Vladimir, Jun 30, 2003
    #1
    1. Advertisements

  2. Vladimir

    Tim Williams Guest

    post the relevant code....

    tim
     
    Tim Williams, Jun 30, 2003
    #2
    1. Advertisements

  3. Maybe you could show line 12 of /IISHelp/iis/misc/default.asp ???

    After looking at http://www.aspfaq.com/2393

    --
    Aaron Bertrand, SQL Server MVP
    http://www.aspfaq.com/

    Please reply in the newsgroups, but if you absolutely
    must reply via e-mail, please take out the TRASH.
     
    Aaron Bertrand [MVP], Jun 30, 2003
    #3
  4. Vladimir

    Vladimir Guest

    the line is:
    Set OBJbrowser = Server.CreateObject("MSWC.BrowserType")

    It's standard IIS Help system which is some how broken.
     
    Vladimir, Jun 30, 2003
    #4
  5. Set OBJbrowser = Server.CreateObject("MSWC.BrowserType")

    I don't believe these objects are available in XP, at least not by default.
    Are you using the old IIS 4/5 help pages on an XP install?
     
    Aaron Bertrand [MVP], Jun 30, 2003
    #5
  6. Vladimir

    Vladimir Guest

    I presume it IIS 5.1. Initially the IIS wasn't installed. I've installed it
    from winXP pro CD. It worked, but now somehow it doesn't.
    -I updated MDAC to latest 2.7 + all patches
    -I run the latest SP for IIS 5.1
    -I installed w3 JMail
    -And finally updated IE 6 and XP with all recommended security patches

    I'm going nuts, how different and they do the security in XP in comparing
    with w2K

    TIA
    Vladimir
     
    Vladimir, Jul 1, 2003
    #6
  7. Vladimir

    Vladimir Guest

    noop! in title it says "Microsoft Internet Information Serveices 5.1
    documentation"
     
    Vladimir, Jul 1, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.