About The Pickaxe 2nd ed. and Ruby 2

Discussion in 'Ruby' started by Surgeon, Jan 5, 2006.

  1. Surgeon

    Surgeon Guest

    Hi,
    I have just ordered the Pickaxe 2nd ed. from Amazon. But now I am
    thinking that in a near future Ruby 2 will be released and this
    wondeful book is on Ruby 1.8. Well, what will happen then? Will it be
    "démodé"?
     
    Surgeon, Jan 5, 2006
    #1
    1. Advertisements

  2. Surgeon

    Phil Tomson Guest

    First off, I don't know if anyone really knows when Ruby 2.0 will actually be
    released. The current 1.9 experimental branch is the testbed for things 2.0.
    If history is any guide I doubt you'll see 2.0 before Christmas of 2006 (Matz
    likes to give us all presents), so at a minimum you'll get a year of use from
    the current Pickaxe. However, if I had to guess I'd say that for Christmas 2006
    we'll see 1.8.6 or 1.8.7 with 2.0 not arriving til Christmas of 2007 (if it
    comes earlier I'll be pleasantly surprised ;-)

    I suspect you'll be glad you got the Pickaxe now because you can start using
    it as a reference for Ruby 1.8 which will remain relevant for at least a couple
    of years. Even if 2.0 arrives early, the current Pickaxe book will stil be
    something like 95%+ compatible.... differences will likely be posted on the
    web somewhere (as was the case in the 1.6 -> 1.8 transition).

    Phil
     
    Phil Tomson, Jan 5, 2006
    #2
    1. Advertisements

  3. Surgeon

    Gene Tani Guest

    Gene Tani, Jan 6, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.