customErrors mode="Off"

T

Tor Inge Rislaa

I am prompted to implement the syntax below to be able to monitor the error
on the remote server trough my browser (client).

I can't seem to find where to place the code in my web.config file to get
this to work.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

The code below is my web.config file. Anyone having a suggestion of where to
implement the syntax?

<?xml version="1.0"?>

<configuration>

<connectionStrings>

<add name="Personal" connectionString="Data Source=.\SQLExpress;Integrated
Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Personal.mdf"
providerName="System.Data.SqlClient" />

<remove name="LocalSqlServer"/>

<add name="LocalSqlServer" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspnetdb.mdf" />

</connectionStrings>

<system.web>

<pages styleSheetTheme="White"/>

<customErrors mode="RemoteOnly"/>

<compilation debug="false"/>

<authentication mode="Forms">

<forms loginUrl="Default.aspx" protection="Validation" timeout="300" />

</authentication>

<authorization>

<allow users="*"/>

</authorization>

<globalization requestEncoding="utf-8" responseEncoding="utf-8"/>

<roleManager enabled="true"/>

<siteMap defaultProvider="XmlSiteMapProvider" enabled="true">

<providers>

<add name="XmlSiteMapProvider"

description="SiteMap provider which reads in .sitemap XML files."

type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.3600.0,
Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"

siteMapFile="web.sitemap"

securityTrimmingEnabled="true"/>

</providers>

</siteMap>

</system.web>

<location path="Admin">

<system.web>

<authorization>

<allow roles="Administrators"/>

<deny users="*"/>

</authorization>

</system.web>

</location>

</configuration>
 
C

Cowboy \(Gregory A. Beamer\)

You may not have that tag in your file. Add this tag

<customErrors mode="Off"/>

anywhere between

<system.web>

and

</system.web>

except nested inside other tags.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

*************************************************
Think outside of the box!
*************************************************
 
T

Tor Inge Rislaa

Work just fine now....
....thanks!

Cowboy (Gregory A. Beamer) said:
You may not have that tag in your file. Add this tag

<customErrors mode="Off"/>

anywhere between

<system.web>

and

</system.web>

except nested inside other tags.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

*************************************************
Think outside of the box!
*************************************************
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
473,836
Messages
2,569,748
Members
45,545
Latest member
rapter____0

Latest Threads

Top