double configuration error of spring context when deploying web app


K

kamiseq

ouups, sorry :) Im too tired, I guess :)
ok so I have a problem with deployment of my war app in tomcat server

this is my log
2008-10-19 23:45:06 org.apache.catalina.core.StandardContext
addApplicationListener
INFO: The listener
"org.springframework.web.context.ContextLoaderListener" is already
configured for this context. The duplicate definition has been
ignored.
2008-10-19 23:45:06 org.apache.catalina.core.StandardContext
addApplicationListener
INFO: The listener "pl.pointit.web.listener.ContextCycleListener" is
already configured for this context. The duplicate definition has been
ignored.
2008-10-19 23:45:06 org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
and it seems my web.xml is totally fine
<?xml version="1.0" encoding="UTF-8"?>
<web-app version="2.5" xmlns="http://java.sun.com/xml/ns/javaee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaeehttp://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
<servlet>
<servlet-name>AutorizationServlet</servlet-name>
<servlet-class>pl.pointit.web.servlet.AutorizationServlet</
servlet-class>
</servlet>
<servlet-mapping>
<servlet-name>AutorizationServlet</servlet-name>
<url-pattern>/login.html</url-pattern>
</servlet-mapping>
<session-config>
<session-timeout>30</session-timeout>
</session-config>
<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
<!--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ --

<context-param>
<param-name>contextConfigLocation</param-name>
<param-value>classpath:spring.xml</param-value>
</context-param>
<listener>
<description>primary Spring Framework configuration</
description>
<listener-
class>org.springframework.web.context.ContextLoaderListener</listener-
class>
</listener>
<listener>
<listener-class>pl.pointit.web.listener.ContextCycleListener</
listener-class>
</listener>
<!--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ --

<servlet>
<servlet-name>weborb</servlet-name>
<servlet-class>weborb.ORBServlet</servlet-class>
<load-on-startup> 1 </load-on-startup>
</servlet>
<servlet>
<servlet-name>download</servlet-name>
<servlet-class>weborb.DownloadServlet</servlet-class>
<load-on-startup> 1 </load-on-startup>
</servlet>
<servlet-mapping>
<servlet-name>download</servlet-name>
<url-pattern>/codegen.wo</url-pattern>
</servlet-mapping>
<servlet-mapping>
<servlet-name>weborb</servlet-name>
<url-pattern>*.wo</url-pattern>
</servlet-mapping>
<!--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ --

</web-app>

I couldnt find anything on google and I run out of ideas.....maybe it
is something about my Tomcat server itself????
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top