Modelsim MXE on wine?

G

Guest

I had MXE (Modelsim Xilinx Edition) running successfully under Wine
until recently. However, following a lot of changes, I 've just
re-installed it, and can't get vsim running. My setup is SL(/RHEL)6,
64-bit, wine 1.2.3. I've installed MXE-III Starter, for both VHDL and
Verilog. When I run vsim I get a pop-up with a long message which
starts:

'can't read "view_master": no such variable when executing
"GUIMAIN"...'

The problem is in the tcl start-up (tcl/vsim/vsim). Anyone else seen
this? Any ideas?

Thanks.
 
A

Allan Herriman

I had MXE (Modelsim Xilinx Edition) running successfully under Wine
until recently. However, following a lot of changes, I 've just
re-installed it, and can't get vsim running. My setup is SL(/RHEL)6,
64-bit, wine 1.2.3. I've installed MXE-III Starter, for both VHDL and
Verilog. When I run vsim I get a pop-up with a long message which
starts:

'can't read "view_master": no such variable when executing "GUIMAIN"...'

The problem is in the tcl start-up (tcl/vsim/vsim). Anyone else seen
this? Any ideas?

I've seen that same error message with Modelsim under Wine. It was a
year or two ago using 64 bit Ubuntu so I can't remember the exact details
but the problem eventually went away when Canonical included a more
recent version of Wine.

The errors went away with Wine 1.4, however I now use Windows 7 on my
work computer and versions of Modelsim post 6.something work fine on that.

Regards,
Allan
(followups not set)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,795
Messages
2,569,644
Members
45,357
Latest member
RuthEsteve

Latest Threads

Top