ObjectList Rendering Problems in Windows Mobile 5 Versions

Discussion in 'ASP .Net Mobile' started by andrew.cripps, Oct 12, 2006.

  1. Help!

    We're using an ObjectList control to produce a neat table of data for
    rendering on Windows Mobile 5 devices through IE.

    We've got two different Windows Mobile 5 devices - device A is OS
    5.1.70 Build 14409.1.1.2, device B is OS 5.1.195 Build 14955.2.3.0
    (i.e. device B is a later ROM).

    On the older build, the rendering works fine. On the later build, it
    ignores the fact that it should be a table and just outputs a bare
    horrible-looking list.

    I can't find anything on this anywhere, has anyone experienced a
    similar problem?

    Any help greatly appreciated.

    Thanks

    Andy
     
    andrew.cripps, Oct 12, 2006
    #1
    1. Advertisements

  2. I've answered my own question!

    The device that was faulty had an HTTP_USER_AGENT which did not start
    with Mozilla/4.0, instead had
    Vodafone/1.0/HTC_Mercury/1.20.161.3/Mozilla/4.0, which meant that the
    browser capabilities failed.

    In my case I hacked the registry of the device to remove all the
    Vodafone cr@p and rendering worked fine. You could also handle this
    server-side I guess.
     
    andrew.cripps, Oct 18, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.