page got cleaned up and now it doesn't display in IE 7


J

jr

This is rather urgent.
I made the changes suggested below to clean up the code. It works in
chrome.
it doesn't work in I.e. 7 which is the requirement. The page is blank
when I go to it from a link.
Is it a closing tag of something? Did I put something in that I.E. 7
choked on. help,
thanks,

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Cart Inventory Upload</title>
<style type="text/css">
.ast { color:red; }
td {font-family:verdana; font-size:12px; line-height:12pt;}
th {font-family:verdana; font-size:12px; line-height:12pt;}
.txt1 {font-family:verdana; font-size:20px;}
a:link {color: blue; text-decoration: none;} /* unvisited link */
a:visited {color: blue; text-decoration: none; } /* visited link */
a:hover {color: #FF00FF} /* mouse over link */
</style>

<script language='javascript'>
function validate_form(thisform) {

var sMsg='';
var sSel='N';
with (thisform) {
if ( cart_id.value=='' ) { sMsg+="No cart_id\r\n"; }
if ( uploadedfile.value=='' ) { sMsg+="No uploaded File
\r\n"; }
for (i = 1; i < bu.length; i++) {
if ( bu.selected) { sSel='Y'; }

}
if ( sSel=='N' ) { sMsg+="No BU selected\r\n"; }

var myfile=uploadedfile;
if ( myfile.value.match(/\.csv$/gi)!=".csv") { sMsg
+="File is not a csv file.\r\n"; }


if ( sMsg.length > 0 ) {
alert(sMsg);
return false;

}
}

}


<script type='text/javascript'>
</head>
<body>
<!--<link href="http://webstyleguide.kp.org/css/rev01/default.css"
rel="stylesheet" type="text/css" />-->
<a href='admin.php'>Admin Menu</a><br />


<form method='post' enctype='multipart/form-data' action='/tools/
cart_inventory/uploader4.php' onsubmit='return validate_form(this);'>
<h2 align='center'>Cart Upload Form</h2>
<table align='center'>
<td><table cellpadding='3' cellspacing='0' border='0' style='border:
1px solid #CCCCCC' align='center'>
<th colspan='2'><span class='ast'>*</span>File to upload
<tr>
<td colspan='2'><input type='file' name='uploadedfile' size='50'
onchange='checkFileType()not listed/available;'>
<tr>
<th align='right'><span class='ast'>*</span>BU
<td><select name='BU'>
<option value=''></option>
<option value='08001'>08001</option>
<option value='08002'>08002</option>
<option value='08003'>08003</option>
<option value='08004'>08004</option>
<option value='08005'>08005</option>
<option value='08006'>08006</option>
<option value='08007'>08007</option>
<option value='08008'>08008</option>
<option value='08009'>08009</option>
<option value='08010'>08010</option>
<option value='08011'>08011</option>
<option value='08012'>08012</option>
<option value='08013'>08013</option>
<option value='08014'>08014</option>
<option value='08015'>08015</option>
<option value='08016'>08016</option>
<option value='08017'>08017</option>
<option value='08018'>08018</option>
<option value='08019'>08019</option>
<option value='08020'>08020</option>
<option value='08021'>08021</option>
<option value='08100'>08100</option>
<option value='08101'>08101</option>
<option value='08102'>08102</option>
<option value='08103'>08103</option>
<option value='08104'>08104</option>
<option value='08105'>08105</option>
<option value='08106'>08106</option>
<option value='08107'>08107</option>
<option value='08108'>08108</option>
<option value='08109'>08109</option>



</select><tr>
<th align='right'><span class='ast'>*</span>Cart ID</option>
<td><select name='Cart ID>
</select><tr>
<td align='center' colspan='2'><input type='submit' value='Upload'>
</table>
<tr>
<td><span class='ast'>*</span> - <font size='-1'><i>Required</i></
font>
</table>
</form>
</body>
</html>
 
Ad

Advertisements

E

Evertjan.

jr wrote on 06 jul 2010 in comp.lang.javascript:
This is rather urgent.

Traditionally that would not help you on usenet.
I made the changes suggested below to clean up the code. It works in
chrome.
it doesn't work in I.e. 7 which is the requirement. The page is blank
when I go to it from a link.

Did you debug?
Did you go back to the old code and alererd row by row?
Is it a closing tag of something?


Did I put something in that I.E. 7
choked on. help,
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Why Transitional? a clean page should use "strict"
<script language='javascript'>

You did not clean this last century code.

I do not see a closing said:
<script type='text/javascript'>
</head>

that is not legal javascript.
 
Ad

Advertisements

J

jr

jr wrote on 06 jul 2010 in comp.lang.javascript:


Traditionally that would not help you on usenet.


Did you debug?
Did you go back to the old code and alererd row by row?


Why Transitional? a clean page should use "strict"


You did not clean this last century code.



that is not legal javascript.

hi Evertjan, I know no one is in a hurry on usenet and that doesn't
work but thanks very much I can go to work now :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top