Please help me!!! ModelSim question

Discussion in 'VHDL' started by Simone Winkler, Aug 27, 2003.

  1. Hello!

    I am a newbie trying to perform a simulation with ModelSim...
    I did a (very small) project with the Xilinx downloadable webpack - and as i
    wanted to simulate it with modelsim, modelsim closed after the following
    line:

    #vsim -lib work -t 1ps -L xilinxcorelib testbench

    the transcript file shows the following:

    # Reading D:/Programme/Modeltech_5.5d/win32/../tcl/vsim/pref.tcl

    my modelsim version is 5.5d - but i also tried 5.5e. Didn't work!
    They always crash after the same line.
    I already tried to reinstall everything - no change. I don't know what to do
    anymore...please help me!!!!

    Thanx,
    Simone
     
    Simone Winkler, Aug 27, 2003
    #1
    1. Advertisements

  2. yikes! Let's start with something a little simpler.

    1.Open an editor and save the following file as hi.vhd:

    -------------------------
    -- hi.vhd
    entity hi is
    end entity hi;

    architecture sim of hi is

    begin
    process is
    begin
    report "Hi.";
    wait;
    end process;
    end architecture sim;
    --------------------------

    2. bring up a modelsim or vsim prompt.

    3. use the pwd, cd, and dir commands
    to get to hi.vhd

    4. make a work library:

    vlib work
    vmap work work

    5. Compile hi.vhd

    vcom hi.vhd

    6. Run hi

    vsim -c hi
    run

    7. If you get: # ** Note: Hi
    then Modelsim is not your problem.
    Compile your own source files the same way
    and take if from there.
    use: vdir to make sure everything compiled
    use: vdir -lib ieee to make sure you have the standard packages
    use: vdir -lib xilinxcorelib to make sure you have the xilinx lib

    -- Mike Treseler
     
    Mike Treseler, Aug 27, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.