Rake 0.8.7 needs Ruby 1.8?


J

Jaime Stuardo

Hello..

I am trying to install a Ruby application called Redmine. In order to
create database structure, I have to execute this command: rake
db:migrate

When I run it, a message telling that msvcrt-ruby18.dll was not found
(I'm attaching the complete message). I have downloaded the last ruby
version (1.9.1) and when I install it, it automatically installed rake
0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the
wrong DLL?

This is the environment setting:

RubyGems Environment:
- RUBYGEMS VERSION: 1.3.6
- RUBY VERSION: 1.9.1 (2010-01-10 patchlevel 378) [i386-mingw32]
- INSTALLATION DIRECTORY: C:/Ruby19/lib/ruby/gems/1.9.1
- RUBY EXECUTABLE: C:/Ruby19/bin/ruby.exe
- EXECUTABLE DIRECTORY: C:/Ruby19/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-mingw32
- GEM PATHS:
- C:/Ruby19/lib/ruby/gems/1.9.1
- C:/Documents and Settings/Administrator/.gem/ruby/1.9.1
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://rubygems.org/

And these are the gems that were installed automatically:

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
mysql (2.8.1)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)
rmagick (2.12.0)
rubygems-update (1.3.6)

Any help will be greatly appreciated
Thanks

Jaime

Attachments:
http://www.ruby-forum.com/attachment/4635/error.JPG
 
Ad

Advertisements

R

Roger Pack

Jaime said:
Hello..

I am trying to install a Ruby application called Redmine. In order to
create database structure, I have to execute this command: rake
db:migrate

When I run it, a message telling that msvcrt-ruby18.dll was not found
(I'm attaching the complete message). I have downloaded the last ruby
version (1.9.1) and when I install it, it automatically installed rake
0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the
wrong DLL?

This means "you're running some gem or other that has binaries for 1.8
but not 1.9" what's your backtrace? (rake --trace I think).
-rp
 
J

Jaime Stuardo

Hello Roger... by executing that command, I receive this response:

C:\Documents and Settings\Administrator>rake --trace
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb,
Rakefile.rb)
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2377:in
`raw_load_rake
file'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2017:in `block
in load
_rakefile'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exce
ption_handling'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2016:in
`load_rakefile
'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2000:in `block
in run'

C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exce
ption_handling'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rake-0.8.7/bin/rake:31:in `<top
(required)>'
C:/Ruby19/bin/rake:19:in `load'
C:/Ruby19/bin/rake:19:in `<main>'

Thanks
Jaime
 
R

Roger Pack

Hello Roger... by executing that command, I receive this response:
C:\Documents and Settings\Administrator>rake --trace
rake aborted!

Thanks for doing that. The backtrace I even more desire would be
$ rake db:migrate --trace

My first guess is a bad mysql gem [?] but the backtrace will tell us
better.
-rp
 
Ad

Advertisements

L

Luis Lavena

Hello..

I am trying to install a Ruby application called Redmine. In order to
create database structure, I have to execute this command: rake
db:migrate

When I run it, a message telling that msvcrt-ruby18.dll was not found
(I'm attaching the complete message). I have downloaded the last ruby
version (1.9.1) and when I install it, it automatically installed rake
0.8.7. Since I have msvcrt-ruby191.dll, why rake is trying to load the
wrong DLL?

Rake do not depend directly of Ruby runtime library either for 1.8 or
1.9, as is pure ruby.

What you might be experiencing is a gem that your application depends
on that do not provide binaries for Ruby 1.9, the version fo Ruby
you're running.

Please provide the output of "rake db:migrate --trace" from inside
your application folder and not your home/profile directory as you
executed in response to Roger comments.
This is the environment setting:

RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.6
  - RUBY VERSION: 1.9.1 (2010-01-10 patchlevel 378) [i386-mingw32]
  - INSTALLATION DIRECTORY: C:/Ruby19/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: C:/Ruby19/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/Ruby19/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - C:/Ruby19/lib/ruby/gems/1.9.1
     - C:/Documents and Settings/Administrator/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     -http://rubygems.org/

And these are the gems that were installed automatically:

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
mysql (2.8.1)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)
rmagick (2.12.0)
rubygems-update (1.3.6)

My guess will be around rmagick gem, as I'm unaware of it being
distributed as fat-binaries and even less for Ruby 1.9 support.

Since you're running Ruby from RubyInstaller, those are my
assumptions, but I might be wrong.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top