Segmentation Fault (core dumped) on Solaris 10

Discussion in 'Perl Misc' started by mariakvelasco, Jan 8, 2008.

  1. Hello,

    I am trying to run a perl script on a Solaris 10 machine, which is
    suppose to display a dialog box and I keep getting a Segmentation
    Fault (core dumped) error. I don't get this error message when I run
    it on Windows or Linux. Does anyone have an idea on where I should
    look for the root of the problem.

    Any advice would be great.

    Thanks!
     
    mariakvelasco, Jan 8, 2008
    #1
    1. Advertisements

  2. Post the script (if it's small), or a small example script which
    demonstrates the problem. The output of perl -V could also help us
    diagnose the problem.
     
    nolo contendere, Jan 8, 2008
    #2
    1. Advertisements


  3. This is what perl -V returns

    Summary of my perl5 (revision 5.0 version 6 subversion 1)
    configuration:
    Platform:
    osname=solaris, osvers=2.7, archname=sun4-solaris
    uname='sunos dewitt.vnet.net 5.7 generic_patch sun4u sparc '
    config_args='-Dcc=gcc -de'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef
    usemultiplicity=undef
    useperlio=undef d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    Compiler:
    cc='gcc', ccflags ='-fno-strict-aliasing -I/usr/local/include -
    D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O',
    cppflags='-fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='2.95.3 20010315 (release)',
    gccosandvers='solaris2.7'
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
    d_longlong=define, longlongsize=8, d_longdbl=define,
    longdblsize=16
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
    lseeksize=8
    alignbytes=8, usemymalloc=y, prototype=define
    Linker and Libraries:
    ld='gcc', ldflags =' -L/usr/local/lib '
    libpth=/usr/local/lib /usr/lib /usr/ccs/lib
    libs=-lsocket -lnsl -lgdbm -ldl -lm -lc
    perllibs=-lsocket -lnsl -ldl -lm -lc
    libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a
    Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-fPIC', lddlflags='-G -L/usr/local/lib'


    Characteristics of this binary (from libperl):
    Compile-time options: USE_LARGE_FILES
    Built under solaris
    Compiled at Apr 26 2001 16:17:32
    @INC:
    /usr/local/lib/perl5/5.6.1/sun4-solaris
    /usr/local/lib/perl5/5.6.1
    /usr/local/lib/perl5/site_perl/5.6.1/sun4-solaris
    /usr/local/lib/perl5/site_perl/5.6.1
    /usr/local/lib/perl5/site_perl
     
    mariakvelasco, Jan 8, 2008
    #3

  4. I am using Tk modules to create my dialog boxes.

    The problem is on my machine, I get the right result when running my
    script; however, it's run on a different machine, the Segmentation
    Fault error arises.

    Is there something missing on the other solaris machine?
     
    mariakvelasco, Jan 10, 2008
    #4
  5. I am getting the following information when I tried to debug it using
    gdb

    Program received signal SIGSEGV, Segmentation fault.
    0xfee32d98 in Tcl_utfToExternalDString

    Hope that gives more information.
     
    mariakvelasco, Jan 10, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.