unable to preload "rbconfig" in my irb session


S

Sandeep K.

I'm using Ruby 1.9.2 with Windows XP as host, I ran the command

irb --simple-prompt -rrbconfig

from the command line and got an error stating:
"E:/Ruby192/lib/ruby/site_ruby/1.9.1/rbreadline.rb:2043:in ``': No such
file or directory - stty -a (Errno::ENOENT)"

I've attached the complete error statement along with the post, please
help.


Thanks,
Sandeep
 
Ad

Advertisements

L

Luis Lavena

I'm using Ruby 1.9.2 with Windows XP as host, I ran the command

irb --simple-prompt -rrbconfig

from the command line and got an error stating:
"E:/Ruby192/lib/ruby/site_ruby/1.9.1/rbreadline.rb:2043:in ``': No such
file or directory - stty -a (Errno::ENOENT)"

I've attached the complete error statement along with the post, please
help.

Have you installed cygwin or cygwin installation bundled with E text
editor?

Are you using a normal command prompt?

What is the output of "SET TERM" ?

This has nothing to do with rbconfig but instead if the rb-readline
(pure-ruby readline) component that is bundled with Ruby 1.9.2-p0
provided by RubyInstaller.

The only way for stty be invoked is an incorrect environment variable
or bash/sh installation interfering with rb-readline.

I'm not able to recreate this:

C:\Users\Luis>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Users\Luis>set TERM
Environment variable TERM not defined

C:\Users\Luis>irb --simple-prompt -rrbconfig
Please provide that information and also open a bug report in rb-
readline issue tracker:

http://github.com/luislavena/rb-readline/issues
 
S

Sandeep K.

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "This has nothing to do with rbconfig but instead
if the rb-readline (pure-ruby readline) component that is bundled with
Ruby 1.9.2-p0
provided by RubyInstaller."

I do not exactly know what my problem is, I'm sorry to say this but
that's how my position is.


Thanks,
Sandeep.
 
S

Sandeep K.

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

Thanks,
Sandeep.
 
L

Luis Lavena

C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

Can you unset TERM?

I searched a bit looking for what could be considered a "nutc"
terminal option and nothing was found. Also dunno what could have set
that for you.

As I indicated in the ticket, please unset it:

SET TERM=

And try again.
I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

stty is a utility in *nix systems used to determine terminal
capabilities. Due the weird terminal setting you have, it is trying to
use stty which is not found.

I mentioned that a cygwin installation or something is interfering in
your system, which with the above that you provided proven correct.
 
H

Heesob Park

Hi,

2010/10/19 Luis Lavena said:
C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=3Dnutc
TERMCAP=3DE:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=3DE:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo

Can you unset TERM?

I searched a bit looking for what could be considered a "nutc"
terminal option and nothing was found. Also dunno what could have set
that for you.

As I indicated in the ticket, please unset it:

SET TERM=3D

And try again.
I'm using a normal command prompt and as I'm yet a beginner I do not
know what you mean by: "The only way for stty be invoked is an incorrect
environment variable or bash/sh installation interfering with
rb-readline."

stty is a utility in *nix systems used to determine terminal
capabilities. Due the weird terminal setting you have, it is trying to
use stty which is not found.

I mentioned that a cygwin installation or something is interfering in
your system, which with the above that you provided proven correct.
It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

rubyinstaller 1.9.2 version:

def no_terminal?
term =3D ENV["TERM"]
term.nil? || (term =3D=3D 'dumb') || (term =3D=3D 'cygwin' &&
RUBY_PLATFORM =3D~ /mswin|mingw/)
end

the latest github version:

def no_terminal?
term =3D ENV["TERM"]
term.nil? || (term =3D=3D 'dumb') || (RUBY_PLATFORM =3D~ /mswin|mingw/)
end

Regards,
Park Heesob



Regards,
Park Heesob
 
Ad

Advertisements

L

Luis Lavena

Hi,

2010/10/19 Luis Lavena <[email protected]>:






C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]
C:\Documents and Settings\Scarlet Pimpernel>set TERM
TERM=nutc
TERMCAP=E:\RATIONAL\RATION~1\NUTCROOT\etc\termcap
TERMINFO=E:\RATIONAL\RATION~1\NUTCROOT\usr\lib\terminfo
Can you unset TERM?
I searched a bit looking for what could be considered a "nutc"
terminal option and nothing was found. Also dunno what could have set
that for you.
As I indicated in the ticket, please unset it:
SET TERM=
And try again.
stty is a utility in *nix systems used to determine terminal
capabilities. Due the weird terminal setting you have, it is trying to
use stty which is not found.
I mentioned that a cygwin installation or something is interfering in
your system, which with the above that you provided proven correct.

It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

Park, do you consider current rb-readline is candidate for a release?

That way I can provide packages and installation instructions to
users.

Thank you
 
S

Sandeep K.

i have unset the TERM.

Now, when i execute the "set TERM" command, i get:

C:\Documents and Settings\Scarlet Pimpernel>set TERM
Environment variable TERM not defined

Please provide me with the correct environment variable settings.


Thanks,
Sandeep.
 
H

Heesob Park

Hi,

2010/10/19 Luis Lavena said:
Hi,

2010/10/19 Luis Lavena <[email protected]>:
C:\Documents and Settings\Scarlet Pimpernel>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]


It seems that the rbreadline.rb distributed with rubyinstaller 1.9.2
is not a bug fixed version.

Park, do you consider current rb-readline is candidate for a release?
Yes, at least, the current version is better than the installer
included version.
That way I can provide packages and installation instructions to
users.


Regards,
Park Heesob
 
S

Sandeep K.

does that mean, I should uninstall my current version of the ruby and
opt for an older one or is there a better way out?

Thanks,
Sandeep
 
Ad

Advertisements

Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top